~ubuntu-branches/ubuntu/natty/xpdf/natty

« back to all changes in this revision

Viewing changes to debian/patches-obselete/04_freetype-glyph.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Scott Kitterman
  • Date: 2010-10-17 00:53:43 UTC
  • mfrom: (6.1.6 sid)
  • Revision ID: james.westby@ubuntu.com-20101017005343-3arnd6x6b55ou9ue
Tags: 3.02-11ubuntu1
Add -lXt -lX11 to LIBS definition in debian/rules to fix FTBFS due to
indirect linking

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 04_freetype-glyph.dpatch by  <hamish@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Bug fix for Freetype glyph handling
6
 
 
7
 
@DPATCH@
8
 
 
9
 
--- xpdf-3.00.orig/splash/SplashFTFont.cc
10
 
+++ xpdf-3.00/splash/SplashFTFont.cc
11
 
@@ -238,6 +238,9 @@
12
 
   if (FT_Get_Glyph(slot, &glyph)) {
13
 
     return NULL;
14
 
   }
15
 
+  if (glyph->format != FT_GLYPH_FORMAT_OUTLINE) {
16
 
+    return NULL;
17
 
+  }
18
 
   path.path = new SplashPath();
19
 
   path.needClose = gFalse;
20
 
   FT_Outline_Decompose(&((FT_OutlineGlyph)glyph)->outline,