~ubuntu-branches/ubuntu/oneiric/awn-extras/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/04-fix-indicator-API-detection.patch

  • Committer: Bazaar Package Importer
  • Author(s): Julien Lavergne
  • Date: 2011-08-19 16:41:05 UTC
  • Revision ID: james.westby@ubuntu.com-20110819164105-1xwagz8ad88w4tq6
Tags: 0.4.1~bzr1507-0ubuntu2
* debian/patches:
 - 04-fix-indicator-API-detection.patch: Build against lastest indicators
   version (LP: #810817)
 - 03-libnotify07.patch: Transition to libnotify 0.7, thanks to Laurent
   Bigonville.
* debian/rules:
 - Use --with autoreconf, needed by 04-fix-indicator-API-detection.patch.
* debian/control:
 - Build-depends on dh-autoreconf.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Upstream changes introduced in version 0.4.1~bzr1507-0ubuntu2~ppa1
 
2
 This patch has been created by dpkg-source during the package build.
 
3
 Here's the last changelog entry, hopefully it gives details on why
 
4
 those changes were made:
 
5
 .
 
6
 awn-extras (0.4.1~bzr1507-0ubuntu2~ppa1) oneiric; urgency=low
 
7
 .
 
8
   *
 
9
 .
 
10
 The person named in the Author field signed this changelog entry.
 
11
Author: Julien Lavergne <gilir@ubuntu.com>
 
12
 
 
13
---
 
14
The information above should follow the Patch Tagging Guidelines, please
 
15
checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
 
16
are templates for supplementary fields that you might want to add:
 
17
 
 
18
Origin: <vendor|upstream|other>, <url of original patch>
 
19
Bug: <url in upstream bugtracker>
 
20
Bug-Debian: http://bugs.debian.org/<bugnumber>
 
21
Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
 
22
Forwarded: <no|not-needed|url proving that it has been forwarded>
 
23
Reviewed-By: <name and email of someone who approved the patch>
 
24
Last-Update: <YYYY-MM-DD>
 
25
 
 
26
Index: awn-extras-0.4.1~bzr1507/configure.ac
 
27
===================================================================
 
28
--- awn-extras-0.4.1~bzr1507.orig/configure.ac  2011-08-19 00:26:10.000000000 +0200
 
29
+++ awn-extras-0.4.1~bzr1507/configure.ac       2011-08-19 00:48:14.000000000 +0200
 
30
@@ -97,9 +97,11 @@
 
31
 
 
32
 if test "$with_indicator" != "no"; then
 
33
 # indicator-applet
 
34
-PKG_CHECK_MODULES(INDICATOR, [indicator >= 0.3])
 
35
-INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator`
 
36
-INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator`
 
37
+INDICATOR_REQUIRED_VERSION=0.3.0
 
38
+INDICATOR_PKG_NAME=indicator-0.4
 
39
+PKG_CHECK_MODULES(INDICATOR, [$INDICATOR_PKG_NAME >= $INDICATOR_REQUIRED_VERSION])
 
40
+INDICATORDIR=`$PKG_CONFIG --variable=indicatordir $INDICATOR_PKG_NAME`
 
41
+INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir $INDICATOR_PKG_NAME`
 
42
 AC_SUBST(INDICATORDIR)
 
43
 AC_SUBST(INDICATORICONSDIR)
 
44
 fi