~ubuntu-branches/ubuntu/oneiric/bluez/oneiric-proposed

« back to all changes in this revision

Viewing changes to debian/patches/02_disable_hal.patch

  • Committer: Bazaar Package Importer
  • Author(s): Mathieu Trudel-Lapierre
  • Date: 2011-07-28 16:47:35 UTC
  • mfrom: (1.1.34 upstream) (6.3.15 sid)
  • Revision ID: james.westby@ubuntu.com-20110728164735-f34luwrarv52mhlq
Tags: 4.95-0ubuntu1
* New upstream release.
* Resynchronize with Debian unstable, remaining changes:
  - debian/source_bluez.py, debian/bluez.install:
    + apport hook made by Baptiste Mille-Mathias.
  - debian/rules: don't use simple-patchsys.
  - debian/source/format: use source format 3.0.
  - debian/patches/pkg-config-install-paths.patch: install bluez-alsa plugin
    to the multiarch path, now that alsa-lib has transitioned.
* debian/patches/02_disable_hal.patch: refreshed.
* debian/patches/pkg-config-install-paths.patch: refreshed.
* debian/control, debian/rules: run autoreconf when building as required by
  pkg-config-install-paths.patch.

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
Updated by Nobuhiro Iwamatsu <iwamatsu@debian.org>
6
6
Debian BTS: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=599023
7
7
 
8
 
Index: bluez-4.94/audio/telephony-maemo5.c
 
8
Index: bluez-4.95/audio/telephony-maemo5.c
9
9
===================================================================
10
 
--- bluez-4.94.orig/audio/telephony-maemo5.c    2010-12-18 20:12:17.000000000 +0100
11
 
+++ bluez-4.94/audio/telephony-maemo5.c 2011-06-06 18:36:36.374465868 +0200
 
10
--- bluez-4.95.orig/audio/telephony-maemo5.c    2011-07-14 20:54:49.377762138 -0400
 
11
+++ bluez-4.95/audio/telephony-maemo5.c 2011-07-14 20:55:20.777762197 -0400
12
12
@@ -1385,6 +1385,7 @@
13
13
        return type == DBUS_TYPE_INVALID ? TRUE : FALSE;
14
14
 }
70
70
        return 0;
71
71
 }
72
72
 
73
 
Index: bluez-4.94/audio/telephony-maemo6.c
 
73
Index: bluez-4.95/audio/telephony-maemo6.c
74
74
===================================================================
75
 
--- bluez-4.94.orig/audio/telephony-maemo6.c    2011-04-25 11:44:21.000000000 +0200
76
 
+++ bluez-4.94/audio/telephony-maemo6.c 2011-06-06 18:36:36.378465868 +0200
77
 
@@ -1370,6 +1370,7 @@
 
75
--- bluez-4.95.orig/audio/telephony-maemo6.c    2011-07-14 20:54:49.377762138 -0400
 
76
+++ bluez-4.95/audio/telephony-maemo6.c 2011-07-14 20:55:44.647762245 -0400
 
77
@@ -1372,6 +1372,7 @@
78
78
        return type == DBUS_TYPE_INVALID ? TRUE : FALSE;
79
79
 }
80
80
 
82
82
 static void hal_battery_level_reply(DBusPendingCall *call, void *user_data)
83
83
 {
84
84
        DBusError err;
85
 
@@ -1485,6 +1486,7 @@
 
85
@@ -1487,6 +1488,7 @@
86
86
                dbus_message_iter_next(&array);
87
87
        }
88
88
 }
89
89
+#endif /* Disable hal */
90
90
 
91
 
 static void csd_call_free(struct csd_call *call)
 
91
 static void csd_call_free(void *data)
92
92
 {
93
 
@@ -1835,9 +1837,11 @@
 
93
@@ -1839,9 +1841,11 @@
94
94
        else if (dbus_message_is_signal(msg, CSD_CSNET_SIGNAL,
95
95
                                "SignalBarsChanged"))
96
96
                handle_signal_bars_changed(msg);
102
102
        else if (dbus_message_is_signal(msg, SSC_DBUS_IFACE,
103
103
                                                "modem_state_changed_ind"))
104
104
                handle_modem_state(msg);
105
 
@@ -1856,6 +1860,7 @@
 
105
@@ -1860,6 +1864,7 @@
106
106
        watches = g_slist_prepend(watches, GUINT_TO_POINTER(watch));
107
107
 }
108
108
 
110
110
 static void hal_find_device_reply(DBusPendingCall *call, void *user_data)
111
111
 {
112
112
        DBusError err;
113
 
@@ -1906,6 +1911,8 @@
 
113
@@ -1910,6 +1915,8 @@
114
114
        remove_pending(call);
115
115
 }
116
116
 
119
119
 int telephony_init(void)
120
120
 {
121
121
        const char *battery_cap = "battery";
122
 
@@ -1945,6 +1952,7 @@
 
122
@@ -1949,6 +1956,7 @@
123
123
 
124
124
        telephony_ready_ind(features, maemo_indicators, BTRH_NOT_SUPPORTED,
125
125
                                                                chld_str);
127
127
        if (send_method_call("org.freedesktop.Hal",
128
128
                                "/org/freedesktop/Hal/Manager",
129
129
                                "org.freedesktop.Hal.Manager",
130
 
@@ -1953,7 +1961,7 @@
 
130
@@ -1957,7 +1965,7 @@
131
131
                                DBUS_TYPE_STRING, &battery_cap,
132
132
                                DBUS_TYPE_INVALID) < 0)
133
133
                error("Unable to send HAL method call");
134
134
-
135
 
+#endif 
 
135
+#endif
136
136
        return 0;
137
137
 }
138
138
 
139
 
Index: bluez-4.94/audio/telephony-ofono.c
 
139
Index: bluez-4.95/audio/telephony-ofono.c
140
140
===================================================================
141
 
--- bluez-4.94.orig/audio/telephony-ofono.c     2011-05-31 04:39:53.000000000 +0200
142
 
+++ bluez-4.94/audio/telephony-ofono.c  2011-06-06 18:36:36.378465868 +0200
143
 
@@ -1350,6 +1350,7 @@
 
141
--- bluez-4.95.orig/audio/telephony-ofono.c     2011-07-14 20:54:49.367762136 -0400
 
142
+++ bluez-4.95/audio/telephony-ofono.c  2011-07-14 20:55:20.787762196 -0400
 
143
@@ -1341,6 +1341,7 @@
144
144
        return TRUE;
145
145
 }
146
146
 
148
148
 static void hal_battery_level_reply(DBusPendingCall *call, void *user_data)
149
149
 {
150
150
        DBusMessage *reply;
151
 
@@ -1533,6 +1534,7 @@
 
151
@@ -1524,6 +1525,7 @@
152
152
        dbus_message_unref(reply);
153
153
        remove_pending(call);
154
154
 }
156
156
 
157
157
 static void handle_service_connect(DBusConnection *conn, void *user_data)
158
158
 {
159
 
@@ -1581,6 +1583,7 @@
 
159
@@ -1579,6 +1581,7 @@
160
160
 
161
161
        watches = g_slist_prepend(watches, GUINT_TO_POINTER(watch));
162
162
 
164
164
        ret = send_method_call("org.freedesktop.Hal",
165
165
                                "/org/freedesktop/Hal/Manager",
166
166
                                "org.freedesktop.Hal.Manager",
167
 
@@ -1590,7 +1593,7 @@
 
167
@@ -1588,7 +1591,7 @@
168
168
                                DBUS_TYPE_INVALID);
169
169
        if (ret < 0)
170
170
                return ret;
172
172
+#endif
173
173
        DBG("telephony_init() successfully");
174
174
 
175
 
        return ret;
 
175
        telephony_ready_ind(features, ofono_indicators, BTRH_NOT_SUPPORTED,