~ubuntu-branches/ubuntu/oneiric/denemo/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/use_libsmf_of_os.diff

  • Committer: Bazaar Package Importer
  • Author(s): Alessio Treglia
  • Date: 2010-10-27 08:00:18 UTC
  • mfrom: (1.2.7 upstream) (3.1.5 sid)
  • Revision ID: james.westby@ubuntu.com-20101027080018-suwj9ozy99d0a5a2
Tags: 0.8.16-1ubuntu1
* Merge with Debian testing (LP: #638617), Ubuntu remaining changes:
  - debian/patches/ubuntuize.diff:
    + Provide a Ubuntu-specific customization.
  - debian/patches/fix_desktop.diff:
    + Add missing trailing semicolon.
    + Add MIME types.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Denemo include a convenience copy of libsmf
 
2
 This patch ensures that the Debian package of denemo
 
3
 reference to the debian package of libsmf and that
 
4
 the convenience copy is not used.
 
5
 See: Debian Policy Manual section 4.13 (Convenience
 
6
 copies of code) for details.
 
7
 
 
8
Author: Josue Abarca <jmaslibre@debian.org.gt>
 
9
Forwarded: not-needed
 
10
Last-Update: 2010-04-09
 
11
 
 
12
 
 
13
--- a/configure.in
 
14
+++ b/configure.in
 
15
@@ -30,6 +30,10 @@
 
16
 CFLAGS="$CFLAGS $GTK2_CFLAGS"
 
17
 LIBS="$GTK2_LIBS"
 
18
 
 
19
+PKG_CHECK_MODULES(LIBSMF, smf >= 1.3)
 
20
+LIBS="$LIBS $LIBSMF_LIBS"
 
21
+CFLAGS="$CFLAGS $LIBSMF_CFLAGS"
 
22
+
 
23
 PKG_CHECK_MODULES(GUILE, guile-1.8 >= 1.8)
 
24
 LIBS="$LIBS $GUILE_LIBS"
 
25
 CFLAGS="$CFLAGS $GUILE_CFLAGS"
 
26
--- a/src/Makefile.am
 
27
+++ b/src/Makefile.am
 
28
@@ -52,7 +52,6 @@
 
29
 
 
30
 localedir = $(datadir)/locale
 
31
 INCLUDES = -I../intl -I$(top_srcdir)/intl -I$(top_srcdir)/include \
 
32
--I$(top_srcdir)/libsmf \
 
33
 -I$(top_srcdir)/pixmaps \
 
34
 -DLOCALEDIR=\"$(localedir)\" \
 
35
 -DSYSCONFDIR=\"$(sysconfdir)/\" \
 
36
@@ -61,7 +60,7 @@
 
37
 -DPKGNAME=\"denemo\" 
 
38
 
 
39
 
 
40
-denemo_LDADD = $(INTLLIBS) ../libsmf/libsmf.a 
 
41
+denemo_LDADD = $(INTLLIBS)
 
42
 AM_CPPFLAGS = $(BINRELOC_CFLAGS)
 
43
 
 
44
 
 
45
--- a/Makefile.am
 
46
+++ b/Makefile.am
 
47
@@ -1,4 +1,4 @@
 
48
-SUBDIRS = libsmf m4 doc actions pixmaps po src \
 
49
+SUBDIRS = m4 doc actions pixmaps po src \
 
50
          fonts soundfonts bin 
 
51
 
 
52