~ubuntu-branches/ubuntu/oneiric/exim4/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/40_dkimnotinpaniclog.diff

  • Committer: Bazaar Package Importer
  • Author(s): Artur Rona
  • Date: 2010-12-28 22:20:17 UTC
  • mfrom: (2.3.4 experimental)
  • Revision ID: james.westby@ubuntu.com-20101228222017-r6vg4eqlqy2fk4ul
Tags: 4.73~rc1-1ubuntu1
* Merge from debian unstable.  Remaining changes: (LP: #697934)
  - debian/patches/71_exiq_grep_error_on_messages_without_size.patch:
    + Improve handling of broken messages when "exim4 -bp" (mailq)
      reports lines without size info.
  - debian/control: Don't declare a Provides: default-mta; in Ubuntu,
    we want postfix to be the default.
  - debian/{control,rules}: Add and enable hardened build for PIE.
    (Closes: #542726)
* Drop B-D on libmysqlclient15-dev, resolved in Debian.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From: John Jetmore <jj33@pobox.com>
2
 
Date: Sat, 12 Jun 2010 13:54:38 +0000 (+0000)
3
 
Subject: iaddressing bug 966 and my own concerns, stop sending non-panic error to panic log... 
4
 
X-Git-Url: http://git.exim.org/exim.git/commitdiff_plain/d4f333f76f0904e18506a7e1964b33b3d39175c1
5
 
Bug-Debian: http://bugs.debian.org/567876
6
 
 
7
 
iaddressing bug 966 and my own concerns, stop sending non-panic error to panic log in dkim.c
8
 
---
9
 
 
10
 
diff -NurBbp a/src/dkim.c b/src/dkim.c
11
 
--- a/src/dkim.c        2010-05-29 21:16:50.000000000 +0200
12
 
+++ b/src/dkim.c        2010-08-28 09:52:19.000000000 +0200
13
 
@@ -92,7 +92,7 @@ void dkim_exim_verify_finish(void) {
14
 
      means there was a processing error somewhere along the way.
15
 
      Log the incident and disable futher verification. */
16
 
   if (!dkim_collect_input) {
17
 
-    log_write(0, LOG_MAIN|LOG_PANIC, "DKIM: Error while running this message through validation, disabling signature verification.");
18
 
+    log_write(0, LOG_MAIN, "DKIM: Error while running this message through validation, disabling signature verification.");
19
 
     dkim_disable_verify = TRUE;
20
 
     return;
21
 
   }