~ubuntu-branches/ubuntu/oneiric/glew/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/debian-changes-1.5.2-0ubuntu1

  • Committer: Bazaar Package Importer
  • Author(s): Joost Yervante Damad
  • Date: 2011-01-11 11:20:03 UTC
  • mfrom: (1.1.8 upstream) (2.1.11 experimental)
  • Revision ID: james.westby@ubuntu.com-20110111112003-j2v6ob84i3h66z0z
Tags: 1.5.7-1
* New upstream release
* back to source format 1.0

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- glew-1.5.2.orig/Makefile
2
 
+++ glew-1.5.2/Makefile
3
 
@@ -43,6 +43,8 @@ endif
4
 
 GLEW_DEST ?= /usr
5
 
 BINDIR ?= $(GLEW_DEST)/bin
6
 
 LIBDIR ?= $(GLEW_DEST)/lib
7
 
+PKGCFGDIR ?= $(LIBDIR)/pkgconfig
8
 
+PKGCFGFILE ?= glew.pc
9
 
 INCDIR ?= $(GLEW_DEST)/include/GL
10
 
 SHARED_OBJ_EXT ?= o
11
 
 TARDIR = ../glew-$(GLEW_VERSION)
12
 
@@ -121,7 +123,7 @@ ifeq ($(patsubst mingw%,mingw,$(SYSTEM))
13
 
        $(STRIP) -x lib/$(LIB.SHARED)
14
 
        $(INSTALL) -m 0644 lib/$(LIB.SHARED) $(BINDIR)/
15
 
 else
16
 
-       $(STRIP) -x lib/$(LIB.SHARED)
17
 
+#      $(STRIP) -x lib/$(LIB.SHARED)
18
 
        $(INSTALL) -m 0644 lib/$(LIB.SHARED) $(LIBDIR)/
19
 
        $(LN) $(LIB.SHARED) $(LIBDIR)/$(LIB.SONAME)
20
 
 endif
21
 
@@ -132,12 +134,26 @@ endif
22
 
 ifeq ($(patsubst mingw%,mingw,$(SYSTEM)), mingw)
23
 
        $(INSTALL) -m 0644 lib/$(LIB.DEVLNK) $(LIBDIR)/
24
 
 else
25
 
-       $(STRIP) -x lib/$(LIB.STATIC)
26
 
+#      $(STRIP) -x lib/$(LIB.STATIC)
27
 
        $(INSTALL) -m 0644 lib/$(LIB.STATIC) $(LIBDIR)/
28
 
        $(LN) $(LIB.SHARED) $(LIBDIR)/$(LIB.DEVLNK)
29
 
 endif
30
 
 # utilities
31
 
-       $(INSTALL) -s -m 0755 bin/$(GLEWINFO.BIN) bin/$(VISUALINFO.BIN) $(BINDIR)/
32
 
+       -$(INSTALL) -m 0755 bin/$(GLEWINFO.BIN) bin/$(VISUALINFO.BIN) $(BINDIR)/
33
 
+
34
 
+pkgconfig:
35
 
+       $(INSTALL) -d -m 0755 $(PKGCFGDIR)
36
 
+       echo prefix=$(TRG_DEST) > $(PKGCFGFILE)
37
 
+       echo exec_prefix=\$$\{prefix\} >> $(PKGCFGFILE)
38
 
+       echo libdir=\$$\{prefix\}/lib >> $(PKGCFGFILE)
39
 
+       echo includedir=\$$\{prefix\}/include >> $(PKGCFGFILE)
40
 
+       echo >> $(PKGCFGFILE)
41
 
+       echo Name: The OpenGL Extension Wrangler Library >> $(PKGCFGFILE)
42
 
+       echo Description: cross-platform C/C++ extension loading library >> $(PKGCFGFILE)
43
 
+       echo Version: $(GLEW_VERSION) >> $(PKGCFGFILE)
44
 
+       echo Libs: -L\$$\{libdir\} -l$(NAME) >> $(PKGCFGFILE)
45
 
+       echo Cflags: -I\$$\{includedir\} >> $(PKGCFGFILE)
46
 
+       $(INSTALL) -m 0644 $(PKGCFGFILE) $(PKGCFGDIR)/
47
 
 
48
 
 uninstall:
49
 
        $(RM) $(INCDIR)/wglew.h
50
 
--- glew-1.5.2.orig/config/Makefile.linux
51
 
+++ glew-1.5.2/config/Makefile.linux
52
 
@@ -3,21 +3,16 @@ CC = cc
53
 
 LD = cc
54
 
 ifneq (undefined, $(origin GLEW_MX))
55
 
 CFLAGS.EXTRA = -DGLEW_MX
56
 
+NAME_SUF=mx
57
 
 endif
58
 
 PICFLAG = -fPIC
59
 
-LDFLAGS.SO = -shared -Wl,-soname=$(LIB.SONAME)
60
 
+LDFLAGS.SO = -shared -Wl,-soname=$(LIB.SONAME) -Wl,-Bsymbolic-functions
61
 
 M_ARCH ?= $(shell uname -m)
62
 
-ifeq (x86_64,${M_ARCH})
63
 
-LDFLAGS.EXTRA = -L/usr/X11R6/lib64
64
 
-LIBDIR = $(GLEW_DEST)/lib64
65
 
-else
66
 
-LDFLAGS.EXTRA = -L/usr/X11R6/lib
67
 
 LIBDIR = $(GLEW_DEST)/lib
68
 
-endif
69
 
 LDFLAGS.GL = -lXmu -lXi -lGLU -lGL -lXext -lX11
70
 
 LDFLAGS.STATIC = -Wl,-Bstatic
71
 
 LDFLAGS.DYNAMIC = -Wl,-Bdynamic
72
 
-NAME = GLEW
73
 
+NAME = GLEW$(NAME_SUF)
74
 
 WARN = -Wall -W
75
 
 POPT = -O2
76
 
 BIN.SUFFIX =
77
 
--- glew-1.5.2.orig/config/Makefile.kfreebsd
78
 
+++ glew-1.5.2/config/Makefile.kfreebsd
79
 
@@ -3,14 +3,16 @@ CC = cc
80
 
 LD = cc
81
 
 ifneq (undefined, $(origin GLEW_MX))
82
 
 CFLAGS.EXTRA = -DGLEW_MX
83
 
+NAME_SUF=mx
84
 
 endif
85
 
 PICFLAG = -fPIC
86
 
-LDFLAGS.SO = -shared -Wl,-soname $(LIB.SONAME)
87
 
-LDFLAGS.EXTRA = -L/usr/X11R6/lib
88
 
+LDFLAGS.SO = -shared -Wl,-soname=$(LIB.SONAME) -Wl,-Bsymbolic-functions
89
 
+M_ARCH ?= $(shell uname -m)
90
 
+LIBDIR = $(GLEW_DEST)/lib
91
 
 LDFLAGS.GL = -lXmu -lXi -lGLU -lGL -lXext -lX11
92
 
 LDFLAGS.STATIC = -Wl,-Bstatic
93
 
 LDFLAGS.DYNAMIC = -Wl,-Bdynamic
94
 
-NAME = GLEW
95
 
+NAME = GLEW$(NAME_SUF)
96
 
 WARN = -Wall -W
97
 
 POPT = -O2
98
 
 BIN.SUFFIX =
99
 
--- glew-1.5.2.orig/config/config.guess
100
 
+++ glew-1.5.2/config/config.guess
101
 
@@ -1,9 +1,10 @@
102
 
 #! /bin/sh
103
 
 # Attempt to guess a canonical system name.
104
 
 #   Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
105
 
-#   2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
106
 
+#   2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009
107
 
+#   Free Software Foundation, Inc.
108
 
 
109
 
-timestamp='2006-02-23'
110
 
+timestamp='2009-06-10'
111
 
 
112
 
 # This file is free software; you can redistribute it and/or modify it
113
 
 # under the terms of the GNU General Public License as published by
114
 
@@ -55,8 +56,8 @@ version="\
115
 
 GNU config.guess ($timestamp)
116
 
 
117
 
 Originally written by Per Bothner.
118
 
-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
119
 
-Free Software Foundation, Inc.
120
 
+Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001,
121
 
+2002, 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
122
 
 
123
 
 This is free software; see the source for copying conditions.  There is NO
124
 
 warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE."
125
 
@@ -160,6 +161,7 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:$
126
 
            arm*) machine=arm-unknown ;;
127
 
            sh3el) machine=shl-unknown ;;
128
 
            sh3eb) machine=sh-unknown ;;
129
 
+           sh5el) machine=sh5le-unknown ;;
130
 
            *) machine=${UNAME_MACHINE_ARCH}-unknown ;;
131
 
        esac
132
 
        # The Operating System including object format, if it has switched
133
 
@@ -168,7 +170,7 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:$
134
 
            arm*|i386|m68k|ns32k|sh3*|sparc|vax)
135
 
                eval $set_cc_for_build
136
 
                if echo __ELF__ | $CC_FOR_BUILD -E - 2>/dev/null \
137
 
-                       | grep __ELF__ >/dev/null
138
 
+                       | grep -q __ELF__
139
 
                then
140
 
                    # Once all utilities can be ECOFF (netbsdecoff) or a.out (netbsdaout).
141
 
                    # Return netbsd for either.  FIX?
142
 
@@ -210,7 +212,7 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:$
143
 
        echo ${UNAME_MACHINE}-unknown-solidbsd${UNAME_RELEASE}
144
 
        exit ;;
145
 
     macppc:MirBSD:*:*)
146
 
-       echo powerppc-unknown-mirbsd${UNAME_RELEASE}
147
 
+       echo powerpc-unknown-mirbsd${UNAME_RELEASE}
148
 
        exit ;;
149
 
     *:MirBSD:*:*)
150
 
        echo ${UNAME_MACHINE}-unknown-mirbsd${UNAME_RELEASE}
151
 
@@ -322,14 +324,30 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:$
152
 
        case `/usr/bin/uname -p` in
153
 
            sparc) echo sparc-icl-nx7; exit ;;
154
 
        esac ;;
155
 
+    s390x:SunOS:*:*)
156
 
+       echo ${UNAME_MACHINE}-ibm-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
157
 
+       exit ;;
158
 
     sun4H:SunOS:5.*:*)
159
 
        echo sparc-hal-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
160
 
        exit ;;
161
 
     sun4*:SunOS:5.*:* | tadpole*:SunOS:5.*:*)
162
 
        echo sparc-sun-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
163
 
        exit ;;
164
 
-    i86pc:SunOS:5.*:*)
165
 
-       echo i386-pc-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
166
 
+    i86pc:SunOS:5.*:* | i86xen:SunOS:5.*:*)
167
 
+       eval $set_cc_for_build
168
 
+       SUN_ARCH="i386"
169
 
+       # If there is a compiler, see if it is configured for 64-bit objects.
170
 
+       # Note that the Sun cc does not turn __LP64__ into 1 like gcc does.
171
 
+       # This test works for both compilers.
172
 
+       if [ "$CC_FOR_BUILD" != 'no_compiler_found' ]; then
173
 
+           if (echo '#ifdef __amd64'; echo IS_64BIT_ARCH; echo '#endif') | \
174
 
+               (CCOPTS= $CC_FOR_BUILD -E - 2>/dev/null) | \
175
 
+               grep IS_64BIT_ARCH >/dev/null
176
 
+           then
177
 
+               SUN_ARCH="x86_64"
178
 
+           fi
179
 
+       fi
180
 
+       echo ${SUN_ARCH}-pc-solaris2`echo ${UNAME_RELEASE}|sed -e 's/[^.]*//'`
181
 
        exit ;;
182
 
     sun4*:SunOS:6*:*)
183
 
        # According to config.sub, this is the proper way to canonicalize
184
 
@@ -530,7 +548,7 @@ EOF
185
 
                echo rs6000-ibm-aix3.2
186
 
        fi
187
 
        exit ;;
188
 
-    *:AIX:*:[45])
189
 
+    *:AIX:*:[456])
190
 
        IBM_CPU_ID=`/usr/sbin/lsdev -C -c processor -S available | sed 1q | awk '{ print $1 }'`
191
 
        if /usr/sbin/lsattr -El ${IBM_CPU_ID} | grep ' POWER' >/dev/null 2>&1; then
192
 
                IBM_ARCH=rs6000
193
 
@@ -638,7 +656,7 @@ EOF
194
 
            # => hppa64-hp-hpux11.23
195
 
 
196
 
            if echo __LP64__ | (CCOPTS= $CC_FOR_BUILD -E - 2>/dev/null) |
197
 
-               grep __LP64__ >/dev/null
198
 
+               grep -q __LP64__
199
 
            then
200
 
                HP_ARCH="hppa2.0w"
201
 
            else
202
 
@@ -770,6 +788,8 @@ EOF
203
 
        case ${UNAME_MACHINE} in
204
 
            pc98)
205
 
                echo i386-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
206
 
+           amd64)
207
 
+               echo x86_64-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
208
 
            *)
209
 
                echo ${UNAME_MACHINE}-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
210
 
        esac
211
 
@@ -777,10 +797,7 @@ EOF
212
 
     i*:CYGWIN*:*)
213
 
        echo ${UNAME_MACHINE}-pc-cygwin
214
 
        exit ;;
215
 
-    i*:MINGW*:*)
216
 
-       echo ${UNAME_MACHINE}-pc-mingw32
217
 
-       exit ;;
218
 
-    i*:MSYS_NT-*:*:*)
219
 
+    *:MINGW*:*)
220
 
        echo ${UNAME_MACHINE}-pc-mingw32
221
 
        exit ;;
222
 
     i*:windows32*:*)
223
 
@@ -790,15 +807,24 @@ EOF
224
 
     i*:PW*:*)
225
 
        echo ${UNAME_MACHINE}-pc-pw32
226
 
        exit ;;
227
 
-    x86:Interix*:[345]*)
228
 
-       echo i586-pc-interix${UNAME_RELEASE}
229
 
-       exit ;;
230
 
-    EM64T:Interix*:[345]*)
231
 
-       echo x86_64-unknown-interix${UNAME_RELEASE}
232
 
-       exit ;;
233
 
+    *:Interix*:[3456]*)
234
 
+       case ${UNAME_MACHINE} in
235
 
+           x86)
236
 
+               echo i586-pc-interix${UNAME_RELEASE}
237
 
+               exit ;;
238
 
+           EM64T | authenticamd | genuineintel)
239
 
+               echo x86_64-unknown-interix${UNAME_RELEASE}
240
 
+               exit ;;
241
 
+           IA64)
242
 
+               echo ia64-unknown-interix${UNAME_RELEASE}
243
 
+               exit ;;
244
 
+       esac ;;
245
 
     [345]86:Windows_95:* | [345]86:Windows_98:* | [345]86:Windows_NT:*)
246
 
        echo i${UNAME_MACHINE}-pc-mks
247
 
        exit ;;
248
 
+    8664:Windows_NT:*)
249
 
+       echo x86_64-pc-mks
250
 
+       exit ;;
251
 
     i*:Windows_NT*:* | Pentium*:Windows_NT*:*)
252
 
        # How do we know it's Interix rather than the generic POSIX subsystem?
253
 
        # It also conflicts with pre-2.0 versions of AT&T UWIN. Should we
254
 
@@ -829,6 +855,16 @@ EOF
255
 
        echo ${UNAME_MACHINE}-pc-minix
256
 
        exit ;;
257
 
     arm*:Linux:*:*)
258
 
+       eval $set_cc_for_build
259
 
+       if echo __ARM_EABI__ | $CC_FOR_BUILD -E - 2>/dev/null \
260
 
+           | grep -q __ARM_EABI__
261
 
+       then
262
 
+           echo ${UNAME_MACHINE}-unknown-linux-gnu
263
 
+       else
264
 
+           echo ${UNAME_MACHINE}-unknown-linux-gnueabi
265
 
+       fi
266
 
+       exit ;;
267
 
+    avr32*:Linux:*:*)
268
 
        echo ${UNAME_MACHINE}-unknown-linux-gnu
269
 
        exit ;;
270
 
     cris:Linux:*:*)
271
 
@@ -849,40 +885,17 @@ EOF
272
 
     m68*:Linux:*:*)
273
 
        echo ${UNAME_MACHINE}-unknown-linux-gnu
274
 
        exit ;;
275
 
-    mips:Linux:*:*)
276
 
+    mips:Linux:*:* | mips64:Linux:*:*)
277
 
        eval $set_cc_for_build
278
 
        sed 's/^        //' << EOF >$dummy.c
279
 
        #undef CPU
280
 
-       #undef mips
281
 
-       #undef mipsel
282
 
+       #undef ${UNAME_MACHINE}
283
 
+       #undef ${UNAME_MACHINE}el
284
 
        #if defined(__MIPSEL__) || defined(__MIPSEL) || defined(_MIPSEL) || defined(MIPSEL)
285
 
-       CPU=mipsel
286
 
+       CPU=${UNAME_MACHINE}el
287
 
        #else
288
 
        #if defined(__MIPSEB__) || defined(__MIPSEB) || defined(_MIPSEB) || defined(MIPSEB)
289
 
-       CPU=mips
290
 
-       #else
291
 
-       CPU=
292
 
-       #endif
293
 
-       #endif
294
 
-EOF
295
 
-       eval "`$CC_FOR_BUILD -E $dummy.c 2>/dev/null | sed -n '
296
 
-           /^CPU/{
297
 
-               s: ::g
298
 
-               p
299
 
-           }'`"
300
 
-       test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
301
 
-       ;;
302
 
-    mips64:Linux:*:*)
303
 
-       eval $set_cc_for_build
304
 
-       sed 's/^        //' << EOF >$dummy.c
305
 
-       #undef CPU
306
 
-       #undef mips64
307
 
-       #undef mips64el
308
 
-       #if defined(__MIPSEL__) || defined(__MIPSEL) || defined(_MIPSEL) || defined(MIPSEL)
309
 
-       CPU=mips64el
310
 
-       #else
311
 
-       #if defined(__MIPSEB__) || defined(__MIPSEB) || defined(_MIPSEB) || defined(MIPSEB)
312
 
-       CPU=mips64
313
 
+       CPU=${UNAME_MACHINE}
314
 
        #else
315
 
        CPU=
316
 
        #endif
317
 
@@ -914,10 +927,13 @@ EOF
318
 
          EV67)  UNAME_MACHINE=alphaev67 ;;
319
 
          EV68*) UNAME_MACHINE=alphaev68 ;;
320
 
         esac
321
 
-       objdump --private-headers /bin/sh | grep ld.so.1 >/dev/null
322
 
+       objdump --private-headers /bin/sh | grep -q ld.so.1
323
 
        if test "$?" = 0 ; then LIBC="libc1" ; else LIBC="" ; fi
324
 
        echo ${UNAME_MACHINE}-unknown-linux-gnu${LIBC}
325
 
        exit ;;
326
 
+    padre:Linux:*:*)
327
 
+       echo sparc-unknown-linux-gnu
328
 
+       exit ;;
329
 
     parisc:Linux:*:* | hppa:Linux:*:*)
330
 
        # Look for CPU level
331
 
        case `grep '^cpu[^a-z]*:' /proc/cpuinfo 2>/dev/null | cut -d' ' -f2` in
332
 
@@ -947,6 +963,9 @@ EOF
333
 
     x86_64:Linux:*:*)
334
 
        echo x86_64-unknown-linux-gnu
335
 
        exit ;;
336
 
+    xtensa*:Linux:*:*)
337
 
+       echo ${UNAME_MACHINE}-unknown-linux-gnu
338
 
+       exit ;;
339
 
     i*86:Linux:*:*)
340
 
        # The BFD linker knows what the default object file format is, so
341
 
        # first see if it will tell us. cd to the root directory to prevent
342
 
@@ -962,17 +981,6 @@ EOF
343
 
          elf32-i386)
344
 
                TENTATIVE="${UNAME_MACHINE}-pc-linux-gnu"
345
 
                ;;
346
 
-         a.out-i386-linux)
347
 
-               echo "${UNAME_MACHINE}-pc-linux-gnuaout"
348
 
-               exit ;;
349
 
-         coff-i386)
350
 
-               echo "${UNAME_MACHINE}-pc-linux-gnucoff"
351
 
-               exit ;;
352
 
-         "")
353
 
-               # Either a pre-BFD a.out linker (linux-gnuoldld) or
354
 
-               # one that does not give us useful --help.
355
 
-               echo "${UNAME_MACHINE}-pc-linux-gnuoldld"
356
 
-               exit ;;
357
 
        esac
358
 
        # Determine whether the default compiler is a.out or elf
359
 
        eval $set_cc_for_build
360
 
@@ -989,7 +997,7 @@ EOF
361
 
        LIBC=gnulibc1
362
 
        # endif
363
 
        #else
364
 
-       #if defined(__INTEL_COMPILER) || defined(__PGI) || defined(__sun)
365
 
+       #if defined(__INTEL_COMPILER) || defined(__PGI) || defined(__SUNPRO_C) || defined(__SUNPRO_CC)
366
 
        LIBC=gnu
367
 
        #else
368
 
        LIBC=gnuaout
369
 
@@ -1038,7 +1046,7 @@ EOF
370
 
     i*86:syllable:*:*)
371
 
        echo ${UNAME_MACHINE}-pc-syllable
372
 
        exit ;;
373
 
-    i*86:LynxOS:2.*:* | i*86:LynxOS:3.[01]*:* | i*86:LynxOS:4.0*:*)
374
 
+    i*86:LynxOS:2.*:* | i*86:LynxOS:3.[01]*:* | i*86:LynxOS:4.[02]*:*)
375
 
        echo i386-unknown-lynxos${UNAME_RELEASE}
376
 
        exit ;;
377
 
     i*86:*DOS:*:*)
378
 
@@ -1082,8 +1090,11 @@ EOF
379
 
     pc:*:*:*)
380
 
        # Left here for compatibility:
381
 
         # uname -m prints for DJGPP always 'pc', but it prints nothing about
382
 
-        # the processor, so we play safe by assuming i386.
383
 
-       echo i386-pc-msdosdjgpp
384
 
+        # the processor, so we play safe by assuming i586.
385
 
+       # Note: whatever this is, it MUST be the same as what config.sub
386
 
+       # prints for the "djgpp" host, or else GDB configury will decide that
387
 
+       # this is a cross-build.
388
 
+       echo i586-pc-msdosdjgpp
389
 
         exit ;;
390
 
     Intel:Mach:3*:*)
391
 
        echo i386-pc-mach3
392
 
@@ -1121,6 +1132,16 @@ EOF
393
 
     3[34]??:*:4.0:* | 3[34]??,*:*:4.0:*)
394
 
         /bin/uname -p 2>/dev/null | grep 86 >/dev/null \
395
 
           && { echo i486-ncr-sysv4; exit; } ;;
396
 
+    NCR*:*:4.2:* | MPRAS*:*:4.2:*)
397
 
+       OS_REL='.3'
398
 
+       test -r /etc/.relid \
399
 
+           && OS_REL=.`sed -n 's/[^ ]* [^ ]* \([0-9][0-9]\).*/\1/p' < /etc/.relid`
400
 
+       /bin/uname -p 2>/dev/null | grep 86 >/dev/null \
401
 
+           && { echo i486-ncr-sysv4.3${OS_REL}; exit; }
402
 
+       /bin/uname -p 2>/dev/null | /bin/grep entium >/dev/null \
403
 
+           && { echo i586-ncr-sysv4.3${OS_REL}; exit; }
404
 
+       /bin/uname -p 2>/dev/null | /bin/grep pteron >/dev/null \
405
 
+           && { echo i586-ncr-sysv4.3${OS_REL}; exit; } ;;
406
 
     m68*:LynxOS:2.*:* | m68*:LynxOS:3.0*:*)
407
 
        echo m68k-unknown-lynxos${UNAME_RELEASE}
408
 
        exit ;;
409
 
@@ -1133,7 +1154,7 @@ EOF
410
 
     rs6000:LynxOS:2.*:*)
411
 
        echo rs6000-unknown-lynxos${UNAME_RELEASE}
412
 
        exit ;;
413
 
-    PowerPC:LynxOS:2.*:* | PowerPC:LynxOS:3.[01]*:* | PowerPC:LynxOS:4.0*:*)
414
 
+    PowerPC:LynxOS:2.*:* | PowerPC:LynxOS:3.[01]*:* | PowerPC:LynxOS:4.[02]*:*)
415
 
        echo powerpc-unknown-lynxos${UNAME_RELEASE}
416
 
        exit ;;
417
 
     SM[BE]S:UNIX_SV:*:*)
418
 
@@ -1196,6 +1217,9 @@ EOF
419
 
     BePC:BeOS:*:*)     # BeOS running on Intel PC compatible.
420
 
        echo i586-pc-beos
421
 
        exit ;;
422
 
+    BePC:Haiku:*:*)    # Haiku running on Intel PC compatible.
423
 
+       echo i586-pc-haiku
424
 
+       exit ;;
425
 
     SX-4:SUPER-UX:*:*)
426
 
        echo sx4-nec-superux${UNAME_RELEASE}
427
 
        exit ;;
428
 
@@ -1205,6 +1229,15 @@ EOF
429
 
     SX-6:SUPER-UX:*:*)
430
 
        echo sx6-nec-superux${UNAME_RELEASE}
431
 
        exit ;;
432
 
+    SX-7:SUPER-UX:*:*)
433
 
+       echo sx7-nec-superux${UNAME_RELEASE}
434
 
+       exit ;;
435
 
+    SX-8:SUPER-UX:*:*)
436
 
+       echo sx8-nec-superux${UNAME_RELEASE}
437
 
+       exit ;;
438
 
+    SX-8R:SUPER-UX:*:*)
439
 
+       echo sx8r-nec-superux${UNAME_RELEASE}
440
 
+       exit ;;
441
 
     Power*:Rhapsody:*:*)
442
 
        echo powerpc-apple-rhapsody${UNAME_RELEASE}
443
 
        exit ;;
444
 
@@ -1295,6 +1328,9 @@ EOF
445
 
     i*86:rdos:*:*)
446
 
        echo ${UNAME_MACHINE}-pc-rdos
447
 
        exit ;;
448
 
+    i*86:AROS:*:*)
449
 
+       echo ${UNAME_MACHINE}-pc-aros
450
 
+       exit ;;
451
 
 esac
452
 
 
453
 
 #echo '(No uname command or uname output not recognized.)' 1>&2
454
 
@@ -1455,9 +1491,9 @@ This script, last modified $timestamp, h
455
 
 the operating system you are using. It is advised that you
456
 
 download the most up to date version of the config scripts from
457
 
 
458
 
-  http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.guess
459
 
+  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.guess;hb=HEAD
460
 
 and
461
 
-  http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.sub
462
 
+  http://git.savannah.gnu.org/gitweb/?p=config.git;a=blob_plain;f=config.sub;hb=HEAD
463
 
 
464
 
 If the version you run ($0) is already up to date, please
465
 
 send the following data and any information you think might be
466
 
--- glew-1.5.2.orig/config/Makefile.gnu
467
 
+++ glew-1.5.2/config/Makefile.gnu
468
 
@@ -3,14 +3,16 @@ CC = cc
469
 
 LD = cc
470
 
 ifneq (undefined, $(origin GLEW_MX))
471
 
 CFLAGS.EXTRA = -DGLEW_MX
472
 
+NAME_SUF=mx
473
 
 endif
474
 
 PICFLAG = -fPIC
475
 
-LDFLAGS.SO = -shared -Wl,-soname=$(LIB.SONAME)
476
 
-LDFLAGS.EXTRA = -L/usr/X11R6/lib
477
 
+LDFLAGS.SO = -shared -Wl,-soname=$(LIB.SONAME) -Wl,-Bsymbolic-functions
478
 
+M_ARCH ?= $(shell uname -m)
479
 
+LIBDIR = $(GLEW_DEST)/lib
480
 
 LDFLAGS.GL = -lXmu -lXi -lGLU -lGL -lXext -lX11
481
 
 LDFLAGS.STATIC = -Wl,-Bstatic
482
 
 LDFLAGS.DYNAMIC = -Wl,-Bdynamic
483
 
-NAME = GLEW
484
 
+NAME = GLEW$(NAME_SUF)
485
 
 WARN = -Wall -W
486
 
 POPT = -O2
487
 
 BIN.SUFFIX =