~ubuntu-branches/ubuntu/oneiric/jabberd2/oneiric-security

« back to all changes in this revision

Viewing changes to debian/patches/etc_dbpath.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Nicolai Spohrer
  • Date: 2008-08-12 16:13:43 UTC
  • mfrom: (1.1.3 upstream) (0.1.2 sid)
  • Revision ID: james.westby@ubuntu.com-20080812161343-6trz3r97dtevxd17
Tags: 2.2.1-1ubuntu1
* Merge with Debian unstable (LP: #257130), remaining changes:
  - debian/control:
    + Modify Maintainer field as per spec
    + Depend on libdb4.6-dev instead of libdb4.4-dev
    + Added Conflicts and Replaces: ..., jabber for jabberd2
  - debian/rules: Added libtoolize call (jabberd2 ships with
     an older ltmain.sh version that conflicts with the
     current libtool version)
  - debian/init: create /var/run/jabber directory with correct
     permissions
* Dropped changes:
  - Debian already depends on libpq-dev

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## etc_dbpath.dpatch by Jorge Salamero Sanz <bencer@cauterized.net>
 
3
## DP: changes in etc files the path of databases
 
4
 
 
5
@DPATCH@
 
6
diff -urNad jabberd2-2.1.23~/etc/c2s.xml.dist.in jabberd2-2.1.23/etc/c2s.xml.dist.in
 
7
--- jabberd2-2.1.23~/etc/c2s.xml.dist.in        2008-04-04 08:47:12.000000000 +0000
 
8
+++ jabberd2-2.1.23/etc/c2s.xml.dist.in 2008-04-04 08:49:16.000000000 +0000
 
9
@@ -393,7 +393,7 @@
 
10
     <!-- SQLite driver configuration -->
 
11
     <sqlite>
 
12
       <!-- Database name -->
 
13
-      <dbname>@localstatedir@/jabberd/db/sqlite.db</dbname>
 
14
+      <dbname>/var/lib/jabberd2/sqlite.db</dbname>
 
15
 
 
16
       <!-- Transacation support. If this is commented out, transactions
 
17
            will be disabled. This might make database accesses faster,
 
18
@@ -407,7 +407,7 @@
 
19
     <!-- Berkeley DB module configuration -->
 
20
     <db>
 
21
       <!-- Directory to store database files under -->
 
22
-      <path>@localstatedir@/jabberd/db</path>
 
23
+      <path>/var/lib/jabberd2/</path>
 
24
 
 
25
       <!-- Synchronize the database to disk after each write. If you
 
26
            disable this, database accesses may be faster, but data may
 
27
diff -urNad jabberd2-2.1.23~/etc/sm.xml.dist.in jabberd2-2.1.23/etc/sm.xml.dist.in
 
28
--- jabberd2-2.1.23~/etc/sm.xml.dist.in 2008-04-04 08:47:12.000000000 +0000
 
29
+++ jabberd2-2.1.23/etc/sm.xml.dist.in  2008-04-04 08:50:18.000000000 +0000
 
30
@@ -151,7 +151,7 @@
 
31
     <!-- Berkeley DB driver configuration -->
 
32
     <db>
 
33
       <!-- Directory to store database files under -->
 
34
-      <path>@localstatedir@/jabberd/db</path>
 
35
+      <path>/var/lib/jabberd2/</path>
 
36
 
 
37
       <!-- Synchronize the database to disk after each write. If you
 
38
            disable this, database accesses may be faster, but data may
 
39
@@ -176,7 +176,7 @@
 
40
     <!-- SQLite driver configuration -->
 
41
     <sqlite>
 
42
       <!-- Database name -->
 
43
-      <dbname>@localstatedir@/jabberd/db/sqlite.db</dbname>
 
44
+      <dbname>/var/lib/jabberd2/sqlite.db</dbname>
 
45
 
 
46
       <!-- Transacation support. If this is commented out, transactions
 
47
            will be disabled. This might make database accesses faster,