~ubuntu-branches/ubuntu/oneiric/kdenetwork/oneiric-proposed

« back to all changes in this revision

Viewing changes to debian/patches/kubuntu_07_kopete_libjasper_optional.diff

  • Committer: Package Import Robot
  • Author(s): Romain Perier, Romain Perier, Philip Muškovac, Tarun Kumar Mall, Jonathan Thomas, Felix Geyer
  • Date: 2011-06-02 22:31:33 UTC
  • mfrom: (0.1.17 sid)
  • Revision ID: package-import@ubuntu.com-20110602223133-4yn8hax58hzwweu1
Tags: 4:4.6.3-1ubuntu1
[ Romain Perier ]
* Merge with Debian unstable, remaining changes:
  - debian/control:
    - Build against libboost1.46-dev
    - Build against libexpat1-dev instead of libexpat-dev
    - Drop from build-deps: libmediastreamer-dev, libortp-dev (in universe)
    - kopete recommends kopete-message-indicator
  - debian/rules:
    - chown kppp to root:dialout instead of root:dip
  - debian/kopete.install: don't add usr/bin/googletalk-call

[ Philip Muškovac ]
* Update Vcs links as the branch is owned by kubuntu-packagers now

[ Tarun Kumar Mall ]
* Removed patch kubuntu_08_kget_metalinker.diff, applied upstream

[ Jonathan Thomas ]
* Update kubuntu_05_samba_sharing.diff to use qapt-batch to install
  samba, now that it has replaced PackageKit in Kubuntu.
* Make kdenetwork-filesharing recommend qapt-batch

[ Felix Geyer ]
* Drop kubuntu_07_kopete_libjasper_optional.diff, not needed anymore.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: kdenetwork-4.6.2/kopete/CMakeLists.txt
2
 
===================================================================
3
 
--- kdenetwork-4.6.2.orig/kopete/CMakeLists.txt 2011-04-01 10:59:27.000000000 +0000
4
 
+++ kdenetwork-4.6.2/kopete/CMakeLists.txt      2011-04-04 17:10:27.741257431 +0000
5
 
@@ -137,6 +137,10 @@
6
 
 macro_optional_find_package(msiLBC)
7
 
 macro_log_feature(MSILBC_FOUND "msiLBC" "iLBC is low bitrate audio codec - plugin for mediastreamer" "http://download.savannah.gnu.org/releases/linphone/plugins/sources/" FALSE "" "Needed to build Google Talk libjingle voice call support with iLBC codec")
8
 
 
9
 
+macro_optional_find_package(Jasper)
10
 
+macro_bool_to_01(JASPER_FOUND HAVE_JASPER)
11
 
+macro_log_feature(JASPER_FOUND Jasper "JasPer library implements the codec specified in the JPEG-2000 Part-1 standard" "http://www.ece.uvic.ca/~mdadams/jasper/" FALSE "" "Required in order to be able to receive and send webcam images from/to Yahoo in Kopete")
12
 
+
13
 
 # Generate config-kopete.h
14
 
 configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config-kopete.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-kopete.h )
15
 
 
16
 
Index: kdenetwork-4.6.2/kopete/config-kopete.h.cmake
17
 
===================================================================
18
 
--- kdenetwork-4.6.2.orig/kopete/config-kopete.h.cmake  2011-04-01 10:59:27.000000000 +0000
19
 
+++ kdenetwork-4.6.2/kopete/config-kopete.h.cmake       2011-04-04 17:10:48.357257499 +0000
20
 
@@ -64,3 +64,6 @@
21
 
 #cmakedefine HAVE_LIBV4L2 1
22
 
 
23
 
 #cmakedefine HAVE_V4L 1
24
 
+
25
 
+/* Define to 1 if libjasper found */
26
 
+#cmakedefine HAVE_JASPER
27
 
Index: kdenetwork-4.6.2/kopete/protocols/yahoo/CMakeLists.txt
28
 
===================================================================
29
 
--- kdenetwork-4.6.2.orig/kopete/protocols/yahoo/CMakeLists.txt 2011-02-25 21:47:33.000000000 +0000
30
 
+++ kdenetwork-4.6.2/kopete/protocols/yahoo/CMakeLists.txt      2011-04-04 17:10:27.741257431 +0000
31
 
@@ -1,6 +1,3 @@
32
 
-find_package(Jasper)
33
 
-macro_log_feature(JASPER_FOUND Jasper "JasPer library implements the codec specified in the JPEG-2000 Part-1 standard" "http://www.ece.uvic.ca/~mdadams/jasper/" TRUE "" "Required in order to be able to receive and send webcam images from/to Yahoo in Kopete")
34
 
-
35
 
 add_subdirectory( libkyahoo ) 
36
 
 #add_subdirectory( ui ) 
37
 
 add_subdirectory( icons ) 
38
 
@@ -9,8 +6,10 @@
39
 
 ${KOPETE_INCLUDES} 
40
 
 ${CMAKE_CURRENT_SOURCE_DIR}/ui 
41
 
 ${CMAKE_CURRENT_SOURCE_DIR}/libkyahoo 
42
 
-${JASPER_INCLUDE_DIR}
43
 
 )
44
 
+if (JASPER_FOUND)
45
 
+   include_directories(${JASPER_INCLUDE_DIR})
46
 
+endif(JASPER_FOUND)
47
 
 
48
 
 link_directories( ${CMAKE_CURRENT_BINARY_DIR}/libkyahoo )
49
 
 
50
 
Index: kdenetwork-4.6.2/kopete/protocols/yahoo/libkyahoo/CMakeLists.txt
51
 
===================================================================
52
 
--- kdenetwork-4.6.2.orig/kopete/protocols/yahoo/libkyahoo/CMakeLists.txt       2011-02-25 21:47:33.000000000 +0000
53
 
+++ kdenetwork-4.6.2/kopete/protocols/yahoo/libkyahoo/CMakeLists.txt    2011-04-04 17:10:27.741257431 +0000
54
 
@@ -1,5 +1,3 @@
55
 
-include_directories( ${JASPER_INCLUDE_DIR} )
56
 
-
57
 
 add_subdirectory( tests ) 
58
 
 
59
 
 
60
 
@@ -40,7 +38,6 @@
61
 
 yahoobuddyiconloader.cpp 
62
 
 stealthtask.cpp 
63
 
 sendpicturetask.cpp 
64
 
-webcamimgformat.cpp
65
 
 webcamtask.cpp 
66
 
 conferencetask.cpp 
67
 
 sendauthresptask.cpp 
68
 
@@ -56,6 +53,9 @@
69
 
 yahoochattask.cpp
70
 
 )
71
 
 
72
 
+if (JASPER_FOUND)
73
 
+   set(libkyahoo_SRCS ${libkyahoo_SRCS} webcamimgformat.cpp)
74
 
+endif (JASPER_FOUND)
75
 
 
76
 
 kde4_add_library( kyahoo SHARED ${libkyahoo_SRCS} )
77
 
 
78
 
Index: kdenetwork-4.6.2/kopete/protocols/yahoo/libkyahoo/webcamtask.cpp
79
 
===================================================================
80
 
--- kdenetwork-4.6.2.orig/kopete/protocols/yahoo/libkyahoo/webcamtask.cpp       2011-02-25 21:47:33.000000000 +0000
81
 
+++ kdenetwork-4.6.2/kopete/protocols/yahoo/libkyahoo/webcamtask.cpp    2011-04-04 17:10:27.741257431 +0000
82
 
@@ -461,6 +461,7 @@
83
 
                        emit viewerLeft( who );
84
 
                break;
85
 
                case Image:
86
 
+#ifdef HAVE_JASPER
87
 
                        {
88
 
                        QPixmap webcamImage;
89
 
                        //webcamImage.loadFromData( info->buffer->buffer() );
90
 
@@ -475,6 +476,7 @@
91
 
                        } else
92
 
                                kDebug(YAHOO_RAW_DEBUG) << "Failed to initialize WebcamImgFormat helper";
93
 
                        }
94
 
+#endif
95
 
                break;
96
 
                default:
97
 
                break;
98
 
Index: kdenetwork-4.6.2/kopete/protocols/yahoo/yahoocontact.cpp
99
 
===================================================================
100
 
--- kdenetwork-4.6.2.orig/kopete/protocols/yahoo/yahoocontact.cpp       2011-02-25 21:47:33.000000000 +0000
101
 
+++ kdenetwork-4.6.2/kopete/protocols/yahoo/yahoocontact.cpp    2011-04-04 17:10:27.741257431 +0000
102
 
@@ -28,6 +28,8 @@
103
 
 #include "kopetetransfermanager.h"
104
 
 #include "kopeteavatarmanager.h"
105
 
 
106
 
+#include "config-kopete.h"
107
 
+
108
 
 // Local Includes
109
 
 #include "yahoocontact.h"
110
 
 #include "yahooaccount.h"
111
 
@@ -629,8 +631,14 @@
112
 
 
113
 
 void YahooContact::inviteWebcam()
114
 
 {
115
 
-       // TODO: some message if code for local video devices is not present
116
 
+#ifdef HAVE_JASPER
117
 
        m_account->yahooSession()->sendWebcamInvite( m_userId );
118
 
+#else
119
 
+       KMessageBox::queuedMessageBox( Kopete::UI::Global::mainWidget(), KMessageBox::Error,
120
 
+                       i18n("Unable to find the Jasper image conversion program.\nJasper is required to render Yahoo webcam images."
121
 
+                               "\nPlease see %1 for further information.", QString("http://userbase.kde.org/Kopete/Webcam_Support") ) );
122
 
+       return;
123
 
+#endif
124
 
 }
125
 
 
126
 
 void YahooContact::receivedWebcamImage( const QPixmap& image )
127
 
@@ -678,9 +686,16 @@
128
 
 
129
 
 void YahooContact::requestWebcam()
130
 
 {
131
 
+#ifdef HAVE_JASPER
132
 
        if( !m_webcamDialog )
133
 
                initWebcamViewer();
134
 
        m_account->yahooSession()->requestWebcam( contactId() );
135
 
+#else
136
 
+       KMessageBox::queuedMessageBox( Kopete::UI::Global::mainWidget(), KMessageBox::Error,
137
 
+                       i18n("Unable to find the Jasper image conversion program.\nJasper is required to render Yahoo webcam images."
138
 
+                               "\nPlease see %1 for further information.", QString("http://userbase.kde.org/Kopete/Webcam_Support") ) );
139
 
+       return;
140
 
+#endif
141
 
 }
142
 
 
143
 
 void YahooContact::closeWebcamDialog()
144
 
Index: kdenetwork-4.6.2/kopete/protocols/yahoo/yahoowebcam.cpp
145
 
===================================================================
146
 
--- kdenetwork-4.6.2.orig/kopete/protocols/yahoo/yahoowebcam.cpp        2011-02-25 21:47:33.000000000 +0000
147
 
+++ kdenetwork-4.6.2/kopete/protocols/yahoo/yahoowebcam.cpp     2011-04-04 17:10:27.741257431 +0000
148
 
@@ -24,8 +24,9 @@
149
 
 #include "avdevice/videodevicepool.h"
150
 
 #endif
151
 
 
152
 
+#ifdef HAVE_JASPER
153
 
 #include "webcamimgformat.h"
154
 
-
155
 
+#endif
156
 
 YahooWebcam::YahooWebcam( YahooAccount *account ) : QObject( 0 )
157
 
 {
158
 
        setObjectName( QLatin1String("yahoo_webcam") );
159
 
@@ -100,6 +101,7 @@
160
 
         */
161
 
 #endif
162
 
 
163
 
+#ifdef HAVE_JASPER
164
 
        QByteArray result;
165
 
        if (WebcamImgFormat::instance())
166
 
        {
167
 
@@ -111,6 +113,7 @@
168
 
                        kDebug(YAHOO_RAW_DEBUG) << "Failed to convert outgoing Yahoo webcam image";
169
 
        } else
170
 
                kDebug(YAHOO_RAW_DEBUG) << "Failed to initialize WebcamImgFormat helper";
171
 
+#endif
172
 
 }
173
 
 
174
 
 void YahooWebcam::addViewer( const QString &viewer )