~ubuntu-branches/ubuntu/oneiric/kdepim/oneiric-proposed

« back to all changes in this revision

Viewing changes to debian/patches/kubuntu_install_headers.diff

  • Committer: Package Import Robot
  • Author(s): Scott Kitterman
  • Date: 2011-08-05 22:42:11 UTC
  • Revision ID: package-import@ubuntu.com-20110805224211-3iqghs69gx673n9z
Tags: 4:4.7.0-0ubuntu2
* Re-add kleopatra related headers to kdepim-dev,install so
  kopete-cryptography will build
* Re-add headers to those installed by kubuntu_install_headers.diff
* Refresh patches

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: kdepim-4.4.11.1/kleopatra/libkleopatraclient/CMakeLists.txt
 
1
Index: kdepim-4.7.0/kleopatra/libkleopatraclient/CMakeLists.txt
2
2
===================================================================
3
 
--- kdepim-4.4.11.1.orig/kleopatra/libkleopatraclient/CMakeLists.txt    2011-04-20 22:03:31.000000000 +0200
4
 
+++ kdepim-4.4.11.1/kleopatra/libkleopatraclient/CMakeLists.txt 2011-06-11 16:30:44.000000000 +0200
 
3
--- kdepim-4.7.0.orig/kleopatra/libkleopatraclient/CMakeLists.txt       2011-08-06 00:10:57.159147932 -0400
 
4
+++ kdepim-4.7.0/kleopatra/libkleopatraclient/CMakeLists.txt    2011-08-06 00:11:00.979147930 -0400
5
5
@@ -6,3 +6,8 @@
6
6
 
7
7
 add_subdirectory( tests )
11
11
+  DESTINATION ${INCLUDE_INSTALL_DIR}/libkleopatraclient
12
12
+  )
13
13
+
14
 
Index: kdepim-4.4.11.1/kleopatra/libkleopatraclient/core/CMakeLists.txt
 
14
Index: kdepim-4.7.0/kleopatra/libkleopatraclient/core/CMakeLists.txt
15
15
===================================================================
16
 
--- kdepim-4.4.11.1.orig/kleopatra/libkleopatraclient/core/CMakeLists.txt       2011-04-20 22:03:31.000000000 +0200
17
 
+++ kdepim-4.4.11.1/kleopatra/libkleopatraclient/core/CMakeLists.txt    2011-06-11 16:30:44.000000000 +0200
18
 
@@ -38,3 +38,11 @@
 
16
--- kdepim-4.7.0.orig/kleopatra/libkleopatraclient/core/CMakeLists.txt  2011-08-06 00:10:57.167147930 -0400
 
17
+++ kdepim-4.7.0/kleopatra/libkleopatraclient/core/CMakeLists.txt       2011-08-06 00:11:00.979147930 -0400
 
18
@@ -56,3 +56,11 @@
19
19
   )
20
20
   
21
21
 
28
28
+  DESTINATION ${INCLUDE_INSTALL_DIR}/libkleopatraclient/core
29
29
+  )
30
30
\ No newline at end of file
31
 
Index: kdepim-4.4.11.1/kleopatra/libkleopatraclient/gui/CMakeLists.txt
 
31
Index: kdepim-4.7.0/kleopatra/libkleopatraclient/gui/CMakeLists.txt
32
32
===================================================================
33
 
--- kdepim-4.4.11.1.orig/kleopatra/libkleopatraclient/gui/CMakeLists.txt        2011-04-20 22:03:31.000000000 +0200
34
 
+++ kdepim-4.4.11.1/kleopatra/libkleopatraclient/gui/CMakeLists.txt     2011-06-11 16:30:44.000000000 +0200
 
33
--- kdepim-4.7.0.orig/kleopatra/libkleopatraclient/gui/CMakeLists.txt   2011-08-06 00:10:57.151147932 -0400
 
34
+++ kdepim-4.7.0/kleopatra/libkleopatraclient/gui/CMakeLists.txt        2011-08-06 00:11:00.983147930 -0400
35
35
@@ -20,3 +20,8 @@
36
36
   DESTINATION ${LIB_INSTALL_DIR}
37
37
   )
42
42
+  DESTINATION ${INCLUDE_INSTALL_DIR}/libkleopatraclient/gui
43
43
+  )
44
44
\ No newline at end of file
45
 
Index: kdepim-4.4.11.1/libkpgp/CMakeLists.txt
 
45
Index: kdepim-4.7.0/libkpgp/CMakeLists.txt
46
46
===================================================================
47
 
--- kdepim-4.4.11.1.orig/libkpgp/CMakeLists.txt 2011-04-20 22:03:31.000000000 +0200
48
 
+++ kdepim-4.4.11.1/libkpgp/CMakeLists.txt      2011-06-11 16:30:44.000000000 +0200
49
 
@@ -34,3 +34,11 @@
 
47
--- kdepim-4.7.0.orig/libkpgp/CMakeLists.txt    2011-08-06 00:10:57.171147930 -0400
 
48
+++ kdepim-4.7.0/libkpgp/CMakeLists.txt 2011-08-06 00:11:00.983147930 -0400
 
49
@@ -35,3 +35,11 @@
50
50
 install(FILES kpgp.upd  DESTINATION ${KCONF_UPDATE_INSTALL_DIR})
51
51
 install(PROGRAMS kpgp-3.1-upgrade-address-data.pl DESTINATION ${KCONF_UPDATE_INSTALL_DIR})
52
52
 
58
58
+        kpgpui.h
59
59
+        libkpgp_export.h
60
60
+        DESTINATION ${INCLUDE_INSTALL_DIR}/kpgp COMPONENT Devel )
 
61
Index: kdepim-4.7.0/libkleo/CMakeLists.txt
 
62
===================================================================
 
63
--- kdepim-4.7.0.orig/libkleo/CMakeLists.txt    2011-08-06 00:11:18.883147920 -0400
 
64
+++ kdepim-4.7.0/libkleo/CMakeLists.txt 2011-08-06 01:32:17.915145448 -0400
 
65
@@ -112,6 +112,57 @@
 
66
 set_target_properties(kleo PROPERTIES VERSION ${GENERIC_LIB_VERSION} SOVERSION ${GENERIC_LIB_SOVERSION} )
 
67
 install(TARGETS kleo ${INSTALL_TARGETS_DEFAULT_ARGS})
 
68
 
 
69
+install( FILES
 
70
+    kleo/kleo_export.h
 
71
+    kleo/enum.h
 
72
+    kleo/oidmap.h
 
73
+    kleo/cryptobackend.h
 
74
+    kleo/cryptobackendfactory.h
 
75
+    kleo/cryptoconfig.h
 
76
+    kleo/dn.h
 
77
+    kleo/job.h
 
78
+    kleo/keylistjob.h
 
79
+    kleo/keygenerationjob.h
 
80
+    kleo/abstractimportjob.h
 
81
+    kleo/importjob.h
 
82
+    kleo/importfromkeyserverjob.h
 
83
+    kleo/exportjob.h
 
84
+    kleo/changeexpiryjob.h
 
85
+    kleo/changeownertrustjob.h
 
86
+    kleo/downloadjob.h
 
87
+    kleo/deletejob.h
 
88
+    kleo/encryptjob.h
 
89
+    kleo/decryptjob.h
 
90
+    kleo/signjob.h
 
91
+    kleo/specialjob.h
 
92
+    kleo/verifydetachedjob.h
 
93
+    kleo/verifyopaquejob.h
 
94
+    kleo/decryptverifyjob.h
 
95
+    kleo/signencryptjob.h
 
96
+    kleo/signkeyjob.h
 
97
+    kleo/adduseridjob.h
 
98
+    kleo/refreshkeysjob.h
 
99
+    kleo/multideletejob.h
 
100
+    kleo/hierarchicalkeylistjob.h
 
101
+    kleo/keyfilter.h
 
102
+    kleo/keyfiltermanager.h
 
103
+    DESTINATION ${INCLUDE_INSTALL_DIR}/kleo COMPONENT Devel)
 
104
+
 
105
+install ( FILES
 
106
+    ui/kdhorizontalline.h
 
107
+    ui/messagebox.h
 
108
+    ui/progressbar.h
 
109
+    ui/progressdialog.h
 
110
+    ui/keylistview.h
 
111
+    ui/keyselectiondialog.h
 
112
+    ui/keyrequester.h
 
113
+    ui/keyapprovaldialog.h
 
114
+    ui/dnattributeorderconfigwidget.h
 
115
+    ui/cryptoconfigmodule.h
 
116
+    ui/cryptoconfigdialog.h
 
117
+    ui/directoryserviceswidget.h
 
118
+    DESTINATION ${INCLUDE_INSTALL_DIR}/kleo/ui COMPONENT Devel)
 
119
+
 
120
 if ( WIN32 )
 
121
 install ( FILES libkleopatrarc-win32.desktop DESTINATION ${CONFIG_INSTALL_DIR} RENAME libkleopatrarc )
 
122
 else ( WIN32 )