~ubuntu-branches/ubuntu/oneiric/libgcrypt11/oneiric-proposed

« back to all changes in this revision

Viewing changes to debian/patches/21_ld_no_as_needed.diff

  • Committer: Bazaar Package Importer
  • Author(s): Matthias Klose
  • Date: 2010-10-07 17:03:33 UTC
  • Revision ID: james.westby@ubuntu.com-20101007170333-b905mlqkgbuxj3fb
Tags: 1.4.5-2ubuntu2
Fix build failure with DSO link changes.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- ./tests/Makefile.am~        2009-04-02 11:25:34.000000000 +0200
 
2
+++ ./tests/Makefile.am 2010-10-07 17:08:22.492112177 +0200
 
3
@@ -36,7 +36,7 @@
 
4
 AM_CPPFLAGS = -I../src -I$(top_srcdir)/src
 
5
 AM_CFLAGS = $(GPG_ERROR_CFLAGS)
 
6
 
 
7
-LDADD = ../src/libgcrypt.la $(DL_LIBS)
 
8
+LDADD = ../src/libgcrypt.la $(GPG_ERROR_LIBS) $(DL_LIBS)
 
9
 
 
10
 EXTRA_PROGRAMS = testapi pkbench
 
11
 noinst_PROGRAMS = $(TESTS) fipsdrv
 
12
--- ./tests/Makefile.in~        2010-10-07 17:05:47.259609934 +0200
 
13
+++ ./tests/Makefile.in 2010-10-07 17:08:56.369611456 +0200
 
14
@@ -334,7 +334,7 @@
 
15
 # a built header.
 
16
 AM_CPPFLAGS = -I../src -I$(top_srcdir)/src
 
17
 AM_CFLAGS = $(GPG_ERROR_CFLAGS)
 
18
-LDADD = ../src/libgcrypt.la $(DL_LIBS)
 
19
+LDADD = ../src/libgcrypt.la $(GPG_ERROR_LIBS) $(DL_LIBS)
 
20
 EXTRA_DIST = README rsa-16k.key cavs_tests.sh cavs_driver.pl
 
21
 all: all-am
 
22