~ubuntu-branches/ubuntu/oneiric/libgtkada2/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/rename_gdialog_to_gtkada-dialog.patch

  • Committer: Bazaar Package Importer
  • Author(s): Devid Antonio Filoni
  • Date: 2009-06-28 10:02:54 UTC
  • mfrom: (6.1.3 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090628100254-htlqpbtnuirrl7wr
Tags: 2.12.0-4ubuntu1
* Merge from Debian unstable, remaining Ubuntu change:
  - add lpia to supported architectures

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Rename the gdialog binary to gtkada-dialog.
 
2
 
 
3
Patch from upstream svn r146020:
 
4
http://libre2.adacore.com/viewvc?view=rev&revision=146020
 
5
 
 
6
Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=497464
 
7
Ubuntu: https://bugs.launchpad.net/bugs/280188
 
8
 
 
9
Index: libgtkada2-2.12.0/src/tools/Makefile.in
 
10
===================================================================
 
11
--- libgtkada2-2.12.0.orig/src/tools/Makefile.in
 
12
+++ libgtkada2-2.12.0/src/tools/Makefile.in
 
13
@@ -7,7 +7,7 @@
 
14
   GATE        = gate
 
15
 endif
 
16
 
 
17
-GDIALOG       = gdialog
 
18
+GDIALOG       = gtkada-dialog
 
19
 GTKADA_CONFIG = gtkada-config
 
20
 
 
21
 GNATMAKELDFLAGS = -largs -L../lib-obj -lgtkada $(GTK_LIBS)
 
22
Index: libgtkada2-2.12.0/src/tools/gate.in
 
23
===================================================================
 
24
--- libgtkada2-2.12.0.orig/src/tools/gate.in
 
25
+++ libgtkada2-2.12.0/src/tools/gate.in
 
26
@@ -105,7 +105,7 @@
 
27
   done
 
28
 
 
29
   if [ $conflicts = 1 ]; then
 
30
-    cat $gt/conflicts.txt | gdialog error justify_left
 
31
+    cat $gt/conflicts.txt | gtkada-dialog error justify_left
 
32
   fi
 
33
   
 
34
   echo done.
 
35
@@ -136,7 +136,7 @@
 
36
       echo "  "$j
 
37
     done
 
38
 
 
39
-    cat << EOF | gdialog error justify_left
 
40
+    cat << EOF | gtkada-dialog error justify_left
 
41
 Merge of some changes failed. It usually means that some modified code
 
42
 is obsolete in the current project file.
 
43
 .rej files have been generated to help merging manually if needed.
 
44
Index: libgtkada2-2.12.0/src/tools/gdialog.adb
 
45
===================================================================
 
46
--- libgtkada2-2.12.0.orig/src/tools/gdialog.adb
 
47
+++ libgtkada2-2.12.0/src/tools/gdialog.adb
 
48
@@ -1,8 +1,8 @@
 
49
 -----------------------------------------------------------------------
 
50
 --                 GDialog - GtkAda Components                       --
 
51
 --                                                                   --
 
52
---                      Copyright (C) 2000                           --
 
53
---        Emmanuel Briot, Joel Brobecker and Arnaud Charlet          --
 
54
+--      Copyright (C) 2000 E. Briot, J. Brobecker and A. Charlet     --
 
55
+--                  Copyright (C) 2009, AdaCore                      --
 
56
 --                                                                   --
 
57
 -- Dialog is free software; you can redistribute it and/or modify it --
 
58
 -- under the terms of the GNU General Public License as published by --
 
59
@@ -23,7 +23,7 @@
 
60
 --
 
61
 --  Example using a unix-like shell:
 
62
 --
 
63
---  $ cat << EOF | gdialog error justify_fill
 
64
+--  $ cat << EOF | gtkada-dialog error justify_fill
 
65
 --  > Merge of some changes failed. It usually means that some modified code
 
66
 --  > is obsolete in the current project file.
 
67
 --  >
 
68
Index: libgtkada2-2.12.0/src/tools/tools.gpr
 
69
===================================================================
 
70
--- libgtkada2-2.12.0.orig/src/tools/tools.gpr
 
71
+++ libgtkada2-2.12.0/src/tools/tools.gpr
 
72
@@ -8,6 +8,7 @@
 
73
    package Builder  is
 
74
       for Default_Switches ("Ada") use Shared.Builder'Default_Switches ("Ada");
 
75
       for Executable ("gate.adb") use "gate-in.exe";
 
76
+      for Executable ("gdialog.adb") use "gtkada-dialog";
 
77
    end Builder;
 
78
 
 
79
    package Compiler renames Shared.Compiler;