~ubuntu-branches/ubuntu/oneiric/libubuntuone/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/01_fix_introspection_for_natty.patch

  • Committer: Sebastien Bacher
  • Date: 2011-01-14 23:25:57 UTC
  • mfrom: (78.1.4 libubuntuone)
  • Revision ID: seb128@ubuntu.com-20110114232557-8hsr518bjphtpj3w
Tags: 0.3.9-0ubuntu1
releasing version 0.3.9-0ubuntu1

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
=== modified file 'configure.ac'
2
 
--- configure.ac        2010-10-18 18:25:45 +0000
3
 
+++ configure.ac        2010-11-24 18:02:50 +0000
4
 
@@ -160,6 +160,15 @@
5
 
 # Check for introspection
6
 
 ##################################################
7
 
 GOBJECT_INTROSPECTION_CHECK([0.6.4])
8
 
+AC_MSG_CHECKING([if gobject-introspection requires new options])
9
 
+$PKG_CONFIG --atleast-version=0.9.4 gobject-introspection-1.0
10
 
+new_introspection=$?
11
 
+if test "x$new_introspection" = "x0"; then
12
 
+   AC_MSG_RESULT([yes])
13
 
+else
14
 
+   AC_MSG_RESULT([no])
15
 
+fi
16
 
+AM_CONDITIONAL([HAVE_NEW_INTROSPECTION], [test "x$new_introspection" = "x0"])
17
 
 
18
 
 AC_CONFIG_FILES([
19
 
 Makefile
20
 
 
21
 
=== modified file 'libubuntuone/Makefile.am'
22
 
--- libubuntuone/Makefile.am    2010-08-25 18:35:07 +0000
23
 
+++ libubuntuone/Makefile.am    2010-11-24 18:05:23 +0000
24
 
@@ -38,6 +38,10 @@
25
 
 INTROSPECTION_SCANNER_ARGS = --add-include-path=$(srcdir)
26
 
 INTROSPECTION_COMPILER_ARGS = --includedir=$(srcdir)
27
 
 
28
 
+if HAVE_NEW_INTROSPECTION
29
 
+INTROSPECTION_SCANNER_ARGS += --identifier-prefix=U1
30
 
+endif
31
 
+
32
 
 if HAVE_INTROSPECTION
33
 
 introspection_files =                  \
34
 
         $(u1include_HEADERS)           \
35
 
 
36
 
=== modified file 'libubuntuone/oauth.c'
37
 
--- libubuntuone/oauth.c        2010-01-06 16:48:47 +0000
38
 
+++ libubuntuone/oauth.c        2010-11-24 18:04:17 +0000
39
 
@@ -914,7 +914,7 @@
40
 
   fclose(F);
41
 
   len=0;
42
 
   md=(unsigned char*) calloc(EVP_MD_size(EVP_sha1()),sizeof(unsigned char));
43
 
-  EVP_DigestFinal(&ctx, md, &len);
44
 
+  EVP_DigestFinal(&ctx, md, (unsigned int *) &len);
45
 
   EVP_MD_CTX_cleanup(&ctx);
46
 
   return oauth_body_hash_encode(len, md);
47
 
 }
48
 
@@ -927,7 +927,7 @@
49
 
   EVP_MD_CTX_init(&ctx);
50
 
   EVP_DigestInit(&ctx,EVP_sha1());
51
 
   EVP_DigestUpdate(&ctx, data, length);
52
 
-  EVP_DigestFinal(&ctx, md, &len);
53
 
+  EVP_DigestFinal(&ctx, md, (unsigned int *) &len);
54
 
   EVP_MD_CTX_cleanup(&ctx);
55
 
   return oauth_body_hash_encode(len, md);
56
 
 }
57