~ubuntu-branches/ubuntu/oneiric/loggerhead/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/debian-changes-1.17+bzr429-1

  • Committer: Bazaar Package Importer
  • Author(s): Jelmer Vernooij, Andrew Starr-Bochicchio, Jelmer Vernooij
  • Date: 2010-10-11 11:00:01 UTC
  • mfrom: (4.1.4 sid)
  • Revision ID: james.westby@ubuntu.com-20101011110001-601j3dubl20c4lqx
Tags: 1.17+bzr429-1
[ Andrew Starr-Bochicchio ]
* debian/control:
 - Recommend python-pygments to support syntax-highlighting. (LP: #607775)
 - Add Vcs-Browser field.
 - Bump Standards-Version to 3.9.1, no-changes needed.

[ Jelmer Vernooij ]
* New upstream snapshot.
* Cope with bzrlib.util.configobj no longer existing.
* Add convenience script for automatically updating dependencies.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Upstream changes introduced in version 1.17+bzr429-1
 
2
 This patch has been created by dpkg-source during the package build.
 
3
 Here's the last changelog entry, hopefully it gives details on why
 
4
 those changes were made:
 
5
 .
 
6
 loggerhead (1.17+bzr429-1) unstable; urgency=low
 
7
 .
 
8
   [ Andrew Starr-Bochicchio ]
 
9
   * debian/control:
 
10
    - Recommend python-pygments to support syntax-highlighting. (LP: #607775)
 
11
    - Add Vcs-Browser field.
 
12
    - Bump Standards-Version to 3.9.1, no-changes needed.
 
13
 .
 
14
   [ Jelmer Vernooij ]
 
15
   * New upstream snapshot.
 
16
   * Cope with bzrlib.util.configobj no longer existing.
 
17
   * Add convenience script for automatically updating dependencies.
 
18
 .
 
19
 The person named in the Author field signed this changelog entry.
 
20
Author: Jelmer Vernooij <jelmer@debian.org>
 
21
Bug-Ubuntu: https://bugs.launchpad.net/bugs/607775
 
22
 
 
23
---
 
24
The information above should follow the Patch Tagging Guidelines, please
 
25
checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
 
26
are templates for supplementary fields that you might want to add:
 
27
 
 
28
Origin: <vendor|upstream|other>, <url of original patch>
 
29
Bug: <url in upstream bugtracker>
 
30
Bug-Debian: http://bugs.debian.org/<bugnumber>
 
31
Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
 
32
Forwarded: <no|not-needed|url proving that it has been forwarded>
 
33
Reviewed-By: <name and email of someone who approved the patch>
 
34
Last-Update: <YYYY-MM-DD>
 
35
 
 
36
--- loggerhead-1.17+bzr429.orig/setup.py
 
37
+++ loggerhead-1.17+bzr429/setup.py
 
38
@@ -41,28 +41,6 @@ setup(
 
39
     package_data = {"loggerhead": ["templates/*.pt",
 
40
                                    "static/css/*.css",
 
41
                                    "static/javascript/*.js",
 
42
-                                   "static/javascript/yui/build/anim/*",
 
43
-                                   "static/javascript/yui/build/base/*",
 
44
-                                   "static/javascript/yui/build/cssbase/*",
 
45
-                                   "static/javascript/yui/build/cssgrids/*",
 
46
-                                   "static/javascript/yui/build/dd/*",
 
47
-                                   "static/javascript/yui/build/dump/*",
 
48
-                                   "static/javascript/yui/build/get/*",
 
49
-                                   "static/javascript/yui/build/json/*",
 
50
-                                   "static/javascript/yui/build/node/*",
 
51
-                                   "static/javascript/yui/build/queue/*",
 
52
-                                   "static/javascript/yui/build/yui/*",
 
53
-                                   "static/javascript/yui/build/attribute/*",
 
54
-                                   "static/javascript/yui/build/cookie/*",
 
55
-                                   "static/javascript/yui/build/cssfonts/*",
 
56
-                                   "static/javascript/yui/build/cssreset/*",
 
57
-                                   "static/javascript/yui/build/dom/*",
 
58
-                                   "static/javascript/yui/build/event/*",
 
59
-                                   "static/javascript/yui/build/io/*",
 
60
-                                   "static/javascript/yui/build/loader/*",
 
61
-                                   "static/javascript/yui/build/oop/*",
 
62
-                                   "static/javascript/yui/build/substitute/*",
 
63
-                                   "static/javascript/yui/build/yui-base/*",
 
64
                                    "static/images/*"]},
 
65
     data_files = [
 
66
         ('share/man/man1', ['serve-branches.1']),
 
67
--- loggerhead-1.17+bzr429.orig/loggerhead.conf.example
 
68
+++ loggerhead-1.17+bzr429/loggerhead.conf.example
 
69
@@ -8,10 +8,6 @@
 
70
 # use this if you want loggerhead to listen to another interface than 127.0.0.1
 
71
 # server.socket_host = 'your_hostname_or_ip'
 
72
 
 
73
-# where's bzrlib?
 
74
-# (you only need this if you don't install bzr.)
 
75
-#bzrpath = '/Users/robey/code/bzr/bzr'
 
76
-
 
77
 # if you want a special title on the front page, set it here:
 
78
 title = 'branches in loggerhead'
 
79
 
 
80
--- /dev/null
 
81
+++ loggerhead-1.17+bzr429/serve-branches.conf.example
 
82
@@ -0,0 +1,3 @@
 
83
+served_branches=/srv/bzr
 
84
+prefix=/loggerhead
 
85
+port=8080
 
86
--- loggerhead-1.17+bzr429.orig/loggerhead/apps/config.py
 
87
+++ loggerhead-1.17+bzr429/loggerhead/apps/config.py
 
88
@@ -10,7 +10,10 @@ import posixpath
 
89
 
 
90
 import bzrlib.lru_cache
 
91
 
 
92
-from bzrlib.util.configobj.configobj import ConfigObj
 
93
+try:
 
94
+    from bzrlib.util.configobj.configobj import ConfigObj
 
95
+except ImportError:
 
96
+    from configobj import ConfigObj
 
97
 
 
98
 from paste.request import path_info_pop
 
99
 from paste import httpexceptions
 
100
--- loggerhead-1.17+bzr429.orig/loggerhead/templates/branchinfo.pt
 
101
+++ loggerhead-1.17+bzr429/loggerhead/templates/branchinfo.pt
 
102
@@ -1,4 +1,4 @@
 
103
-<div id="branch-info" tal:condition="python:branch.served_url">
 
104
+<div id="branch-info">
 
105
   To get this branch, use: <br/>
 
106
   <code>bzr branch
 
107
   <tal:served-url tal:replace="python:branch.served_url" /></code>
 
108
--- loggerhead-1.17+bzr429.orig/loggerhead/tests/test_simple.py
 
109
+++ loggerhead-1.17+bzr429/loggerhead/tests/test_simple.py
 
110
@@ -21,7 +21,10 @@ import os
 
111
 import shutil
 
112
 
 
113
 from bzrlib.tests import TestCaseWithTransport
 
114
-from bzrlib.util.configobj.configobj import ConfigObj
 
115
+try:
 
116
+    from bzrlib.util.configobj.configobj import ConfigObj
 
117
+except ImportError:
 
118
+    from configobj import ConfigObj
 
119
 from bzrlib import config
 
120
 
 
121
 from loggerhead.apps.branch import BranchWSGIApp