~ubuntu-branches/ubuntu/oneiric/lxsession/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/04_gtk3_migration.patch

  • Committer: Bazaar Package Importer
  • Author(s): Julien Lavergne
  • Date: 2010-11-05 00:58:58 UTC
  • Revision ID: james.westby@ubuntu.com-20101105005858-03au083bzyv9bsrt
Tags: 0.4.4-3ubuntu1
* debian/rules:
 - Add CFLAGS for GTK3 migration.
 - Add LDFLAGS for building with --as-needed
 - Add dh_strip for debug package.
* debian/control
 - Add a debug package.
 - Wrap build-depends and depends.
* debian/patches/04_gtk3_migration.patch:
 - Build with CFLAGS for GTK3 migration.
* debian/patches/05_not_launching-autostart-programs.patch:
 - Add an option to not autostart programs (LP: #655384)
* debian/patches/06_lX11_liking.patch:
 - Add -lX11 to fix FTBFS with gold.
* debian/dirs
 - Remove.
* debian/lxsession.install:
 - Add.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#Upstream: https://sourceforge.net/tracker/?func=detail&aid=3103279&group_id=180858&atid=894871
 
2
Index: lxsession-0.4.4/lxsession-logout/lxsession-logout.c
 
3
===================================================================
 
4
--- lxsession-0.4.4.orig/lxsession-logout/lxsession-logout.c    2010-10-31 14:49:30.000000000 +0100
 
5
+++ lxsession-0.4.4/lxsession-logout/lxsession-logout.c 2010-10-31 15:34:31.000000000 +0100
 
6
@@ -360,17 +360,35 @@
 
7
 /* Handler for "expose_event" on background. */
 
8
 gboolean expose_event(GtkWidget * widget, GdkEventExpose * event, GdkPixbuf * pixbuf)
 
9
 {
 
10
+
 
11
+#if GTK_CHECK_VERSION(2,22,0)
 
12
+     GtkAllocation allocation;
 
13
+     gtk_widget_get_allocation(widget, &allocation);
 
14
+#endif
 
15
+
 
16
     if (pixbuf != NULL)
 
17
     {
 
18
         /* Copy the appropriate rectangle of the root window pixmap to the drawing area.
 
19
          * All drawing areas are immediate children of the toplevel window, so the allocation yields the source coordinates directly. */
 
20
         gdk_draw_pixbuf(
 
21
-            widget->window,                                    /* Drawable to render to */
 
22
+#if GTK_CHECK_VERSION(2,14,0)
 
23
+            gtk_widget_get_window(widget),                                     /* Drawable to render to */
 
24
+#else
 
25
+            widget->window,                        /* Drawable to render to */
 
26
+#endif
 
27
             NULL,                                              /* GC for clipping */
 
28
             pixbuf,                                            /* Source pixbuf */
 
29
+#if GTK_CHECK_VERSION(2,22,0)
 
30
+            allocation.x, allocation.y,
 
31
+#else
 
32
             widget->allocation.x, widget->allocation.y,                /* Source coordinates */
 
33
+#endif
 
34
             0, 0,                                              /* Destination coordinates */
 
35
+#if GTK_CHECK_VERSION(2,22,0)
 
36
+            allocation.width, allocation.height,
 
37
+#else
 
38
             widget->allocation.width, widget->allocation.height,
 
39
+#endif
 
40
             GDK_RGB_DITHER_NORMAL,                             /* Dither type */
 
41
             0, 0);                                             /* Dither offsets */
 
42
     }