~ubuntu-branches/ubuntu/oneiric/morse/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/01makefile

  • Committer: Bazaar Package Importer
  • Author(s): Nanakos Chrysostomos
  • Date: 2011-06-17 13:57:00 UTC
  • mfrom: (1.1.3 upstream)
  • Revision ID: james.westby@ubuntu.com-20110617135700-b0zzrwr018nhyee6
Tags: 2.4-1
New upstream release

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Minor Makefile changes needed for Debian
 
2
Author: Nanakos Chrysostomos <nanakos@wired-net.gr>
 
3
 
 
4
--- morse-2.4.orig/Makefile
 
5
+++ morse-2.4/Makefile
 
6
@@ -37,10 +37,16 @@ ALL=  $(DOCS) Makefile $(SOURCES) test_i
 
7
        qso.d/*.[ch] qso.d/Makefile
 
8
 
 
9
 default:
 
10
-       make testmorse
 
11
+       make all
 
12
 
 
13
 all: morse QSO morse.1 QSO.1
 
14
 
 
15
+install: all
 
16
+       install morse.d/morsePA $(DESTDIR)/usr/bin/morse
 
17
+       install morse.d/morseLinux $(DESTDIR)/usr/bin
 
18
+       install morse.d/morseX11 $(DESTDIR)/usr/bin
 
19
+       install qso.d/QSO $(DESTDIR)/usr/bin
 
20
+
 
21
 morse:
 
22
        cd morse.d && make DEVICE=${DEVICE}
 
23
        ln morse.d/morse ./morse