~ubuntu-branches/ubuntu/oneiric/mpqc/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/08_gcc-4.0_fixes.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Daniel Leidert (dale)
  • Date: 2008-03-14 17:24:36 UTC
  • mto: (3.1.4 sid)
  • mto: This revision was merged to the branch mainline in revision 8.
  • Revision ID: james.westby@ubuntu.com-20080314172436-1xec9aeysbe1k9ij
debian/control(.in): Added DM-Upload-Allowed for DM status.
(Build-Depends, Build-Depends-Indep): Moved doxygen to Build-Depends to
fix FTBFS.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
## 08_gcc-4.0_fixes.dpatch taken from CVS.
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: gcc-4.0 build fixes
6
 
 
7
 
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
8
 
patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
9
 
 
10
 
if [ $# -ne 1 ]; then
11
 
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
12
 
    exit 1
13
 
fi
14
 
case "$1" in
15
 
       -patch) patch $patch_opts -p1 < $0;;
16
 
       -unpatch) patch $patch_opts -p1 -R < $0;;
17
 
        *)
18
 
                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
19
 
                exit 1;;
20
 
esac
21
 
 
22
 
exit 0
23
 
@DPATCH@
24
 
diff -Naur mpqc-old/src/lib/chemistry/qc/basis/integral.cc mpqc/src/lib/chemistry/qc/basis/integral.cc
25
 
--- mpqc-old/src/lib/chemistry/qc/basis/integral.cc     2005-07-20 01:39:15.564158776 +0200
26
 
+++ mpqc/src/lib/chemistry/qc/basis/integral.cc 2005-07-20 01:39:39.620501656 +0200
27
 
@@ -56,6 +56,10 @@
28
 
   set_basis(b1,b2,b3,b4);
29
 
 }
30
 
 
31
 
+Integral::~Integral()
32
 
+{
33
 
+}
34
 
+
35
 
 Integral::Integral(StateIn& s) :
36
 
   SavableState(s)
37
 
 {
38
 
diff -Naur mpqc-old/src/lib/chemistry/qc/basis/integral.h mpqc/src/lib/chemistry/qc/basis/integral.h
39
 
--- mpqc-old/src/lib/chemistry/qc/basis/integral.h      2005-07-20 01:39:15.564158776 +0200
40
 
+++ mpqc/src/lib/chemistry/qc/basis/integral.h  2005-07-20 01:39:39.622501352 +0200
41
 
@@ -79,6 +79,8 @@
42
 
     Integral(StateIn&);
43
 
     /// Integral the Integral object from the given KeyVal object.
44
 
     Integral(const Ref<KeyVal>&);
45
 
+
46
 
+    virtual ~Integral();
47
 
     
48
 
     void save_data_state(StateOut&);
49
 
 
50
 
diff -Naur mpqc-old/src/lib/chemistry/qc/basis/obint.cc mpqc/src/lib/chemistry/qc/basis/obint.cc
51
 
--- mpqc-old/src/lib/chemistry/qc/basis/obint.cc        2005-07-20 01:39:15.564158776 +0200
52
 
+++ mpqc/src/lib/chemistry/qc/basis/obint.cc    2005-07-20 01:39:39.625500896 +0200
53
 
@@ -44,6 +44,10 @@
54
 
 
55
 
 ///////////////////////////////////////////////////////////////////////
56
 
 
57
 
+EfieldDotVectorData::~EfieldDotVectorData()
58
 
+{
59
 
+}
60
 
+
61
 
 void
62
 
 EfieldDotVectorData::set_position(double*p)
63
 
 {
64
 
@@ -62,6 +66,10 @@
65
 
 
66
 
 ///////////////////////////////////////////////////////////////////////
67
 
 
68
 
+DipoleData::~DipoleData()
69
 
+{
70
 
+}
71
 
+
72
 
 void
73
 
 DipoleData::set_origin(double*o)
74
 
 {
75
 
diff -Naur mpqc-old/src/lib/chemistry/qc/basis/obint.h mpqc/src/lib/chemistry/qc/basis/obint.h
76
 
--- mpqc-old/src/lib/chemistry/qc/basis/obint.h 2005-07-20 01:39:15.564158776 +0200
77
 
+++ mpqc/src/lib/chemistry/qc/basis/obint.h     2005-07-20 01:39:39.627500592 +0200
78
 
@@ -49,6 +49,9 @@
79
 
 class EfieldDotVectorData: public RefCount
80
 
 {
81
 
   public:
82
 
+    EfieldDotVectorData() {};
83
 
+    ~EfieldDotVectorData();
84
 
+
85
 
     double position[3];
86
 
     double vector[3];
87
 
 
88
 
@@ -64,6 +67,7 @@
89
 
 
90
 
     DipoleData(double *d) {origin[0]=d[0]; origin[1]=d[1]; origin[2]=d[2];}
91
 
     DipoleData() {origin[0]=origin[1]=origin[2]=0.0;}
92
 
+    ~DipoleData();
93
 
     void set_origin(double*);
94
 
 };
95
 
 
96
 
diff -Naur mpqc-old/src/lib/math/scmat/abstract.cc mpqc/src/lib/math/scmat/abstract.cc
97
 
--- mpqc-old/src/lib/math/scmat/abstract.cc     2005-07-20 01:39:15.657144640 +0200
98
 
+++ mpqc/src/lib/math/scmat/abstract.cc 2005-07-20 01:39:40.774326248 +0200
99
 
@@ -449,6 +449,10 @@
100
 
 {
101
 
 }
102
 
 
103
 
+SymmSCMatrix::~SymmSCMatrix()
104
 
+{
105
 
+}
106
 
+
107
 
 void
108
 
 SymmSCMatrix::save(StateOut&s)
109
 
 {
110
 
@@ -801,6 +805,10 @@
111
 
 {
112
 
 }
113
 
 
114
 
+DiagSCMatrix::~DiagSCMatrix()
115
 
+{
116
 
+}
117
 
+
118
 
 void
119
 
 DiagSCMatrix::save(StateOut&s)
120
 
 {
121
 
diff -Naur mpqc-old/src/lib/math/scmat/abstract.h mpqc/src/lib/math/scmat/abstract.h
122
 
--- mpqc-old/src/lib/math/scmat/abstract.h      2005-07-20 01:39:15.658144488 +0200
123
 
+++ mpqc/src/lib/math/scmat/abstract.h  2005-07-20 01:39:40.784324728 +0200
124
 
@@ -367,6 +367,7 @@
125
 
     Ref<SCMatrixKit> kit_;
126
 
   public:
127
 
     SymmSCMatrix(const RefSCDimension&, SCMatrixKit *);
128
 
+    ~SymmSCMatrix();
129
 
 
130
 
     /// Return the SCMatrixKit object that created this object.
131
 
     Ref<SCMatrixKit> kit() const { return kit_; }
132
 
@@ -505,6 +506,7 @@
133
 
     Ref<SCMatrixKit> kit_;
134
 
   public:
135
 
     DiagSCMatrix(const RefSCDimension&, SCMatrixKit *);
136
 
+    ~DiagSCMatrix();
137
 
 
138
 
     /// Return the SCMatrixKit used to create this object.
139
 
     Ref<SCMatrixKit> kit() const { return kit_; }
140
 
diff -Naur mpqc-old/src/lib/math/scmat/block.cc mpqc/src/lib/math/scmat/block.cc
141
 
--- mpqc-old/src/lib/math/scmat/block.cc        2005-07-20 01:39:15.658144488 +0200
142
 
+++ mpqc/src/lib/math/scmat/block.cc    2005-07-20 01:39:40.796322904 +0200
143
 
@@ -837,7 +837,9 @@
144
 
 ///////////////////////////////////////////////////////////////////////
145
 
 // SCMatrixSubblockIter
146
 
 
147
 
-// inlined or pure virtual
148
 
+SCMatrixSubblockIter::~SCMatrixSubblockIter()
149
 
+{
150
 
+}
151
 
 
152
 
 ///////////////////////////////////////////////////////////////////////
153
 
 // SCMatrixSimpleSubblockIter
154
 
diff -Naur mpqc-old/src/lib/math/scmat/block.h mpqc/src/lib/math/scmat/block.h
155
 
--- mpqc-old/src/lib/math/scmat/block.h 2005-07-20 01:39:15.658144488 +0200
156
 
+++ mpqc/src/lib/math/scmat/block.h     2005-07-20 01:39:40.798322600 +0200
157
 
@@ -389,6 +389,7 @@
158
 
     /** The access variable should be one of Read, Write, Accum, and None,
159
 
         with the SCMatrixSubblockIter:: scope operator applied. */
160
 
     SCMatrixSubblockIter(Access access): access_(access) {}
161
 
+    ~SCMatrixSubblockIter();
162
 
     /// Start at the beginning.
163
 
     virtual void begin() = 0;
164
 
     /// Returns nonzero if there is another block.
165
 
diff -Naur mpqc-old/src/lib/util/class/class.h mpqc/src/lib/util/class/class.h
166
 
--- mpqc-old/src/lib/util/class/class.h 2005-07-20 01:39:15.671142512 +0200
167
 
+++ mpqc/src/lib/util/class/class.h     2005-07-20 01:39:41.015289616 +0200
168
 
@@ -319,6 +319,7 @@
169
 
 template <class A>
170
 
 class ForceLinkBase {
171
 
   public:
172
 
+    ForceLinkBase() {};
173
 
     virtual ~ForceLinkBase() {};
174
 
     virtual DescribedClass *create(A) = 0;
175
 
 };
176
 
@@ -335,6 +336,8 @@
177
 
 template <class T, class A = const Ref<KeyVal> &>
178
 
 class ForceLink: public ForceLinkBase<A> {
179
 
   public:
180
 
+    ForceLink() {};
181
 
+    virtual ~ForceLink() {};
182
 
     DescribedClass *create(A a) { return new T(a); }
183
 
 };
184
 
 
185
 
diff -Naur mpqc-old/src/lib/util/group/topology.cc mpqc/src/lib/util/group/topology.cc
186
 
--- mpqc-old/src/lib/util/group/topology.cc     2005-07-20 01:39:15.681140992 +0200
187
 
+++ mpqc/src/lib/util/group/topology.cc 2005-07-20 01:39:41.207260432 +0200
188
 
@@ -46,6 +46,10 @@
189
 
   forwards();
190
 
 }
191
 
 
192
 
+GlobalMsgIter::~GlobalMsgIter()
193
 
+{
194
 
+}
195
 
+
196
 
 static ClassDesc MachineTopology_cd(
197
 
   typeid(MachineTopology),"MachineTopology",1,"public DescribedClass",
198
 
   0, 0, 0);
199
 
diff -Naur mpqc-old/src/lib/util/group/topology.h mpqc/src/lib/util/group/topology.h
200
 
--- mpqc-old/src/lib/util/group/topology.h      2005-07-20 01:39:15.682140840 +0200
201
 
+++ mpqc/src/lib/util/group/topology.h  2005-07-20 01:39:41.208260280 +0200
202
 
@@ -53,6 +53,7 @@
203
 
     virtual int fwdrecv() = 0;
204
 
   public:
205
 
     GlobalMsgIter(int nproc, int me, int root = 0);
206
 
+    ~GlobalMsgIter();
207
 
     void backwards() { fwd_ = 0; i_ = n_ - 1; }
208
 
     void forwards() { fwd_ = 1; i_ = 0; }
209
 
     void next() { if (fwd_) i_++; else i_--; }
210
 
diff -Naur mpqc-old/src/lib/util/ref/ref.h mpqc/src/lib/util/ref/ref.h
211
 
--- mpqc-old/src/lib/util/ref/ref.h     2005-07-20 01:39:15.697138560 +0200
212
 
+++ mpqc/src/lib/util/ref/ref.h 2005-07-20 01:39:41.400231096 +0200
213
 
@@ -306,6 +306,7 @@
214
 
     void reference(RefCount *);
215
 
     int dereference(RefCount *);
216
 
   public:
217
 
+    RefBase() {};
218
 
     virtual ~RefBase();
219
 
     /// Returns the DescribedClass pointer for the contained object.
220
 
     virtual RefCount* parentpointer() const = 0;
221
 
diff -u -r2.9 -r2.10
222
 
--- mpqc/src/lib/util/group/message.h   2004/11/06 01:57:22     2.9
223
 
+++ mpqc/src/lib/util/group/message.h   2005/07/14 23:11:18     2.10
224
 
@@ -52,18 +52,21 @@
225
 
 template <class T>
226
 
 class GrpSumReduce: public GrpReduce<T> {
227
 
   public:
228
 
+    ~GrpSumReduce() {};
229
 
     void reduce(T*target, T*data, int nelement);
230
 
 };
231
 
 
232
 
 template <class T>
233
 
 class GrpMinReduce: public GrpReduce<T> {
234
 
   public:
235
 
+    ~GrpMinReduce() {};
236
 
     void reduce(T*target, T*data, int nelement);
237
 
 };
238
 
 
239
 
 template <class T>
240
 
 class GrpMaxReduce: public GrpReduce<T> {
241
 
   public:
242
 
+    ~GrpMaxReduce() {};
243
 
     void reduce(T*target, T*data, int nelement);
244
 
 };
245