~ubuntu-branches/ubuntu/oneiric/openssl/oneiric-security

« back to all changes in this revision

Viewing changes to debian/patches/openssl-pod-misspell.patch

  • Committer: Package Import Robot
  • Author(s): Steve Beattie
  • Date: 2011-09-14 22:06:03 UTC
  • mfrom: (11.1.23 sid)
  • Revision ID: package-import@ubuntu.com-20110914220603-tsuxw8z3kt4lx9oc
Tags: 1.0.0e-2ubuntu1
* Resynchronise with Debian, fixes CVE-2011-1945, CVE-2011-3207 and
  CVE-2011-3210 (LP: #850608). Remaining changes:
  - debian/libssl1.0.0.postinst:
    + Display a system restart required notification bubble on libssl1.0.0
      upgrade.
    + Use a different priority for libssl1.0.0/restart-services depending
      on whether a desktop, or server dist-upgrade is being performed.
  - debian/{libssl1.0.0-udeb.dirs, control, rules}: Create
    libssl1.0.0-udeb, for the benefit of wget-udeb (no wget-udeb package
    in Debian).
  - debian/{libcrypto1.0.0-udeb.dirs, libssl1.0.0.dirs, libssl1.0.0.files,
    rules}: Move runtime libraries to /lib, for the benefit of
    wpasupplicant.
  - debian/patches/aesni.patch: Backport Intel AES-NI support, now from
    http://rt.openssl.org/Ticket/Display.html?id=2065 rather than the
    0.9.8 variant.
  - debian/patches/Bsymbolic-functions.patch: Link using
    -Bsymbolic-functions.
  - debian/patches/perlpath-quilt.patch: Don't change perl #! paths under
    .pc.
  - debian/rules:
    + Don't run 'make test' when cross-building.
    + Use host compiler when cross-building.  Patch from Neil Williams.
    + Don't build for processors no longer supported: i486, i586 (on
      i386), v8 (on sparc).
    + Fix Makefile to properly clean up libs/ dirs in clean target.
    + Replace duplicate files in the doc directory with symlinks.
* debian/libssl1.0.0.postinst: only display restart notification on
  servers (LP: #244250)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- a/apps/ca.c
 
2
+++ b/apps/ca.c
 
3
@@ -148,7 +148,7 @@
 
4
 static const char *ca_usage[]={
 
5
 "usage: ca args\n",
 
6
 "\n",
 
7
-" -verbose        - Talk alot while doing things\n",
 
8
+" -verbose        - Talk a lot while doing things\n",
 
9
 " -config file    - A config file\n",
 
10
 " -name arg       - The particular CA definition to use\n",
 
11
 " -gencrl         - Generate a new CRL\n",
 
12
--- a/apps/ecparam.c
 
13
+++ b/apps/ecparam.c
 
14
@@ -105,7 +105,7 @@
 
15
  *                    in the asn1 der encoding
 
16
  *                    possible values: named_curve (default)
 
17
  *                                     explicit
 
18
- * -no_seed         - if 'explicit' parameters are choosen do not use the seed
 
19
+ * -no_seed         - if 'explicit' parameters are chosen do not use the seed
 
20
  * -genkey          - generate ec key
 
21
  * -rand file       - files to use for random number input
 
22
  * -engine e        - use engine e, possibly a hardware device
 
23
@@ -286,7 +286,7 @@
 
24
                BIO_printf(bio_err, "                                   "
 
25
                                " explicit\n");
 
26
                BIO_printf(bio_err, " -no_seed          if 'explicit'"
 
27
-                               " parameters are choosen do not"
 
28
+                               " parameters are chosen do not"
 
29
                                " use the seed\n");
 
30
                BIO_printf(bio_err, " -genkey           generate ec"
 
31
                                " key\n");
 
32
--- a/crypto/evp/encode.c
 
33
+++ b/crypto/evp/encode.c
 
34
@@ -250,7 +250,7 @@
 
35
        /* We parse the input data */
 
36
        for (i=0; i<inl; i++)
 
37
                {
 
38
-               /* If the current line is > 80 characters, scream alot */
 
39
+               /* If the current line is > 80 characters, scream a lot */
 
40
                if (ln >= 80) { rv= -1; goto end; }
 
41
 
 
42
                /* Get char and put it into the buffer */
 
43
--- a/doc/apps/config.pod
 
44
+++ b/doc/apps/config.pod
 
45
@@ -119,7 +119,7 @@
 
46
 information.
 
47
 
 
48
 The section pointed to by B<engines> is a table of engine names (though see
 
49
-B<engine_id> below) and further sections containing configuration informations
 
50
+B<engine_id> below) and further sections containing configuration information
 
51
 specific to each ENGINE.
 
52
 
 
53
 Each ENGINE specific section is used to set default algorithms, load
 
54
--- a/doc/apps/genpkey.pod
 
55
+++ b/doc/apps/genpkey.pod
 
56
@@ -114,6 +114,8 @@
 
57
 
 
58
 The number of bits in the generated parameters. If not specified 1024 is used.
 
59
 
 
60
+=back
 
61
+
 
62
 =head1 DH PARAMETER GENERATION OPTIONS
 
63
 
 
64
 =over 4
 
65
--- a/doc/apps/openssl.pod
 
66
+++ b/doc/apps/openssl.pod
 
67
@@ -287,8 +287,6 @@
 
68
 
 
69
 SHA-1 Digest
 
70
 
 
71
-=back
 
72
-
 
73
 =item B<sha224>
 
74
 
 
75
 SHA-224 Digest
 
76
@@ -305,6 +303,8 @@
 
77
 
 
78
 SHA-512 Digest
 
79
 
 
80
+=back
 
81
+
 
82
 =head2 ENCODING AND CIPHER COMMANDS
 
83
 
 
84
 =over 10
 
85
--- a/doc/apps/req.pod
 
86
+++ b/doc/apps/req.pod
 
87
@@ -159,7 +159,7 @@
 
88
 the algorithm is determined by the parameters. B<algname:file> use algorithm
 
89
 B<algname> and parameter file B<file>: the two algorithms must match or an
 
90
 error occurs. B<algname> just uses algorithm B<algname>, and parameters,
 
91
-if neccessary should be specified via B<-pkeyopt> parameter.
 
92
+if necessary should be specified via B<-pkeyopt> parameter.
 
93
 
 
94
 B<dsa:filename> generates a DSA key using the parameters
 
95
 in the file B<filename>. B<ec:filename> generates EC key (usable both with
 
96
--- a/doc/apps/ts.pod
 
97
+++ b/doc/apps/ts.pod
 
98
@@ -352,7 +352,7 @@
 
99
 
 
100
 This is the main section and it specifies the name of another section
 
101
 that contains all the options for the B<-reply> command. This default
 
102
-section can be overriden with the B<-section> command line switch. (Optional)
 
103
+section can be overridden with the B<-section> command line switch. (Optional)
 
104
 
 
105
 =item B<oid_file>
 
106
 
 
107
@@ -453,7 +453,7 @@
 
108
 =head1 ENVIRONMENT VARIABLES
 
109
 
 
110
 B<OPENSSL_CONF> contains the path of the configuration file and can be
 
111
-overriden by the B<-config> command line option.
 
112
+overridden by the B<-config> command line option.
 
113
 
 
114
 =head1 EXAMPLES
 
115
 
 
116
--- a/doc/apps/tsget.pod
 
117
+++ b/doc/apps/tsget.pod
 
118
@@ -124,7 +124,7 @@
 
119
 =item [request]...
 
120
 
 
121
 List of files containing B<RFC 3161> DER-encoded time stamp requests. If no
 
122
-requests are specifed only one request will be sent to the server and it will be
 
123
+requests are specified only one request will be sent to the server and it will be
 
124
 read from the standard input. (Optional)
 
125
 
 
126
 =back
 
127
--- a/doc/apps/x509v3_config.pod
 
128
+++ b/doc/apps/x509v3_config.pod
 
129
@@ -174,7 +174,7 @@
 
130
 
 
131
 The value of B<dirName> should point to a section containing the distinguished
 
132
 name to use as a set of name value pairs. Multi values AVAs can be formed by
 
133
-preceeding the name with a B<+> character.
 
134
+preceding the name with a B<+> character.
 
135
 
 
136
 otherName can include arbitrary data associated with an OID: the value
 
137
 should be the OID followed by a semicolon and the content in standard