~ubuntu-branches/ubuntu/oneiric/polkit-qt-1/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/kubuntu_01_fix_glib_ftbfs.diff

  • Committer: Bazaar Package Importer
  • Author(s): Jonathan Thomas
  • Date: 2010-11-07 01:18:28 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20101107011828-qf5lzf950ih0l250
Tags: 0.98.1~git20101107-0ubuntu1
* New upstream snapshot:
  - Drop kubuntu_01_fix_glib_ftbfs.diff, accepted upstream
  - Bump build-depend versions on polkit to >= 0.98

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: polkit-qt-1-0.95.1/CMakeLists.txt
2
 
===================================================================
3
 
--- polkit-qt-1-0.95.1.orig/CMakeLists.txt      2010-07-02 09:59:07.735794971 -0400
4
 
+++ polkit-qt-1-0.95.1/CMakeLists.txt   2010-07-02 10:00:48.545794971 -0400
5
 
@@ -17,6 +17,8 @@
6
 
 pkg_check_modules (POLKIT-1 REQUIRED polkit-gobject-1>=0.95)
7
 
 pkg_check_modules (POLKIT-1_AGENT REQUIRED polkit-agent-1>=0.95)
8
 
 
9
 
+add_definitions(-DQT_NO_KEYWORDS)
10
 
+
11
 
 message(STATUS " ${POLKIT-1_INCLUDE_DIRS} ===========")
12
 
 
13
 
 include_directories(
14
 
Index: polkit-qt-1-0.95.1/agent/listeneradapter.cpp
15
 
===================================================================
16
 
--- polkit-qt-1-0.95.1.orig/agent/listeneradapter.cpp   2010-07-02 09:59:04.765794971 -0400
17
 
+++ polkit-qt-1-0.95.1/agent/listeneradapter.cpp        2010-07-02 09:59:21.325794971 -0400
18
 
@@ -61,7 +61,7 @@
19
 
 {
20
 
     Listener *listItem;
21
 
 
22
 
-    foreach(listItem, m_listeners) {
23
 
+    Q_FOREACH(listItem, m_listeners) {
24
 
         Q_ASSERT(listItem);
25
 
 
26
 
         if (listItem->listener() == listener)
27
 
Index: polkit-qt-1-0.95.1/agent/polkitqt1-agent-session.cpp
28
 
===================================================================
29
 
--- polkit-qt-1-0.95.1.orig/agent/polkitqt1-agent-session.cpp   2010-07-02 09:58:56.375794971 -0400
30
 
+++ polkit-qt-1-0.95.1/agent/polkitqt1-agent-session.cpp        2010-07-02 09:59:21.325794971 -0400
31
 
@@ -101,25 +101,25 @@
32
 
 {
33
 
     qDebug() << "COMPLETED";
34
 
     Session *session = (Session *)user_data;
35
 
-    emit((Session *)user_data)->completed(gained_authorization);
36
 
+    Q_EMIT((Session *)user_data)->completed(gained_authorization);
37
 
 }
38
 
 
39
 
 void Session::Private::request(PolkitAgentSession *s, gchar *request, gboolean echo_on, gpointer user_data)
40
 
 {
41
 
     qDebug() << "REQUEST";
42
 
-    emit((Session *)user_data)->request(QString::fromUtf8(request), echo_on);
43
 
+    Q_EMIT((Session *)user_data)->request(QString::fromUtf8(request), echo_on);
44
 
 }
45
 
 
46
 
 void Session::Private::showError(PolkitAgentSession *s, gchar *text, gpointer user_data)
47
 
 {
48
 
     qDebug() << "showError";
49
 
-    emit((Session *)user_data)->showError(QString::fromUtf8(text));
50
 
+    Q_EMIT((Session *)user_data)->showError(QString::fromUtf8(text));
51
 
 }
52
 
 
53
 
 void Session::Private::showInfo(PolkitAgentSession *s, gchar *text, gpointer user_data)
54
 
 {
55
 
     qDebug() << "showInfo";
56
 
-    emit((Session *)user_data)->showInfo(QString::fromUtf8(text));
57
 
+    Q_EMIT((Session *)user_data)->showInfo(QString::fromUtf8(text));
58
 
 }
59
 
 
60
 
 //
61
 
Index: polkit-qt-1-0.95.1/core/polkitqt1-authority.cpp
62
 
===================================================================
63
 
--- polkit-qt-1-0.95.1.orig/core/polkitqt1-authority.cpp        2010-07-02 09:58:38.075794970 -0400
64
 
+++ polkit-qt-1-0.95.1/core/polkitqt1-authority.cpp     2010-07-02 09:59:21.325794971 -0400
65
 
@@ -208,7 +208,7 @@
66
 
     QList<QString> seats;
67
 
     qVariantValue<QDBusArgument> (msg.arguments()[0]) >> seats;
68
 
     // it can be multiple seats present so connect all their signals
69
 
-    foreach(const QString &seat, seats) {
70
 
+    Q_FOREACH(const QString &seat, seats) {
71
 
         seatSignalsConnect(seat);
72
 
     }
73
 
 }
74
 
@@ -244,7 +244,7 @@
75
 
 void Authority::Private::dbusFilter(const QDBusMessage &message)
76
 
 {
77
 
     if (message.type() == QDBusMessage::SignalMessage) {
78
 
-        emit q->consoleKitDBChanged();
79
 
+        Q_EMIT q->consoleKitDBChanged();
80
 
 
81
 
         // TODO: Test this with the multiseat support
82
 
         if (message.member() == "SeatAdded")
83
 
@@ -278,7 +278,7 @@
84
 
 
85
 
 void Authority::Private::pk_config_changed()
86
 
 {
87
 
-    emit Authority::instance()->configChanged();
88
 
+    Q_EMIT Authority::instance()->configChanged();
89
 
 }
90
 
 
91
 
 PolkitAuthority *Authority::polkitAuthority() const
92
 
@@ -361,7 +361,7 @@
93
 
         return;
94
 
     }
95
 
     if (pkResult != NULL) {
96
 
-        emit authority->checkAuthorizationFinished(polkitResultToResult(pkResult));
97
 
+        Q_EMIT authority->checkAuthorizationFinished(polkitResultToResult(pkResult));
98
 
         g_object_unref(pkResult);
99
 
     } else {
100
 
         authority->d->setError(E_UnknownResult);
101
 
@@ -421,7 +421,7 @@
102
 
         return;
103
 
     }
104
 
 
105
 
-    emit authority->enumerateActionsFinished(actionsToListAndFree(list));
106
 
+    Q_EMIT authority->enumerateActionsFinished(actionsToListAndFree(list));
107
 
 }
108
 
 
109
 
 void Authority::enumerateActionsCancel()
110
 
@@ -491,7 +491,7 @@
111
 
         return;
112
 
     }
113
 
 
114
 
-    emit authority->registerAuthenticationAgentFinished(res);
115
 
+    Q_EMIT authority->registerAuthenticationAgentFinished(res);
116
 
 }
117
 
 
118
 
 void Authority::registerAuthenticationAgentCancel()
119
 
@@ -559,7 +559,7 @@
120
 
         return;
121
 
     }
122
 
 
123
 
-    emit authority->unregisterAuthenticationAgentFinished(res);
124
 
+    Q_EMIT authority->unregisterAuthenticationAgentFinished(res);
125
 
 }
126
 
 
127
 
 void Authority::unregisterAuthenticationAgentCancel()
128
 
@@ -626,7 +626,7 @@
129
 
         return;
130
 
     }
131
 
 
132
 
-    emit authority->authenticationAgentResponseFinished(res);
133
 
+    Q_EMIT authority->authenticationAgentResponseFinished(res);
134
 
 }
135
 
 
136
 
 void Authority::authenticationAgentResponseCancel()
137
 
@@ -685,7 +685,7 @@
138
 
 
139
 
     g_list_free(glist);
140
 
 
141
 
-    emit authority->enumerateTemporaryAuthorizationsFinished(res);
142
 
+    Q_EMIT authority->enumerateTemporaryAuthorizationsFinished(res);
143
 
 }
144
 
 
145
 
 void Authority::enumerateTemporaryAuthorizationsCancel()
146
 
@@ -741,7 +741,7 @@
147
 
         return;
148
 
     }
149
 
 
150
 
-    emit authority->revokeTemporaryAuthorizationsFinished(res);
151
 
+    Q_EMIT authority->revokeTemporaryAuthorizationsFinished(res);
152
 
 }
153
 
 
154
 
 void Authority::revokeTemporaryAuthorizationsCancel()
155
 
@@ -797,7 +797,7 @@
156
 
         return;
157
 
     }
158
 
 
159
 
-    emit authority->revokeTemporaryAuthorizationFinished(res);
160
 
+    Q_EMIT authority->revokeTemporaryAuthorizationFinished(res);
161
 
 }
162
 
 
163
 
 void Authority::revokeTemporaryAuthorizationCancel()
164
 
Index: polkit-qt-1-0.95.1/gui/polkitqt1-gui-action.cpp
165
 
===================================================================
166
 
--- polkit-qt-1-0.95.1.orig/gui/polkitqt1-gui-action.cpp        2010-07-02 09:58:00.195794972 -0400
167
 
+++ polkit-qt-1-0.95.1/gui/polkitqt1-gui-action.cpp     2010-07-02 09:59:21.325794971 -0400
168
 
@@ -127,8 +127,8 @@
169
 
     switch (d->pkResult) {
170
 
     case Authority::Yes:
171
 
     case Authority::Challenge:
172
 
-        // just emit the 'activated' signal
173
 
-        emit authorized();
174
 
+        // just Q_EMIT the 'activated' signal
175
 
+        Q_EMIT authorized();
176
 
         return true;
177
 
         break;
178
 
     default:
179
 
@@ -141,7 +141,7 @@
180
 
              * Hence, they probably have a good reason for doing
181
 
              * this so do let the 'activate' signal propagate..
182
 
              */
183
 
-            emit authorized();
184
 
+            Q_EMIT authorized();
185
 
             return true;
186
 
         }
187
 
         break;
188
 
@@ -207,7 +207,7 @@
189
 
         }
190
 
         break;
191
 
     }
192
 
-    emit parent->dataChanged();
193
 
+    Q_EMIT parent->dataChanged();
194
 
 }
195
 
 
196
 
 void Action::Private::configChanged()
197
 
Index: polkit-qt-1-0.95.1/gui/polkitqt1-gui-actionbutton.cpp
198
 
===================================================================
199
 
--- polkit-qt-1-0.95.1.orig/gui/polkitqt1-gui-actionbutton.cpp  2010-07-02 09:57:22.455794970 -0400
200
 
+++ polkit-qt-1-0.95.1/gui/polkitqt1-gui-actionbutton.cpp       2010-07-02 09:59:21.315794971 -0400
201
 
@@ -57,7 +57,7 @@
202
 
 {
203
 
     Q_Q(ActionButton);
204
 
 
205
 
-    foreach(QAbstractButton *ent, buttons) {
206
 
+    Q_FOREACH(QAbstractButton *ent, buttons) {
207
 
         ent->setVisible(q->isVisible());
208
 
         ent->setEnabled(q->isEnabled());
209
 
         ent->setText(q->text());
210
 
@@ -81,7 +81,7 @@
211
 
     Q_D(ActionButton);
212
 
 
213
 
     bool tg = false;
214
 
-    foreach(QAbstractButton *ent, d->buttons) {
215
 
+    Q_FOREACH(QAbstractButton *ent, d->buttons) {
216
 
         if (ent->isCheckable()) {
217
 
             // we set the the current Action state
218
 
             ent->setChecked(isChecked());
219
 
@@ -102,7 +102,7 @@
220
 
     Q_D(ActionButton);
221
 
 
222
 
     // First, let's clear the list
223
 
-    foreach(QAbstractButton *ent, d->buttons) {
224
 
+    Q_FOREACH(QAbstractButton *ent, d->buttons) {
225
 
         d->removeButton(ent);
226
 
     }
227
 
 
228
 
@@ -124,7 +124,7 @@
229
 
         // if we are not checkable BUT the button
230
 
         // is (eg a QCheckBox) we should set all buttons to
231
 
         // checkable.
232
 
-        foreach(QAbstractButton *ent, buttons) {
233
 
+        Q_FOREACH(QAbstractButton *ent, buttons) {
234
 
             ent->setCheckable(true);
235
 
         }
236
 
         // set the checkable state of Action to store the initial state
237
 
@@ -156,7 +156,7 @@
238
 
 {
239
 
     Q_Q(ActionButton);
240
 
 
241
 
-    emit q->clicked(qobject_cast<QAbstractButton *>(q->sender()), c);
242
 
+    Q_EMIT q->clicked(qobject_cast<QAbstractButton *>(q->sender()), c);
243
 
 }
244
 
 
245
 
 }
246
 
Index: polkit-qt-1-0.95.1/gui/polkitqt1-gui-actionbuttons.cpp
247
 
===================================================================
248
 
--- polkit-qt-1-0.95.1.orig/gui/polkitqt1-gui-actionbuttons.cpp 2010-07-02 09:57:55.885794970 -0400
249
 
+++ polkit-qt-1-0.95.1/gui/polkitqt1-gui-actionbuttons.cpp      2010-07-02 09:59:21.315794971 -0400
250
 
@@ -40,7 +40,7 @@
251
 
 
252
 
 void ActionButtons::setButtons(const QList<QAbstractButton *> &buttons)
253
 
 {
254
 
-    foreach(QAbstractButton *ent, buttons) {
255
 
+    Q_FOREACH(QAbstractButton *ent, buttons) {
256
 
         addButton(ent);
257
 
     }
258
 
 }