~ubuntu-branches/ubuntu/oneiric/postgresql-9.1/oneiric-updates

« back to all changes in this revision

Viewing changes to debian/patches/51-default-sockets-in-var.patch

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt
  • Date: 2011-05-29 19:34:38 UTC
  • Revision ID: james.westby@ubuntu.com-20110529193438-3oqsycz86037p2tf
Tags: 9.1~beta1-4
* debian/control: Add postgresql-common dependency to -server-dev, so that
  we get the pg_config diversion.
* 52-tutorial-README.patch: Fix server-dev version in comment.
* 51-default-sockets-in-var.patch: Move the pg_regress patching parts to
  debian/pg_regress-in-tmp.patch and temporarily apply it only for running
  the local checks. In the installed system it seems we actually do want it
  to use the /var/run/postgresql socket dir. (Closes: #554166)

Show diffs side-by-side

added added

removed removed

Lines of Context:
7
7
clusters will still use /tmp). Since system cluster are by far the common case,
8
8
set it as default.
9
9
 
10
 
As a consequence of this, we now need to explicitly specify the pg_regress
11
 
socket dir as /tmp, since it runs the server as the invoking user.
12
 
 
13
10
Index: postgresql-9.1-9.1~beta1/src/include/pg_config_manual.h
14
11
===================================================================
15
12
--- postgresql-9.1-9.1~beta1.orig/src/include/pg_config_manual.h        2011-04-27 23:17:22.000000000 +0200
23
20
 
24
21
 /*
25
22
  * The random() function is expected to yield values between 0 and
26
 
Index: postgresql-9.1-9.1~beta1/src/test/regress/pg_regress.c
27
 
===================================================================
28
 
--- postgresql-9.1-9.1~beta1.orig/src/test/regress/pg_regress.c 2011-04-27 23:17:22.000000000 +0200
29
 
+++ postgresql-9.1-9.1~beta1/src/test/regress/pg_regress.c      2011-05-10 11:24:47.331949788 +0200
30
 
@@ -906,7 +906,7 @@
31
 
 
32
 
        /* And now we can build and execute the shell command */
33
 
        snprintf(psql_cmd, sizeof(psql_cmd),
34
 
-                        SYSTEMQUOTE "\"%s%spsql\" -X -c \"%s\" \"%s\"" SYSTEMQUOTE,
35
 
+                        SYSTEMQUOTE "\"%s%spsql\" -h /tmp -X -c \"%s\" \"%s\"" SYSTEMQUOTE,
36
 
                         psqldir ? psqldir : "",
37
 
                         psqldir ? "/" : "",
38
 
                         query_escaped,
39
 
@@ -2207,7 +2207,7 @@
40
 
                 * Check if there is a postmaster running already.
41
 
                 */
42
 
                snprintf(buf2, sizeof(buf2),
43
 
-                                SYSTEMQUOTE "\"%s/psql\" -X postgres <%s 2>%s" SYSTEMQUOTE,
44
 
+                                SYSTEMQUOTE "\"%s/psql\" -h /tmp -X postgres <%s 2>%s" SYSTEMQUOTE,
45
 
                                 bindir, DEVNULL, DEVNULL);
46
 
 
47
 
                for (i = 0; i < 16; i++)
48
 
@@ -2239,7 +2239,7 @@
49
 
                 */
50
 
                header(_("starting postmaster"));
51
 
                snprintf(buf, sizeof(buf),
52
 
-                                SYSTEMQUOTE "\"%s/postgres\" -D \"%s/data\" -F%s -c \"listen_addresses=%s\" > \"%s/log/postmaster.log\" 2>&1" SYSTEMQUOTE,
53
 
+                                SYSTEMQUOTE "\"%s/postgres\" -D \"%s/data\" -k /tmp -F%s -c \"listen_addresses=%s\" > \"%s/log/postmaster.log\" 2>&1" SYSTEMQUOTE,
54
 
                                 bindir, temp_install,
55
 
                                 debug ? " -d 5" : "",
56
 
                                 hostname ? hostname : "",
57
 
Index: postgresql-9.1-9.1~beta1/src/test/regress/pg_regress_main.c
58
 
===================================================================
59
 
--- postgresql-9.1-9.1~beta1.orig/src/test/regress/pg_regress_main.c    2011-04-27 23:17:22.000000000 +0200
60
 
+++ postgresql-9.1-9.1~beta1/src/test/regress/pg_regress_main.c 2011-05-10 11:25:19.291949792 +0200
61
 
@@ -64,7 +64,7 @@
62
 
                                                   "%s ", launcher);
63
 
 
64
 
        snprintf(psql_cmd + offset, sizeof(psql_cmd) - offset,
65
 
-                        SYSTEMQUOTE "\"%s%spsql\" -X -a -q -d \"%s\" < \"%s\" > \"%s\" 2>&1" SYSTEMQUOTE,
66
 
+                        SYSTEMQUOTE "\"%s%spsql\" -h /tmp -X -a -q -d \"%s\" < \"%s\" > \"%s\" 2>&1" SYSTEMQUOTE,
67
 
                         psqldir ? psqldir : "",
68
 
                         psqldir ? "/" : "",
69
 
                         dblist->str,