~ubuntu-branches/ubuntu/oneiric/pulseaudio/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/0003-fix-uploading-of-samples-into-PA.-Problem-discovered.patch

  • Committer: Bazaar Package Importer
  • Author(s): Daniel T Chen
  • Date: 2007-12-04 00:56:08 UTC
  • mfrom: (1.1.3 upstream)
  • Revision ID: james.westby@ubuntu.com-20071204005608-y1xqvcu45g1yxtlu
Tags: 0.9.8-1ubuntu1
"Hail our new PulseAudio overlords (part two)."

* Merge from Debian unstable.
* Ubuntu-specific changes:
  - debian/control:
    + Don't build-depend on libjack0.100.0-dev or build jack module
      packages,
    + Update pulseaudio's Recommends and Suggests to accomodate
      existing promoted main packages,
    + Explicitly mention pasuspender in pulseaudio-utils's long
      description,
    + Add Vcs-Bzr URI,
    + Adhere to DebianMaintainerField;
  - debian/rules: Use multiuser for update-rc.d;
  - debian/patches/series: Retain the exclusion of
    0001-Set-ESD-socket-to-tmp-.esd-socket-to-match-up-with.patch.
* Dropped Ubuntu-specific change (absorbed into Debian source):
  debian/patches/0002-Double-esound-maximum-sample-size.patch.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From 50b9a0cc8da84f848f0e9099c484edfdec2a92db Mon Sep 17 00:00:00 2001
 
2
From: Lennart Poettering <lennart@poettering.net>
 
3
Date: Thu, 22 Nov 2007 15:09:00 +0000
 
4
Subject: [PATCH] fix uploading of samples into PA. Problem discovered by Colin Guthrie
 
5
 
 
6
git-svn-id: svn://svn.0pointer.net/pulseaudio/trunk@2074 fefdeb5f-60dc-0310-8127-8f9354f1896f
 
7
---
 
8
 src/pulse/stream.c |    2 +-
 
9
 1 files changed, 1 insertions(+), 1 deletions(-)
 
10
 
 
11
diff --git a/src/pulse/stream.c b/src/pulse/stream.c
 
12
index 3e2d455..8ec348f 100644
 
13
--- a/src/pulse/stream.c
 
14
+++ b/src/pulse/stream.c
 
15
@@ -586,7 +586,7 @@ void pa_create_stream_callback(pa_pdispatch *pd, uint32_t command, PA_GCC_UNUSED
 
16
         }
 
17
     }
 
18
 
 
19
-    if (s->context->version >= 12) {
 
20
+    if (s->context->version >= 12 && s->direction != PA_STREAM_UPLOAD) {
 
21
         pa_sample_spec ss;
 
22
         pa_channel_map cm;
 
23
         const char *dn = NULL;