~ubuntu-branches/ubuntu/oneiric/python-distutils-extra/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/debian-changes-2.22-3

  • Committer: Bazaar Package Importer
  • Author(s): Martin Pitt, Martin Pitt, Didier Roche
  • Date: 2010-11-03 22:37:27 UTC
  • Revision ID: james.westby@ubuntu.com-20101103223727-myfre6qawqa7ok9v
Tags: 2.22-3
[ Martin Pitt ]
* auto.py: Skip setup.py when calculating automatic requires, since
  modules from that script are just build dependencies. Thanks Michael
  Terry! (LP: #643655)
* python-mkdebian: Update python-mkdebian's generated copyright fields with
  latest names/values from http://dep.debian.net/deps/dep5/. Thanks Michael
  Terry!
* Rebuild against Python 2.7 in Ubuntu. (LP: #670188)

[ Didier Roche ]
* Return an error when can't update changelog (LP: #656950)
* Add --force-copyright to force copyright file to be recreated
  (LP: #656943)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Upstream changes introduced in version 2.22-3
 
2
 This patch has been created by dpkg-source during the package build.
 
3
 Here's the last changelog entry, hopefully it gives details on why
 
4
 those changes were made:
 
5
 .
 
6
 python-distutils-extra (2.22-3) unstable; urgency=low
 
7
 .
 
8
   [ Martin Pitt ]
 
9
   * auto.py: Skip setup.py when calculating automatic requires, since
 
10
     modules from that script are just build dependencies. Thanks Michael
 
11
     Terry! (LP: #643655)
 
12
   * python-mkdebian: Update python-mkdebian's generated copyright fields with
 
13
     latest names/values from http://dep.debian.net/deps/dep5/. Thanks Michael
 
14
     Terry!
 
15
   * Rebuild against Python 2.7 in Ubuntu. (LP: #670188)
 
16
 .
 
17
   [ Didier Roche ]
 
18
   * Return an error when can't update changelog (LP: #656950)
 
19
   * Add --force-copyright to force copyright file to be recreated
 
20
     (LP: #656943)
 
21
 .
 
22
 The person named in the Author field signed this changelog entry.
 
23
Author: Martin Pitt <mpitt@debian.org>
 
24
Bug-Ubuntu: https://bugs.launchpad.net/bugs/643655
 
25
Bug-Ubuntu: https://bugs.launchpad.net/bugs/656943
 
26
Bug-Ubuntu: https://bugs.launchpad.net/bugs/656950
 
27
Bug-Ubuntu: https://bugs.launchpad.net/bugs/670188
 
28
 
 
29
---
 
30
The information above should follow the Patch Tagging Guidelines, please
 
31
checkout http://dep.debian.net/deps/dep3/ to learn about the format. Here
 
32
are templates for supplementary fields that you might want to add:
 
33
 
 
34
Origin: <vendor|upstream|other>, <url of original patch>
 
35
Bug: <url in upstream bugtracker>
 
36
Bug-Debian: http://bugs.debian.org/<bugnumber>
 
37
Bug-Ubuntu: https://launchpad.net/bugs/<bugnumber>
 
38
Forwarded: <no|not-needed|url proving that it has been forwarded>
 
39
Reviewed-By: <name and email of someone who approved the patch>
 
40
Last-Update: <YYYY-MM-DD>
 
41
 
 
42
--- python-distutils-extra-2.22.orig/DistUtilsExtra/auto.py
 
43
+++ python-distutils-extra-2.22/DistUtilsExtra/auto.py
 
44
@@ -379,6 +379,8 @@ def __requires(attrs, src_all):
 
45
 
 
46
     # iterate over all *.py and scripts which are Python
 
47
     for s in src_all:
 
48
+        if s == 'setup.py':
 
49
+            continue
 
50
         if s.startswith('data' + os.path.sep):
 
51
             continue
 
52
         ext = os.path.splitext(s)[1]
 
53
--- python-distutils-extra-2.22.orig/DistUtilsExtra/command/check.py
 
54
+++ python-distutils-extra-2.22/DistUtilsExtra/command/check.py
 
55
@@ -1,20 +1,7 @@
 
56
 # DistUtilsExtra.command.check - check command for DistUtilsExtra
 
57
 #
 
58
 # Author: Rodney Dawes <rodney.dawes@canonical.com>
 
59
-#
 
60
 # Copyright 2009 Canonical Ltd.
 
61
-#
 
62
-# This program is free software: you can redistribute it and/or modify it 
 
63
-# under the terms of the GNU General Public License version 3, as published 
 
64
-# by the Free Software Foundation.
 
65
-#
 
66
-# This program is distributed in the hope that it will be useful, but 
 
67
-# WITHOUT ANY WARRANTY; without even the implied warranties of 
 
68
-# MERCHANTABILITY, SATISFACTORY QUALITY, or FITNESS FOR A PARTICULAR 
 
69
-# PURPOSE.  See the GNU General Public License for more details.
 
70
-#
 
71
-# You should have received a copy of the GNU General Public License along 
 
72
-# with this program.  If not, see <http://www.gnu.org/licenses/>.
 
73
 
 
74
 """DistUtilsExtra.command.check
 
75
 
 
76
--- python-distutils-extra-2.22.orig/test/auto.py
 
77
+++ python-distutils-extra-2.22/test/auto.py
 
78
@@ -9,6 +9,10 @@ class T(unittest.TestCase):
 
79
         self.src = tempfile.mkdtemp()
 
80
 
 
81
         self._mksrc('setup.py', '''
 
82
+# ignore warning about import from local path
 
83
+import warnings
 
84
+warnings.filterwarnings('ignore', 'Module DistUtilsExtra was already imported from.*')
 
85
+
 
86
 from DistUtilsExtra.auto import setup
 
87
 
 
88
 setup(
 
89
@@ -707,7 +711,7 @@ print ('import iamnota.module')
 
90
 
 
91
         # check requires
 
92
         req = [prop.split(' ', 1)[1] for prop in egg if prop.startswith('Requires: ')]
 
93
-        self.assertEqual(set(req), set(['DistUtilsExtra.auto', 'httplib2', 'pkg_resources']))
 
94
+        self.assertEqual(set(req), set(['httplib2', 'pkg_resources']))
 
95
 
 
96
     def test_help(self):
 
97
         '''Docbook XML help'''