~ubuntu-branches/ubuntu/oneiric/samba/oneiric

« back to all changes in this revision

Viewing changes to debian/patches/fix-lpbug-393012.patch

  • Committer: Bazaar Package Importer
  • Author(s): Chuck Short
  • Date: 2010-12-08 00:16:04 UTC
  • mfrom: (0.39.7 sid)
  • Revision ID: james.westby@ubuntu.com-20101208001604-sv2xvi0e8n2z89hl
Tags: 2:3.5.6~dfsg-3ubuntu1
* Merge from debian unstable.  Remaining changes:
  + debian/patches/VERSION.patch:
    - set SAMBA_VERSION_SUFFIX to Ubuntu.
  + debian/smb.conf:
    - add "(Samba, Ubuntu)" to server string.
    - comment out the default [homes] share, and add a comment about
      "valid users = %S" to show users how to restrict access to
      \\server\username to only username.
    - Set 'usershare allow guests', so that usershare admins are 
      allowed to create public shares in addition to authenticated
      ones.
    - add map to guest = Bad user, maps bad username to guest access. 
  + debian/samba-common.config:
    - Do not change priority to high if dhclient3 is installed.
    - Use priority medium instead of high for the workgroup question.
  + debian/mksmbpasswd.awk:
    - Do not add user with UID less than 1000 to smbpasswd
  + debian/control:
    - Make libwbclient0 replace/conflict with hardy's likewise-open.
    - Don't build against or suggest ctdb.
    - Add dependency on samba-common-bin to samba.
    - Add cuups breaks to push the package to aslo upgrade cups (LP: #639768)
  + debian/rules:
    - enable "native" PIE hardening.
    - Add BIND_NOW to maximize benefit of RELRO hardening.
  + Add ufw integration:
    - Created debian/samba.ufw.profile
    - debian/rules, debian/samba.dirs, debian/samba.files: install
      profile
    - debian/control: have samba suggest ufw
  + Add apport hook:
    - Created debian/source_samba.py.
    - debian/rules, debian/samba.dirs, debian/samba-common-bin.files: install
  + Switch to upstart:
    - Add debian/samba.{nmbd,smbd}.upstart.
    - Don't ship the /etc/network/if-up.d file.
  + debian/samba.postinst: 
    - Fixed bashism.
    - Avoid scary pdbedit warnings on first import.
  + debian/samba-common.postinst: Add more informative error message for
    the case where smb.conf was manually deleted
  + debian/samba.logrotate: Make it upstart compatible
  + debian/samba-common.dhcp: Fix typo to get a proper parsing in
    /etc/samba/dhcp.
  + Dropped:
    - debian/patches/fix-lpbug-393012.patch: Dropped in favor of debian's patch.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Naurp samba-3.5.6.orig//source3/libsmb/clireadwrite.c samba-3.5.6//source3/libsmb/clireadwrite.c
2
 
--- samba-3.5.6.orig//source3/libsmb/clireadwrite.c     2010-10-07 12:41:16.000000000 -0400
3
 
+++ samba-3.5.6//source3/libsmb/clireadwrite.c  2010-11-26 09:58:51.464107999 -0500
4
 
@@ -704,8 +704,7 @@ static bool cli_issue_write(struct cli_s
5
 
                                off_t offset,
6
 
                                uint16 mode,
7
 
                                const char *buf,
8
 
-                               size_t size,
9
 
-                               int i)
10
 
+                               size_t size)
11
 
 {
12
 
        char *p;
13
 
        bool large_writex = false;
14
 
@@ -779,8 +778,6 @@ static bool cli_issue_write(struct cli_s
15
 
                cli_setup_bcc(cli, p+size);
16
 
        }
17
 
 
18
 
-       SSVAL(cli->outbuf,smb_mid,cli->mid + i);
19
 
-
20
 
        show_msg(cli->outbuf);
21
 
        if (direct_writes) {
22
 
                /* For direct writes we now need to write the data
23
 
@@ -829,7 +826,7 @@ ssize_t cli_write(struct cli_state *cli,
24
 
                        if (!cli_issue_write(cli, fnum, offset + bsent,
25
 
                                        write_mode,
26
 
                                        buf + bsent,
27
 
-                                       size1, issued))
28
 
+                                       size1))
29
 
                                return -1;
30
 
                        issued++;
31
 
                }