~ubuntu-branches/ubuntu/oneiric/soprano/oneiric-proposed

« back to all changes in this revision

Viewing changes to debian/patches/02_disable_usr_lib_install_rpath.diff

  • Committer: Bazaar Package Importer
  • Author(s): Modestas Vainius
  • Date: 2011-03-23 19:10:49 UTC
  • mfrom: (1.1.34 upstream) (12.2.10 sid)
  • Revision ID: james.westby@ubuntu.com-20110323191049-k8osjcachf4fyl5e
Tags: 2.6.0+dfsg.1-3
Fix symbol files to support both gcc 4.4 and Qt 4.6 configurations.
Fixes FTBFS.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Do not set install RPATH to /usr/lib by default
2
 
             /usr/lib RPATH is disallowed on Debian systems
3
 
             and is a bad practice in general
4
 
Author: Modestas Vainius <modax@debian.org>
5
 
Forwarded: not-needed
6
 
 
7
 
--- a/CMakeLists.txt
8
 
+++ b/CMakeLists.txt
9
 
@@ -129,15 +129,6 @@ set(INCLUDE_INSTALL_DIR      "${CMAKE_IN
10
 
 set(PKGCONFIG_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}/pkgconfig/" CACHE STRING "Base directory for pkgconfig files")
11
 
 
12
 
 
13
 
-# Set up RPATH handling, so the libs are found if they are installed to a non-standard location.
14
 
-# By default cmake builds the targets with full RPATH to everything in the build directory,
15
 
-# but then removes the RPATH when installing.
16
 
-# These two options below make it set the RPATH of the installed targets to all
17
 
-# RPATH directories outside the current CMAKE_BINARY_DIR and also the library
18
 
-# install directory. Alex
19
 
-set(CMAKE_INSTALL_RPATH_USE_LINK_PATH  TRUE)
20
 
-set(CMAKE_INSTALL_RPATH                ${LIB_DESTINATION} )
21
 
-
22
 
 if(APPLE)
23
 
    set(CMAKE_INSTALL_NAME_DIR ${LIB_DESTINATION})
24
 
 endif(APPLE)