~ubuntu-branches/ubuntu/oneiric/xserver-xorg-input-synaptics/oneiric-updates

« back to all changes in this revision

Viewing changes to debian/patches/117_gestures.patch

  • Committer: Bazaar Package Importer
  • Author(s): Timo Aaltonen
  • Date: 2011-07-05 16:40:31 UTC
  • mfrom: (1.2.3 upstream) (0.3.6 sid)
  • Revision ID: james.westby@ubuntu.com-20110705164031-in4m0pac6i5575uo
Tags: 1.4.1-1ubuntu1
* Merge from Debian unstable, remaining changes:
  - 101_resolution_detect_option.patch:
    + Provide an option to prevent synaptics from communicating the
      touchpad size to the xserver. (LP: 327428)
  - 103_enable_cornertapping.patch:
    + Enable right/middle clicks by tapping in the bottom- and top-right
      corners.
  - 104_always_enable_tapping.patch:
    + Enable tapping regardless of the presence of physical buttons.
  - 106_always_enable_vert_edge_scroll.patch:
    + Enable vertical edge tapping by default even if we enable two-finger
      scrolling as well.
  - 115_evdev_only.patch:
    + Only bind to /dev/input/event* evdev devices (LP 624985)
  - 116_xi2_1.patch:
  - 117_gestures.patch:
    + multitouch and uTouch gesture support
  - 118_quell_error_msg.patch:
    + Don't print error "Unable to find a synaptics device" when used
      on system that doesn't have a touchpad anyway. (LP: 716712)
  - 119_active_area_touches.patch:
  - 120_active_touches_num_fingers.patch:
  - 121_semi-mt_num_fingers.patch:
    + Fix handling for SemiMultitouch trackpads with integrated buttons
      (LP: 736523)
  - 122_revert_pressure_finger_default.patch:
    + Fix spurious right click events on some trackpads (LP: 742213)
  - 123_order_ProcessTouch_for_numFingers.patch:
    + Fix jumpy cursor on multitouch trackpads (LP: 751525)
  - 124_syndaemon_events.patch:
    + Drain spurious events from XRecord connection as a work around
      for a buggy X server. (LP: 754470)
  - debian/control:
    + Add depends on libmtdev and libutouch-grail
    + Build-depend on multitouch-enabled inputproto.
    + Depend on multitouch-enabled xserver.
    + Depend on udev.
    + Move libxtst-dev to Build-Conflicts so syndaemon does not use XRecord,
      preventing a wide range of crashes in _CallCallbacks. (LP: 774978)
  - debian/gbp.conf:
    + Specify ‘ubuntu’ branch.
  - debian/local/51-synaptics-quirks.conf:
    + Split out our synaptics quirks into 51-synaptics-quirks.conf
  - debian/local/66-xorg-synaptics.rules:
    + Add the udev rule back for tagging specific machines to be quirked.
  - debian/xserver-xorg-input-synaptics.postinst.in:
    + Trigger udev to pick up new udev rules
* Drop 114_jumpy_cursor_first_part.patch, fixed upstream.
* Update 115_evdev_only.patch to apply.
* Update 117_gestures.patch to apply.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- a/configure.ac
2
 
+++ b/configure.ac
3
 
@@ -104,6 +104,10 @@ case "${host}" in
 
1
Index: xserver-xorg-input-synaptics/configure.ac
 
2
===================================================================
 
3
--- xserver-xorg-input-synaptics.orig/configure.ac      2011-07-05 11:54:55.781347674 +0300
 
4
+++ xserver-xorg-input-synaptics/configure.ac   2011-07-05 11:55:02.771347676 +0300
 
5
@@ -104,6 +104,10 @@
4
6
 
5
7
        # Obtain compiler/linker options for mtdev
6
8
        PKG_CHECK_MODULES(MTDEV, mtdev)
11
13
        ;;
12
14
 *freebsd* | *openbsd* | *netbsd* | *dragonfly*)
13
15
        AC_MSG_RESULT([psmcomm])
14
 
--- a/src/Makefile.am
15
 
+++ b/src/Makefile.am
16
 
@@ -39,8 +39,8 @@ AM_CFLAGS = $(XORG_CFLAGS)
 
16
Index: xserver-xorg-input-synaptics/src/Makefile.am
 
17
===================================================================
 
18
--- xserver-xorg-input-synaptics.orig/src/Makefile.am   2011-07-05 11:54:55.781347674 +0300
 
19
+++ xserver-xorg-input-synaptics/src/Makefile.am        2011-07-05 11:55:02.771347676 +0300
 
20
@@ -39,8 +39,8 @@
17
21
 
18
22
 if BUILD_EVENTCOMM
19
23
 @DRIVER_NAME@_drv_la_SOURCES += \
24
28
 endif
25
29
 
26
30
 if BUILD_PSMCOMM
27
 
--- a/src/eventcomm.c
28
 
+++ b/src/eventcomm.c
 
31
Index: xserver-xorg-input-synaptics/src/eventcomm.c
 
32
===================================================================
 
33
--- xserver-xorg-input-synaptics.orig/src/eventcomm.c   2011-07-05 11:54:55.781347674 +0300
 
34
+++ xserver-xorg-input-synaptics/src/eventcomm.c        2011-07-05 11:55:02.771347676 +0300
29
35
@@ -43,6 +43,7 @@
30
36
 #include <xf86.h>
31
37
 #include <xorg/xserver-properties.h>
34
40
 
35
41
 
36
42
 #define SYSCALL(call) while (((call) == -1) && (errno == EINTR))
37
 
@@ -186,28 +187,13 @@ EventDeviceOnHook(InputInfoPtr pInfo, Sy
 
43
@@ -186,28 +187,13 @@
38
44
             ecpriv->cur_slot = abs.value;
39
45
     }
40
46
 
65
71
 }
66
72
 
67
73
 static void
68
 
@@ -491,9 +477,8 @@ SynapticsReadEvent(InputInfoPtr pInfo, s
 
74
@@ -499,9 +485,8 @@
69
75
     int rc = TRUE;
70
76
     ssize_t len;
71
77
 
77
83
     else
78
84
         len = read(pInfo->fd, ev, sizeof(*ev));
79
85
 
80
 
@@ -503,166 +488,182 @@ SynapticsReadEvent(InputInfoPtr pInfo, s
 
86
@@ -511,167 +496,182 @@
81
87
         if (errno != EAGAIN)
82
88
             xf86MsgVerb(X_NONE, 0, "%s: Read error %s\n", pInfo->name, strerror(errno));
83
89
         rc = FALSE;
216
222
                 ProcessTouch(pInfo, priv);
217
223
-               return TRUE;
218
224
-           }
 
225
-           break;
219
226
-       case EV_KEY:
220
227
-           v = (ev.value ? TRUE : FALSE);
221
228
-           switch (ev.code) {
402
409
     return FALSE;
403
410
 }
404
411
 
405
 
--- a/src/eventcomm.h
406
 
+++ b/src/eventcomm.h
 
412
Index: xserver-xorg-input-synaptics/src/eventcomm.h
 
413
===================================================================
 
414
--- xserver-xorg-input-synaptics.orig/src/eventcomm.h   2011-07-05 11:54:55.781347674 +0300
 
415
+++ xserver-xorg-input-synaptics/src/eventcomm.h        2011-07-05 11:55:02.771347676 +0300
407
416
@@ -32,12 +32,15 @@
408
417
 #include <X11/Xdefs.h>
409
418
 #include <xorg/input.h>
420
429
 
421
430
 typedef struct {
422
431
     BOOL need_grab;
423
 
@@ -54,6 +57,13 @@ typedef struct {
 
432
@@ -54,6 +57,13 @@
424
433
     int num_mt_axes;
425
434
     int num_touches;
426
435
     struct mtdev *mtdev;
434
443
+extern void GrailClose(InputInfoPtr pInfo);
435
444
+
436
445
 #endif /* _EVENTCOMM_H_ */
437
 
--- /dev/null
438
 
+++ b/src/grail.c
 
446
Index: xserver-xorg-input-synaptics/src/grail.c
 
447
===================================================================
 
448
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
449
+++ xserver-xorg-input-synaptics/src/grail.c    2011-07-05 11:55:02.771347676 +0300
439
450
@@ -0,0 +1,376 @@
440
451
+/*
441
452
+ * Copyright © 2010 Canonical, Ltd.
813
824
+        ecpriv->grail = NULL;
814
825
+    }
815
826
+}
816
 
--- a/src/synaptics.c
817
 
+++ b/src/synaptics.c
818
 
@@ -119,7 +119,6 @@ static InputInfoPtr SynapticsPreInit(Inp
 
827
Index: xserver-xorg-input-synaptics/src/synaptics.c
 
828
===================================================================
 
829
--- xserver-xorg-input-synaptics.orig/src/synaptics.c   2011-07-05 11:54:55.781347674 +0300
 
830
+++ xserver-xorg-input-synaptics/src/synaptics.c        2011-07-05 11:55:02.771347676 +0300
 
831
@@ -119,7 +119,6 @@
819
832
 static void SynapticsUnInit(InputDriverPtr drv, InputInfoPtr pInfo, int flags);
820
833
 static Bool DeviceControl(DeviceIntPtr, int);
821
834
 static void ReadInput(InputInfoPtr);
823
836
 static int ControlProc(InputInfoPtr, xDeviceCtl*);
824
837
 static int SwitchMode(ClientPtr, DeviceIntPtr, int);
825
838
 static Bool DeviceInit(DeviceIntPtr);
826
 
@@ -1214,7 +1213,7 @@ is_inside_active_area(SynapticsPrivate *
 
839
@@ -1219,7 +1218,7 @@
827
840
     return inside_area;
828
841
 }
829
842
 
832
845
 timerFunc(OsTimerPtr timer, CARD32 now, pointer arg)
833
846
 {
834
847
     InputInfoPtr pInfo = arg;
835
 
@@ -2410,7 +2409,7 @@ repeat_scrollbuttons(const InputInfoPtr
 
848
@@ -2422,7 +2421,7 @@
836
849
  * milliseconds to wait before calling the function again if no state change
837
850
  * occurs.
838
851
  */
841
854
 HandleState(InputInfoPtr pInfo, struct SynapticsHwState *hw)
842
855
 {
843
856
     SynapticsPrivate *priv = (SynapticsPrivate *) (pInfo->private);
844
 
--- a/src/synproto.h
845
 
+++ b/src/synproto.h
846
 
@@ -105,4 +105,7 @@ extern struct SynapticsProtocolOperation
 
857
Index: xserver-xorg-input-synaptics/src/synproto.h
 
858
===================================================================
 
859
--- xserver-xorg-input-synaptics.orig/src/synproto.h    2011-07-05 11:54:55.781347674 +0300
 
860
+++ xserver-xorg-input-synaptics/src/synproto.h 2011-07-05 11:55:02.771347676 +0300
 
861
@@ -105,4 +105,7 @@
847
862
 #endif /* BUILD_PSMCOMM */
848
863
 extern struct SynapticsProtocolOperations alps_proto_operations;
849
864