~ubuntu-branches/ubuntu/precise/csound/precise

« back to all changes in this revision

Viewing changes to debian/patches/0002-link-dssi-dl.patch

  • Committer: Package Import Robot
  • Author(s): Felipe Sateler
  • Date: 2012-04-19 09:26:46 UTC
  • mfrom: (3.2.19 sid)
  • Revision ID: package-import@ubuntu.com-20120419092646-96xbj1n6atuqosk2
Tags: 1:5.17.6~dfsg-1
* New upstream release
 - Do not build the wiimote opcodes (we need wiiuse).
* Add new API function to symbols file
* Disable lua opcodes, they were broken. Requires OpenMP to be enabled.
* Backport fixes from upstream:
  - Link dssi4cs with dl. Backport
  - Fix building of CsoundAC

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
--- a/Opcodes/CMakeLists.txt
 
2
+++ b/Opcodes/CMakeLists.txt
 
3
@@ -69,7 +69,7 @@
 
4
 check_deps(BUILD_DSSI_OPCODES LADSPA_H)
 
5
 if(BUILD_DSSI_OPCODES)
 
6
     set(dssi_SRC dssi4cs/src/load.c dssi4cs/src/dssi4cs.c)
 
7
-    make_plugin(dssi4cs "${dssi_SRC}" )
 
8
+    make_plugin(dssi4cs "${dssi_SRC}" dl)
 
9
 endif()
 
10
 
 
11
 check_deps(BUILD_FLUID_OPCODES FLUIDSYNTH_H)