~ubuntu-branches/ubuntu/precise/d-feet/precise

« back to all changes in this revision

Viewing changes to debian/patches/10_tree_model_crash.patch

  • Committer: Bazaar Package Importer
  • Author(s): Robert Ancell
  • Date: 2010-04-19 13:59:04 UTC
  • Revision ID: james.westby@ubuntu.com-20100419135904-dchlmeva68spz4n9
Tags: 0.1.10-2ubuntu1
* debian/patches/10_tree_model_crash.patch:
  - Fix crash in tree model API usage (LP: #189543)
* debian/rules:
* debian/control:
  - Use quilt

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
## Description: add some description
 
2
## Origin/Author: add some origin or author
 
3
## Bug: bug URL
 
4
Index: d-feet-0.1.10/dfeet/introspect_data.py
 
5
===================================================================
 
6
--- d-feet-0.1.10.orig/dfeet/introspect_data.py 2010-04-19 13:59:03.454051568 +1000
 
7
+++ d-feet-0.1.10/dfeet/introspect_data.py      2010-04-19 13:58:57.724039241 +1000
 
8
@@ -51,6 +51,8 @@
 
9
         return self.child_list.index(child)
 
10
 
 
11
     def on_get_iter(self, path):
 
12
+        if path[0] >= len(self.child_list):
 
13
+            return None
 
14
         op = self.child_list[path[0]]
 
15
         if len(path) == 1:
 
16
             return op