~ubuntu-branches/ubuntu/precise/fcitx-sunpinyin/precise

« back to all changes in this revision

Viewing changes to debian/patches/0001-01-lower_sunpinyin_version.patch.patch

  • Committer: Package Import Robot
  • Author(s): YunQiang Su
  • Date: 2012-02-05 21:23:55 UTC
  • mfrom: (1.1.5 sid)
  • Revision ID: package-import@ubuntu.com-20120205212355-dby0rt6cbdrfdk07
Tags: 0.3.3-1
New upstream release: fcitx 4.2.0. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: IME Packaging Team <pkg-ime-devel@lists.alioth.debian.org>
 
2
Date: Sun, 5 Feb 2012 21:12:25 +0800
 
3
Subject: 01-lower_sunpinyin_version.patch
 
4
 
 
5
===================================================================
 
6
---
 
7
 CMakeLists.txt |    2 +-
 
8
 src/eim.cpp    |    4 +++-
 
9
 2 files changed, 4 insertions(+), 2 deletions(-)
 
10
 
 
11
diff --git a/CMakeLists.txt b/CMakeLists.txt
 
12
index 5ab4779..68f3a44 100644
 
13
--- a/CMakeLists.txt
 
14
+++ b/CMakeLists.txt
 
15
@@ -10,7 +10,7 @@ FIND_PACKAGE(Libintl REQUIRED)
 
16
 FIND_PACKAGE(Gettext REQUIRED)
 
17
 FIND_PACKAGE(Fcitx 4.2.0 REQUIRED)
 
18
 
 
19
-PKG_CHECK_MODULES(SUNPINYIN REQUIRED "sunpinyin-2.0 >= 2.0.4" )
 
20
+PKG_CHECK_MODULES(SUNPINYIN REQUIRED "sunpinyin-2.0 >= 2.0.3" )
 
21
 
 
22
 # uninstall target
 
23
 configure_file(
 
24
diff --git a/src/eim.cpp b/src/eim.cpp
 
25
index d5790f9..605fc32 100644
 
26
--- a/src/eim.cpp
 
27
+++ b/src/eim.cpp
 
28
@@ -400,7 +400,8 @@ void FcitxSunpinyinDestroy (void* arg)
 
29
 
 
30
 INPUT_RETURN_VALUE FcitxSunpinyinDeleteCandidate (FcitxSunpinyin* sunpinyin, FcitxCandidateWord* candWord)
 
31
 {
 
32
-    if (candWord->owner == sunpinyin)
 
33
+/*
 
34
+       if (candWord->owner == sunpinyin)
 
35
     {
 
36
         CCandidateList pcl;
 
37
         sunpinyin->view->getCandidateList(pcl, 0, sunpinyin->candNum);
 
38
@@ -410,6 +411,7 @@ INPUT_RETURN_VALUE FcitxSunpinyinDeleteCandidate (FcitxSunpinyin* sunpinyin, Fci
 
39
         classicView->deleteCandidate(*index, mask);
 
40
         return IRV_DISPLAY_CANDWORDS;
 
41
     }
 
42
+*/
 
43
     return IRV_TO_PROCESS;
 
44
 }
 
45
 
 
46
--