~ubuntu-branches/ubuntu/precise/ffmpeg-debian/precise

« back to all changes in this revision

Viewing changes to debian/patches/i386-fpic-workaround.patch

  • Committer: Bazaar Package Importer
  • Author(s): Reinhard Tartler
  • Date: 2009-07-18 10:55:24 UTC
  • mfrom: (1.1.6 upstream) (0.1.3 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090718105524-joadmuw3zpqxlitc
Tags: 4:0.5+svn20090609-1ubuntu1
* merge from debian. Remaining changes:
  - don't build-depend on libfaad-dev, disabling faad decoder.
  - build arm vfp variant
* update gbp.conf
* move gbp.conf to debian/

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Workaround to get ffmpeg packages built with i386 using -fPIC.
 
2
This disables -fPIC for the problematic files.
 
3
==========================================================================
 
4
--- a/Makefile
 
5
+++ b/Makefile
 
6
@@ -83,6 +83,15 @@
 
7
 
 
8
 VHOOKCFLAGS += $(filter-out -mdynamic-no-pic,$(CFLAGS))
 
9
 
 
10
+# Disable use of -fPIC on problematic files for i386
 
11
+ifeq (,$(findstring i386 i486 i586 i686,$(shell uname -m)))
 
12
+I386CFLAGS += $(filter-out -fPIC -DPIC,$(CFLAGS))
 
13
+libavcodec/x86/dsputil_mmx.o: libavcodec/x86/dsputil_mmx.c
 
14
+       $(CC) $(I386CFLAGS) $(LIBOBJFLAGS) -c -o $@ $<
 
15
+libavcodec/x86/flacdsp_mmx.o: libavcodec/x86/flacdsp_mmx.c
 
16
+       $(CC) $(I386CFLAGS) $(LIBOBJFLAGS) -c -o $@ $<
 
17
+endif
 
18
+
 
19
 BASEHOOKS = fish null watermark
 
20
 ALLHOOKS = $(BASEHOOKS) drawtext imlib2 ppm
 
21
 ALLHOOKS_SRCS = $(addprefix vhook/, $(addsuffix .c, $(ALLHOOKS)))