~ubuntu-branches/ubuntu/precise/firefox/precise-proposed

« back to all changes in this revision

Viewing changes to debian/patches/ubuntu-ua-string-changes.patch

  • Committer: Package Import Robot
  • Author(s): Chris Coulson
  • Date: 2012-01-05 16:43:28 UTC
  • mfrom: (1.1.68)
  • Revision ID: package-import@ubuntu.com-20120105164328-lq9z15wmfv0o4sy6
Tags: 10.0~b3+build2-0ubuntu1
* New upstream release from the beta channel (FIREFOX_10_0b3_BUILD2)

* "Fix" LP: #897794 - some websites expect "X11" to be the first token of
  the platform component in the UA string
  - update debian/patches/ubuntu-ua-string-changes.patch
* Defuzz ubuntu-codes-google.patch

Show diffs side-by-side

added added

removed removed

Lines of Context:
2
2
Author: Chris Coulson <chris.coulson@canonical.com>
3
3
Forwarded: not-needed
4
4
 
5
 
diff -r bd1411e362fb netwerk/protocol/http/Makefile.in
6
 
--- a/netwerk/protocol/http/Makefile.in Fri Oct 07 11:37:04 2011 +0100
7
 
+++ b/netwerk/protocol/http/Makefile.in Wed Oct 12 13:00:13 2011 +0100
8
 
@@ -124,3 +124,7 @@
 
5
Index: mozilla/netwerk/protocol/http/Makefile.in
 
6
===================================================================
 
7
--- mozilla.orig/netwerk/protocol/http/Makefile.in      2012-01-03 02:09:16.000000000 +0000
 
8
+++ mozilla/netwerk/protocol/http/Makefile.in   2012-01-04 00:18:41.514892835 +0000
 
9
@@ -126,3 +126,7 @@
9
10
 include $(topsrcdir)/config/rules.mk
10
11
 
11
12
 DEFINES += -DIMPL_NS_NET
13
14
+ifdef MOZ_UA_VENDOR
14
15
+DEFINES += -DMOZ_UA_VENDOR=\""$(MOZ_UA_VENDOR)"\"
15
16
+endif
16
 
diff -r bd1411e362fb netwerk/protocol/http/nsHttpHandler.cpp
17
 
--- a/netwerk/protocol/http/nsHttpHandler.cpp   Fri Oct 07 11:37:04 2011 +0100
18
 
+++ b/netwerk/protocol/http/nsHttpHandler.cpp   Wed Oct 12 13:00:13 2011 +0100
19
 
@@ -190,6 +190,9 @@
 
17
Index: mozilla/netwerk/protocol/http/nsHttpHandler.cpp
 
18
===================================================================
 
19
--- mozilla.orig/netwerk/protocol/http/nsHttpHandler.cpp        2012-01-03 02:09:17.000000000 +0000
 
20
+++ mozilla/netwerk/protocol/http/nsHttpHandler.cpp     2012-01-04 00:27:56.814882968 +0000
 
21
@@ -193,6 +193,9 @@
20
22
     , mLegacyAppName("Mozilla")
21
23
     , mLegacyAppVersion("5.0")
22
24
     , mProduct("Gecko")
26
28
     , mUserAgentIsDirty(true)
27
29
     , mUseCache(true)
28
30
     , mPromptTempRedirect(true)
29
 
@@ -285,6 +288,9 @@
 
31
@@ -291,6 +294,9 @@
30
32
     LOG(("> misc = %s\n", mMisc.get()));
31
33
     LOG(("> product = %s\n", mProduct.get()));
32
34
     LOG(("> product-sub = %s\n", mProductSub.get()));
36
38
     LOG(("> app-name = %s\n", mAppName.get()));
37
39
     LOG(("> app-version = %s\n", mAppVersion.get()));
38
40
     LOG(("> compat-firefox = %s\n", mCompatFirefox.get()));
39
 
@@ -603,6 +609,9 @@
 
41
@@ -590,6 +596,9 @@
40
42
     // than if we didn't preallocate at all.
41
43
     mUserAgent.SetCapacity(mLegacyAppName.Length() + 
42
44
                            mLegacyAppVersion.Length() + 
46
48
 #ifndef UA_SPARE_PLATFORM
47
49
                            mPlatform.Length() + 
48
50
 #endif
49
 
@@ -613,7 +622,7 @@
 
51
@@ -600,7 +609,7 @@
50
52
                            mAppName.Length() +
51
53
                            mAppVersion.Length() +
52
54
                            mCompatFirefox.Length() +
55
57
 
56
58
     // Application portion
57
59
     mUserAgent.Assign(mLegacyAppName);
58
 
@@ -623,6 +632,10 @@
59
 
 
60
 
     // Application comment
61
 
     mUserAgent += '(';
 
60
@@ -614,6 +623,10 @@
 
61
     mUserAgent += mPlatform;
 
62
     mUserAgent.AppendLiteral("; ");
 
63
 #endif
62
64
+#ifdef MOZ_UA_VENDOR
63
65
+    mUserAgent += mVendor;
64
66
+    mUserAgent.AppendLiteral("; ");
65
67
+#endif
66
 
 #ifndef UA_SPARE_PLATFORM
67
 
     mUserAgent += mPlatform;
 
68
     mUserAgent += mOscpu;
68
69
     mUserAgent.AppendLiteral("; ");
69
 
@@ -661,7 +674,6 @@
 
70
     mUserAgent += mMisc;
 
71
@@ -648,7 +661,6 @@
70
72
 void
71
73
 nsHttpHandler::InitUserAgentComponents()
72
74
 {
74
76
       // Gather platform.
75
77
     mPlatform.AssignLiteral(
76
78
 #if defined(ANDROID)
77
 
diff -r bd1411e362fb netwerk/protocol/http/nsHttpHandler.h
78
 
--- a/netwerk/protocol/http/nsHttpHandler.h     Fri Oct 07 11:37:04 2011 +0100
79
 
+++ b/netwerk/protocol/http/nsHttpHandler.h     Wed Oct 12 13:00:13 2011 +0100
80
 
@@ -305,6 +305,7 @@
 
79
Index: mozilla/netwerk/protocol/http/nsHttpHandler.h
 
80
===================================================================
 
81
--- mozilla.orig/netwerk/protocol/http/nsHttpHandler.h  2012-01-03 02:09:17.000000000 +0000
 
82
+++ mozilla/netwerk/protocol/http/nsHttpHandler.h       2012-01-04 00:18:41.514892835 +0000
 
83
@@ -312,6 +312,7 @@
81
84
     // useragent components
82
85
     nsCString      mLegacyAppName;
83
86
     nsCString      mLegacyAppVersion;