~ubuntu-branches/ubuntu/precise/gccgo-4.7/precise

« back to all changes in this revision

Viewing changes to debian/patches/gcc-driver-extra-langs.diff

  • Committer: Package Import Robot
  • Author(s): Matthias Klose
  • Date: 2012-03-11 19:37:32 UTC
  • Revision ID: package-import@ubuntu.com-20120311193732-ty08ntcphseuouao
Tags: 4.7.0~rc1-0ubuntu1
* Build standalone gccgo-4.7 packages.
* libgo: Work around parse error of struct timex_ on ARM.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
# DP: Add options and specs for languages that are not built from a source
 
2
# DP: (but built from separate sources).
 
3
 
 
4
---
 
5
 gcc/Makefile.in |    4 ++--
 
6
 1 files changed, 2 insertions(+), 2 deletions(-)
 
7
 
 
8
Index: b/src/gcc/Makefile.in
 
9
===================================================================
 
10
--- a/src/gcc/Makefile.in
 
11
+++ b/src/gcc/Makefile.in
 
12
@@ -531,8 +531,8 @@
 
13
                      dg-torture.exp,ieee.exp \
 
14
                      vect.exp,guality.exp,unsorted.exp \
 
15
                      struct-layout-1.exp,stackalign.exp,$(dg_target_exps)
 
16
-lang_opt_files=@lang_opt_files@ $(srcdir)/c-family/c.opt $(srcdir)/common.opt
 
17
-lang_specs_files=@lang_specs_files@
 
18
+lang_opt_files=$(sort @lang_opt_files@ $(srcdir)/c-family/c.opt $(srcdir)/common.opt $(foreach lang,$(subst ada,ada/gcc-interface,$(debian_extra_langs)),$(srcdir)/$(lang)/lang.opt))
 
19
+lang_specs_files=$(sort @lang_specs_files@ $(foreach lang,$(subst ada,ada/gcc-interface,$(debian_extra_langs)),$(srcdir)/$(lang)/lang-specs.h))
 
20
 lang_tree_files=@lang_tree_files@
 
21
 target_cpu_default=@target_cpu_default@
 
22
 OBJC_BOEHM_GC=@objc_boehm_gc@