~ubuntu-branches/ubuntu/precise/ghostscript/precise

« back to all changes in this revision

Viewing changes to debian/patches/1001_dont-crash-when-not-finding-icc-profile.patch

  • Committer: Package Import Robot
  • Author(s): Till Kamppeter
  • Date: 2011-10-17 15:52:31 UTC
  • Revision ID: package-import@ubuntu.com-20111017155231-1033p8albu0mkwye
Tags: 9.04~dfsg-0ubuntu12
* debian/patches/1001_dont-crash-when-not-finding-icc-profile.patch,
  debian/patches/020110923-5688545-fix-setting-the-iccprofilesdir-userparam.patch,
  debian/patches/020110923-7e048c5-dont-crash-when-not-finding-icc-profile.patch:
  Patch got applied upstream, replaced the patch by "official" upstream GIT
  patches. No change in source code.
* debian/control, debian/rules: Build Ghostscript against liblcms instead
  of liblcms1, to fix a crash on Apple-generated EPS figures (both
  standalone or embedded in LaTeX-generated PostScript files, LP: #787067).
* debian/control, debian/rules, debian/libgs__VER__.install.in,
  debian/libgs-dev.install: Stop using d-shlibmove, it is not compatible
  with libcms2.
* debian/symbols.common: Updated. Applied patch which dpkg-gensymbols
  generated for debian/libgs9.symbols to this file.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- a/base/gstrans.c
2
 
+++ b/base/gstrans.c
3
 
@@ -585,6 +585,8 @@
4
 
        go ahead and take care of that now */
5
 
     if (icc_manager->smask_profiles == NULL) {
6
 
         code = gsicc_initialize_iccsmask(icc_manager);
7
 
+        if (code < 0)
8
 
+            return(code);
9
 
     }
10
 
     /* A new soft mask group,  make sure the profiles are set */
11
 
     if_debug0('v', "[v]pushing soft mask color sending\n");
12
 
--- a/Resource/Init/gs_lev2.ps
13
 
+++ b/Resource/Init/gs_lev2.ps
14
 
@@ -639,7 +639,7 @@
15
 
 
16
 
 //systemdict /ICCProfilesDir .knownget {
17
 
   % Set the directory sepcified by the command line option
18
 
-  mark exch /ICCProfilesDir exch .dicttomark .setuserparams
19
 
+  mark exch /ICCProfilesDir exch .dicttomark .setuserparams2
20
 
 } {
21
 
   % First see if the current value is valid so we don't have to guess
22
 
   mark .currentuserparams .dicttomark /ICCProfilesDir get
23
 
@@ -654,7 +654,7 @@
24
 
         .file_name_separator concatstrings
25
 
         dup (default_gray.icc) concatstrings status {
26
 
           pop pop pop pop
27
 
-          mark exch /ICCProfilesDir exch .dicttomark .setuserparams
28
 
+          mark exch /ICCProfilesDir exch .dicttomark .setuserparams2
29
 
           exit
30
 
         } {
31
 
           pop