~ubuntu-branches/ubuntu/precise/gmanedit/precise

« back to all changes in this revision

Viewing changes to debian/patches/file_save_dialog

  • Committer: Bazaar Package Importer
  • Author(s): Ralf Treinen
  • Date: 2011-02-26 22:02:05 UTC
  • mfrom: (7.2.1 sid)
  • Revision ID: james.westby@ubuntu.com-20110226220205-fgawjf4nwhxw8imd
Tags: 0.4.2-4
* Adopt the package (closes: #543840)
* Patch link_with_zlib: fixes FTBFS - thanks a lot to Mathieu
  Trudel-Lapierre for the patch! (closes: #554557)
* debian/rules:
  + use dh_autoreconf since we have patched configure.in.
  + cleanup
  + installation of gmanedit.xpm via dh_install and debian/gmanedit.install
  + use debian/gmanedit as package build directory
  + dh_clean -k => dh_prep
* debhelper compatibility level 8, bump build-dependeny on debhelper.
* Patch typo_in_menu: remove spurious copy of src/interface.c~
* Add patch file_save_dialog: allows to enter file name when saving a
  new man page. Thanks a lot to Mathieu Trudel-Lapierre for the patch!
  (closes: #571681)
* Add patch desktop_utf8: recode desktop file into utf8 (closes: #614141)
* debian/control: added dependency on ${misc:Depends} (needed by debhelper)
* Migrate to source format 3.0 (quilt):
  + use quilt instead of dpatch,
  + remove dpatch from build-dependencies
  + add debian/source/format,
  + no more patching in debian rules
  + simplify names of patches
  + use RFC822 headers in patches.
* Add debian/watch
* Standards-Version 3.9.1 (no change)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Mathieu Trudel-Lapierre <mathieu-tl@ubuntu.com>
 
2
Description: Correctly initialize the file choose with a SAVE action.
 
3
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=571681
 
4
Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+source/gmanedit/+bug/688827
 
5
Forwarded: yes
 
6
Approved: Ralf Treinen <treinen@debian.org>
 
7
 
 
8
--- gmanedit~/src/interface.c   2010-12-10 19:57:44.000000000 -0500
 
9
+++ gmanedit/src/interface.c    2010-12-10 20:05:53.093455001 -0500
 
10
@@ -288,9 +288,9 @@
 
11
 
 
12
   save_file = gtk_file_chooser_dialog_new (_("Gmanedit - Saving file"),
 
13
                                      GTK_WINDOW (parent),
 
14
-                                     GTK_FILE_CHOOSER_ACTION_OPEN,
 
15
+                                     GTK_FILE_CHOOSER_ACTION_SAVE,
 
16
                                      GTK_STOCK_CANCEL, GTK_RESPONSE_CANCEL,
 
17
-                                     GTK_STOCK_OPEN, GTK_RESPONSE_ACCEPT,
 
18
+                                     GTK_STOCK_SAVE, GTK_RESPONSE_ACCEPT,
 
19
                                      NULL);
 
20
   GdkPixbuf *icon_pixbuf = create_image ("gmanedit_icon.png");
 
21
   gtk_window_set_icon (GTK_WINDOW (save_file), icon_pixbuf);