~ubuntu-branches/ubuntu/precise/gnome-do/precise-backports

« back to all changes in this revision

Viewing changes to debian/patches/03_fix_libX11_linkage.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Christopher James Halse Rogers
  • Date: 2008-04-14 21:36:12 UTC
  • mfrom: (0.1.2 lenny) (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20080414213612-j6izjrqjsd4f4ulo
* Initial Debian package (closes: #474022)
* debian/patches/02_use_cli_for_wrapper:
  + Patch upstream's wrapper to call /usr/bin/cli rather than mono
* debian/patches/01_fix_libX11_linkage:
  + Link libdo against libX11; fix undefined symbol warnings.
* debian/patches/03_show_in_all_DEs:
  + Show the launcher in all desktop environments; it's useful in XFCE
  and KDE as well as GNOME.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## 03_fix_libX11_linkage.dpatch by Christopher James Halse Rogers <raof@ubuntu.com>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Explicitly link to libX11 to resolve missing symbols
6
 
## DP: on link.
7
 
 
8
 
@DPATCH@
9
 
diff -urNad gnome-do-0.4.0.1~/libdo/Makefile.in gnome-do-0.4.0.1/libdo/Makefile.in
10
 
--- gnome-do-0.4.0.1~/libdo/Makefile.in 2008-03-18 13:31:06.000000000 +1100
11
 
+++ gnome-do-0.4.0.1/libdo/Makefile.in  2008-03-18 13:57:00.000000000 +1100
12
 
@@ -261,7 +261,7 @@
13
 
        eggaccelerators.c
14
 
 
15
 
 libdo_la_LDFLAGS = -export-dynamic -module -avoid-version
16
 
-libdo_la_LIBADD = $(LIBDO_LIBS)
17
 
+libdo_la_LIBADD = $(LIBDO_LIBS) -lX11
18
 
 all: all-am
19
 
 
20
 
 .SUFFIXES: