~ubuntu-branches/ubuntu/precise/gvfs/precise-proposed

« back to all changes in this revision

Viewing changes to debian/patches/06_no_crash_on_unmount.patch

  • Committer: Package Import Robot
  • Author(s): Martin Pitt
  • Date: 2011-11-17 07:43:33 UTC
  • mfrom: (1.1.77) (33.1.18 experimental)
  • Revision ID: package-import@ubuntu.com-20111117074333-ua4kq03btq4shvb1
Tags: 1.10.1-1ubuntu1
* Merge with Debian experimental. Remaining Ubuntu changes:
  - debian/control.in: Drop libbluray-dev build dependency (in universe).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: gvfs-1.9.5/daemon/gvfsjobunmount.c
2
 
===================================================================
3
 
--- gvfs-1.9.5.orig/daemon/gvfsjobunmount.c     2011-09-19 12:00:11.792248128 -0400
4
 
+++ gvfs-1.9.5/daemon/gvfsjobunmount.c  2011-09-19 12:13:31.592263918 -0400
5
 
@@ -231,6 +231,7 @@
6
 
                           gpointer user_data)
7
 
 {
8
 
   GVfsBackend *backend;
9
 
+  GVfsDaemon *daemon;
10
 
   GVfsJobUnmount *op_job = G_VFS_JOB_UNMOUNT (user_data);
11
 
 
12
 
   g_debug ("unregister_mount_callback, unmount_reply: %p, error: %p\n", unmount_reply, error);
13
 
@@ -239,9 +240,10 @@
14
 
   (*G_VFS_JOB_CLASS (g_vfs_job_unmount_parent_class)->send_reply) (G_VFS_JOB (op_job));
15
 
 
16
 
   /* Unlink job source from daemon */
17
 
+  daemon = g_vfs_backend_get_daemon (backend);
18
 
   g_vfs_job_source_closed (G_VFS_JOB_SOURCE (backend));
19
 
 
20
 
-  g_vfs_daemon_close_active_channels (g_vfs_backend_get_daemon ((backend)));
21
 
+  g_vfs_daemon_close_active_channels (daemon);
22
 
 }
23
 
 
24
 
 /* Might be called on an i/o thread */