~ubuntu-branches/ubuntu/precise/libcgi-formbuilder-perl/precise

« back to all changes in this revision

Viewing changes to debian/patches/020110909~fcd40bf.patch

  • Committer: Package Import Robot
  • Author(s): Jonas Smedegaard
  • Date: 2011-09-11 02:55:17 UTC
  • mfrom: (1.1.6 upstream)
  • Revision ID: package-import@ubuntu.com-20110911025517-nhr6j6fwwc9xc4l1
Tags: 3.06-1
* New upstream release.
* Use CDBS perl-makemaker.mk (not deprecated perlmodule.mk).
  Tighten build-dependency on CDBS.
* Update copyright file:
  + Fix use Comment field (not License-Comments).
  + Quote license names in comments.
* Add patch cherry-picked upstream to fix testsuite.
* Update package relations:
  + Build-depend on and suggest libcgi-ssi-perl.
  + Make suggestions unversioned and drop conflicts: satisfied even in
    oldstable.
  + Maintain all relations using CDBS in rules file.
* Stop preserving cruft no long shipped upstream.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Fix failing template tests due to JS bugfix in 3.06
 
2
Author: Nate Wiger <nate@wiger.org>
 
3
Last-Update: 2011-09-11
 
4
 
 
5
--- a/t/2b-test03.html
 
6
+++ b/t/2b-test03.html
 
7
@@ -24,6 +24,7 @@
 
8
     if (! selected_sex) {
 
9
         alertstr += '- Choose one of the "glass EYE fucker" options\n';
 
10
         invalid++;
 
11
+        invalid_fields.push('sex');
 
12
     }
 
13
 
 
14
     if (invalid > 0 || alertstr != '') {
 
15
--- a/t/2c-test03.html
 
16
+++ b/t/2c-test03.html
 
17
@@ -24,6 +24,7 @@
 
18
     if (! selected_sex) {
 
19
         alertstr += '- Choose one of the "glass EYE fucker" options\n';
 
20
         invalid++;
 
21
+        invalid_fields.push('sex');
 
22
     }
 
23
 
 
24
     if (invalid > 0 || alertstr != '') {
 
25
--- a/t/2d-test03.html
 
26
+++ b/t/2d-test03.html
 
27
@@ -24,6 +24,7 @@
 
28
     if (! selected_sex) {
 
29
         alertstr += '- Choose one of the "glass EYE fucker" options\n';
 
30
         invalid++;
 
31
+        invalid_fields.push('sex');
 
32
     }
 
33
 
 
34
     if (invalid > 0 || alertstr != '') {
 
35
--- a/t/2e-test01.html
 
36
+++ b/t/2e-test01.html
 
37
@@ -26,7 +26,6 @@
 
38
 </script>
 
39
 <p>
 
40
 <form action="TEST" method="get" onsubmit="return validate(this);"><input id="_submitted" name="_submitted" type="hidden" value="1" />
 
41
-<input id="_submit" name="_submit" type="hidden" />
 
42
 Enter your name: <input id="name" name="name" type="text" />
 
43
 FYI, your dress size is 42<br>
 
44
 <input id="_reset" name="_reset" type="reset" value="No esta una button del submito" /> 
 
45
--- a/t/2e-test02.html
 
46
+++ b/t/2e-test02.html
 
47
@@ -4,8 +4,7 @@
 
48
 
 
49
 <p>
 
50
 <form action="TEST" method="get"><input id="_submitted" name="_submitted" type="hidden" value="1" />
 
51
-<input id="_submit" name="_submit" type="hidden" />
 
52
 Enter your name: <input id="name" name="name" size="80" type="text" />
 
53
 FYI, your dress size is 8<br>
 
54
-<input id="_reset" name="_reset" type="reset" value="Start over, boob!" /> <input name="_submit" type="submit" value="Submit" />
 
55
+<input id="_reset" name="_reset" type="reset" value="Start over, boob!" /> <input id="_submit" name="_submit" type="submit" value="Submit" />
 
56
 </form>
 
57
--- a/t/2e-test03.html
 
58
+++ b/t/2e-test03.html
 
59
@@ -38,8 +38,7 @@
 
60
 </script>
 
61
 <p>
 
62
 <form action="TEST" method="get" onsubmit="return validate(this);"><input id="_submitted" name="_submitted" type="hidden" value="1" />
 
63
-<input id="_submit" name="_submit" type="hidden" />
 
64
 Enter your name: <input id="name" name="name" type="text" />
 
65
 FYI, your dress size is (unknown)<br>
 
66
- <input onclick="document.getElementById('_submit').value = this.value;" type="submit" value="Update" /><input onclick="document.getElementById('_submit').value = this.value;" type="submit" value="Delete" />
 
67
+ <input id="_submit" name="_submit" onclick="this.form._submit.value = this.value;" type="submit" value="Update" /><input id="_submit_2" name="_submit" onclick="this.form._submit.value = this.value;" type="submit" value="Delete" />
 
68
 </form>
 
69
--- a/t/2e-test04.html
 
70
+++ b/t/2e-test04.html
 
71
@@ -10,11 +10,10 @@
 
72
 <body>
 
73
 
 
74
 <form action="TEST" method="post"><input id="_submitted" name="_submitted" type="hidden" value="1" />
 
75
-<input id="_submit" name="_submit" type="hidden" />
 
76
   test form page:<br/>
 
77
   <br/>
 
78
   <!-- buttons -->
 
79
-<input name="_submit" type="submit" value="Submit" />
 
80
+<input id="_submit" name="_submit" type="submit" value="Submit" />
 
81
 </form>
 
82
 
 
83
 </body>