~ubuntu-branches/ubuntu/precise/libnss-ldap/precise

« back to all changes in this revision

Viewing changes to debian/patches/00fix-ethers-truncation.patch

  • Committer: Bazaar Package Importer
  • Author(s): Chuck Short
  • Date: 2009-11-06 01:24:42 UTC
  • mfrom: (1.1.8 upstream) (11.1.1 squeeze)
  • Revision ID: james.westby@ubuntu.com-20091106012442-5nynms8vz39j8o6i
Tags: 264-2ubuntu1
* Merge from debian testing, remaining changes:
  + debian/control: update Maintainer field now that in main
  + debian/control: Depends on ldap-auth-config
  + debian/control: Removed Depends on po-debconf and debconf (debconf
    handled by ldap-auth-config now)
  + removed the following files:
    - debian/config
    - debian/libnss-ldap.postinst
    - debian/libnss-ldap.postrm
    - debian/patches/00debian_conf.patch
    - debian/po
    - debian/templates
  + debian/LDAP-Permissions.txt: use /etc/ldap.conf
  + debian/README.Debian: use /etc/ldap.conf
  + debian/rules: don't use --with-ldap-conf-file and --with-ldap-secret-file
  + debian/libnss-ldap.install: removed usr/share/libnss-ldap/ldap.conf
  + debian/libnss-ldap.dirs: removed usr/share/libnss-ldap
  + debian/control: move nscd to Suggests
  + debian/patches/series, debian/patches/00fix-ethers-truncation.patch:
    Fix lookups for hostname by MAC address (http://bugzilla.padl.com/show_bug.cgi?id=388) (LP: #315241)
* Remaining changes from debian unstable for LP: #155947
  + added debian/nssldap-update-ignoreusers which update
    nss_initgroups_ignoreusers in /etc/ldap.conf based on
    nss_initgroups_minimum_uid
  + add manpage for nssldap-update-ignoreusers
  + debian/libnss-ldap.install: added usr/sbin/nssldap-update-ignoreusers
    and usr/share/man/man8/nssldap-update-ignoreusers.8
  + added debian/libnss-ldap.init to call nssldap-update-ignoreusers on
    shutdown
  + debian/rules: install initscript
  + debian/libnss-ldap.dirs: added var/lib/libnss-ldap
  + debian/patches/01_minimum_uid.patch: update ldap.conf and manpage for
    nss_initgroups_ignoreusers and nss_initgroups_minimum_uid updates

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Narup nss_ldap-261.orig/ldap-ethers.c nss_ldap-261/ldap-ethers.c
2
 
--- nss_ldap-261.orig/ldap-ethers.c     2008-07-02 22:32:10.000000000 -0400
3
 
+++ nss_ldap-261/ldap-ethers.c  2009-10-08 14:12:57.000000000 -0400
 
1
diff -Naurp nss_ldap-264.orig/ldap-ethers.c nss_ldap-264/ldap-ethers.c
 
2
--- nss_ldap-264.orig/ldap-ethers.c     2008-10-30 16:50:15.000000000 -0400
 
3
+++ nss_ldap-264/ldap-ethers.c  2009-11-06 15:09:06.293835568 -0500
4
4
@@ -207,12 +207,27 @@ NSS_STATUS
5
5
 _nss_ldap_getntohost_r (struct ether_addr * addr, struct ether * result,
6
6
                        char *buffer, size_t buflen, int *errnop)
34
34
 }
35
35
 #endif
36
36
 
37
 
diff -Narup nss_ldap-261.orig/ldap-schema.c nss_ldap-261/ldap-schema.c
38
 
--- nss_ldap-261.orig/ldap-schema.c     2008-07-02 22:32:10.000000000 -0400
39
 
+++ nss_ldap-261/ldap-schema.c  2009-10-08 14:12:57.000000000 -0400
 
37
diff -Naurp nss_ldap-264.orig/ldap-schema.c nss_ldap-264/ldap-schema.c
 
38
--- nss_ldap-264.orig/ldap-schema.c     2008-10-30 16:50:15.000000000 -0400
 
39
+++ nss_ldap-264/ldap-schema.c  2009-11-06 15:09:06.293835568 -0500
40
40
@@ -154,8 +154,8 @@ _nss_ldap_init_filters ()
41
41
            "(&(%s=%s)(%s=%s))", AT (objectClass), OC (ieee802Device),
42
42
             ATM (LM_ETHERS, cn), "%s");