~ubuntu-branches/ubuntu/precise/lirc/precise

« back to all changes in this revision

Viewing changes to debian/patches/13-warning-cleanup

  • Committer: Bazaar Package Importer
  • Author(s): Mario Limonciello
  • Date: 2009-06-18 01:48:20 UTC
  • mfrom: (1.2.8 upstream)
  • Revision ID: james.westby@ubuntu.com-20090618014820-xd3wmu47cd23ejtc
Tags: 0.8.5-0ubuntu1
* New upstream version. (LP: #383446)
  - Fixes imon support (LP: #283317)
* Refresh the following patches for new version:
  - debian/patches/04_man_pages
  - debian/patches/13-warning-cleanup
  - debian/patches/21_atiusb
  - debian/patches/23_pad2keys
  - debian/patches/28_irrecord_resume_support
  - debian/patches/35_general_deviniput
* debian/control:
  - Add build-depends on libftdi-dev to prevent FTBFS.
* debian/copyright:
  - Update to what debian is shipping.
* debian/modules-source/{lirc-modules-source.conf, Makefile}
  - Don't build cmdir anymore.  It's now a userspace module
* debian/rules:
  - Generate dkms.conf using sed instead.
* debian/patches/12_pvr150_transmit_support:
  - Drop.  Upstream didn't like this patch due to questionable
   copyright, and we aren't properly supporting it anyway.
  - Refresh 20_serial_igor
  - Refresh 26_transmitter_lircd
* debian/lirc-modules-source.README.Debian:
  - Drop, inaccurate now.
* debian/lirc.init.d:
  - Cleanup a useless for loop.

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
## DP: Remove build time debug messages for kernel drivers
6
6
 
7
7
@DPATCH@
8
 
diff -urNad lirc-0.8.3~/drivers/lirc_gpio/lirc_gpio.c lirc-0.8.3/drivers/lirc_gpio/lirc_gpio.c
9
 
--- lirc-0.8.3~/drivers/lirc_gpio/lirc_gpio.c   2008-05-10 16:22:40.000000000 -0500
10
 
+++ lirc-0.8.3/drivers/lirc_gpio/lirc_gpio.c    2008-05-10 16:22:40.000000000 -0500
11
 
@@ -88,12 +88,6 @@
12
 
 static int soft_gap;
13
 
 static int sample_rate = 10;
14
 
 
15
 
-#define dprintk(fmt, args...)                                  \
16
 
-       do {                                                    \
17
 
-               if (debug)                                      \
18
 
-                       printk(KERN_DEBUG fmt, ## args);        \
19
 
-       } while (0)
20
 
-
21
 
 struct rcv_info {
22
 
        int bttv_id;
23
 
        int card_id;
24
 
diff -urNad lirc-0.8.3~/drivers/lirc_it87/lirc_it87.c lirc-0.8.3/drivers/lirc_it87/lirc_it87.c
25
 
--- lirc-0.8.3~/drivers/lirc_it87/lirc_it87.c   2008-01-13 05:13:49.000000000 -0600
26
 
+++ lirc-0.8.3/drivers/lirc_it87/lirc_it87.c    2008-05-10 16:22:40.000000000 -0500
27
 
@@ -366,17 +366,12 @@
28
 
 
29
 
 static int set_use_inc(void *data)
30
 
 {
31
 
-#if WE_DONT_USE_LOCAL_OPEN_CLOSE
32
 
-       MOD_INC_USE_COUNT;
33
 
-#endif
34
 
        return 0;
35
 
 }
36
 
 
37
 
 static void set_use_dec(void *data)
38
 
 {
39
 
-#if WE_DONT_USE_LOCAL_OPEN_CLOSE
40
 
-       MOD_DEC_USE_COUNT;
41
 
-#endif
42
 
+
43
 
 }
44
 
 static struct lirc_plugin plugin = {
45
 
        .name           = LIRC_DRIVER_NAME,
46
 
diff -urNad lirc-0.8.3~/drivers/lirc_serial/lirc_serial.c lirc-0.8.3/drivers/lirc_serial/lirc_serial.c
47
 
--- lirc-0.8.3~/drivers/lirc_serial/lirc_serial.c       2008-04-06 14:03:52.000000000 -0500
48
 
+++ lirc-0.8.3/drivers/lirc_serial/lirc_serial.c        2008-05-10 16:22:40.000000000 -0500
49
 
@@ -63,15 +63,6 @@
 
8
Index: lirc-0.8.5/drivers/lirc_serial/lirc_serial.c
 
9
===================================================================
 
10
--- lirc-0.8.5.orig/drivers/lirc_serial/lirc_serial.c   2009-03-15 04:34:00.000000000 -0500
 
11
+++ lirc-0.8.5/drivers/lirc_serial/lirc_serial.c        2009-06-15 01:04:29.000000000 -0500
 
12
@@ -62,15 +62,6 @@
50
13
 
51
14
 #include <linux/autoconf.h>
52
15
 
62
25
 #include <linux/module.h>
63
26
 #include <linux/errno.h>
64
27
 #include <linux/signal.h>
65
 
diff -urNad lirc-0.8.3~/drivers/lirc_sir/lirc_sir.c lirc-0.8.3/drivers/lirc_sir/lirc_sir.c
66
 
--- lirc-0.8.3~/drivers/lirc_sir/lirc_sir.c     2008-01-13 05:13:50.000000000 -0600
67
 
+++ lirc-0.8.3/drivers/lirc_sir/lirc_sir.c      2008-05-10 16:22:40.000000000 -0500
68
 
@@ -48,15 +48,6 @@
 
28
Index: lirc-0.8.5/drivers/lirc_sir/lirc_sir.c
 
29
===================================================================
 
30
--- lirc-0.8.5.orig/drivers/lirc_sir/lirc_sir.c 2009-03-08 14:13:45.000000000 -0500
 
31
+++ lirc-0.8.5/drivers/lirc_sir/lirc_sir.c      2009-06-15 01:51:45.000000000 -0500
 
32
@@ -46,16 +46,6 @@
 
33
 #endif
69
34
 
70
35
 #include <linux/autoconf.h>
71
 
 
72
 
-#if !defined(LIRC_ON_SA1100) && !defined(CONFIG_SERIAL_MODULE)
 
36
-#if !defined(CONFIG_SERIAL_MODULE)
 
37
-#if !defined(LIRC_ON_SA1100)
73
38
-#warning "******************************************"
74
39
-#warning " Your serial port driver is compiled into "
75
40
-#warning " the kernel. You will have to release the "
77
42
-#warning "    setserial /dev/ttySx uart none        "
78
43
-#warning "******************************************"
79
44
-#endif
80
 
-
81
 
 #include <linux/module.h>
 
45
-#endif
 
46
 
82
47
 #include <linux/sched.h>
83
48
 #include <linux/errno.h>
84
 
@@ -511,17 +502,11 @@
85
 
 
86
 
 static int set_use_inc(void *data)
87
 
 {
88
 
-#if WE_DONT_USE_LOCAL_OPEN_CLOSE
89
 
-       MOD_INC_USE_COUNT;
90
 
-#endif
91
 
        return 0;
92
 
 }
93
 
 
94
 
 static void set_use_dec(void *data)
95
 
 {
96
 
-#if WE_DONT_USE_LOCAL_OPEN_CLOSE
97
 
-       MOD_DEC_USE_COUNT;
98
 
-#endif
99
 
 }
100
 
 static struct lirc_plugin plugin = {
101
 
        .name           = LIRC_DRIVER_NAME,