~ubuntu-branches/ubuntu/precise/lxpanel/precise

« back to all changes in this revision

Viewing changes to debian/patches/redefine-alarm-variable.patch

  • Committer: Package Import Robot
  • Author(s): Julien Lavergne
  • Date: 2012-02-13 23:40:40 UTC
  • mfrom: (1.1.10)
  • Revision ID: package-import@ubuntu.com-20120213234040-w24ouhodotl76yav
Tags: 0.5.8+git20120212-0ubuntu1
* New upstream snapshot
 - Run dialog opens up in the background (LP: #889414)
 - Abiliy to configure task Bar Font (LP: #690662)
 - Volume applet uses wrong icon (LP: #878117)
 - Add ability for lxpanel sound applet to launch a GUI for sound management
   (LP: #692276)
 - lxpanel indicator support can't be configured (LP: #692260)
 - Task Bar (Window List) - Options on 64bit version are different than 32bit
   version (LP: #909127)
* debian/patches
 - indicator-support.patch: Remove, merged upstream.
 - fix_indicator_dir.patch: Remove, merged upstream.
 - fix_position.patch: Remove, merged upstream.
 - missing_glades.patch: Remove, fixed upstream.
 - default-config.patch: Refresh.
 - configure_desktop_number.patch: Refresh.
 - 99_refresh_autotools.patch: Refresh.
* debian/control:
 - Build-depends on libwnck-dev.
* debian/lxpanel.install:
 - Add new plugins.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#http://dep.debian.net/deps/dep3/
2
 
Description: A patch to rename alarm variable already defined in include header.
3
 
 
4
 
Origin: Ubuntu
5
 
Forwarded: https://sourceforge.net/tracker/?func=detail&aid=3007605&group_id=180858&atid=894871
6
 
Author: Julien Lavergne <gilir@ubuntu.com>
7
 
Last-Update: 2010-05-26
8
 
 
9
 
--- lxpanel-0.5.5.orig/src/plugins/batt/batt.c
10
 
+++ lxpanel-0.5.5/src/plugins/batt/batt.c
11
 
@@ -95,15 +95,15 @@ typedef struct {
12
 
 typedef struct {
13
 
     char *command;
14
 
     sem_t *lock;
15
 
-} alarm;
16
 
+} alarmStruct;
17
 
 
18
 
 static void destructor(Plugin *p);
19
 
 static void update_display(lx_battery *lx_b, gboolean repaint);
20
 
 
21
 
-/* alarmProcess takes the address of a dynamically allocated alarm struct (which
22
 
+/* alarmProcess takes the address of a dynamically allocated alarmStruct struct (which
23
 
    it must free). It ensures that alarm commands do not run concurrently. */
24
 
 static void * alarmProcess(void *arg) {
25
 
-    alarm *a = (alarm *) arg;
26
 
+    alarmStruct *a = (alarmStruct *) arg;
27
 
 
28
 
     sem_wait(a->lock);
29
 
     system(a->command);
30
 
@@ -157,7 +157,7 @@ void update_display(lx_battery *lx_b, gb
31
 
        /* Run the alarm command if it isn't already running */
32
 
        if (alarmCanRun) {
33
 
            
34
 
-           alarm *a = (alarm *) malloc(sizeof(alarm));
35
 
+           alarmStruct *a = (alarmStruct *) malloc(sizeof(alarmStruct));
36
 
            a->command = lx_b->alarmCommand;
37
 
            a->lock = &(lx_b->alarmProcessLock);
38