~ubuntu-branches/ubuntu/precise/makedumpfile/precise

« back to all changes in this revision

Viewing changes to debian/patches/build-static-and-dynamic-binaries.patch

  • Committer: Bazaar Package Importer
  • Author(s): John Wright
  • Date: 2010-03-03 17:17:35 UTC
  • mfrom: (1.1.3 upstream) (7.1.2 sid)
  • Revision ID: james.westby@ubuntu.com-20100303171735-vxw4zqii21mcj0a0
Tags: 1.3.5-1
* New upstream version
* Preserve upstream's original makedumpfile.8 in clean target
* kdump-config: Fix a typo
* Switch to the "3.0 (quilt)" source format
  - Remove unneeded Build-Depends on quilt
* Update kdump-tools.README.Debian to reflect that recent kernels
  don't need a crash kernel start address
* Apply patch from Petter Reinholdtsen to fix incorrect dependencies
  in kdump-tools.init (Closes: #569685)
* Indicate support for Linux 2.6.32
  - Although upstream hasn't updated its LATEST_VERSION macro, this
    version works without modification on Linux 2.6.32.  Squelch a
    warning that a 2.6.32 kernel is not supported.
* Backport upstream commit 4a16bd39866093f4949f8e9dc183fa2321bda22d
  - Fix buffer overflow when writing dh->signature

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Build both static and dynamic binaries
 
2
 
 
3
Signed-off-by: John Wright <jsw@debian.org>
 
4
Index: makedumpfile/Makefile
 
5
===================================================================
 
6
--- makedumpfile.orig/Makefile  2009-10-22 00:59:49.000000000 -0600
 
7
+++ makedumpfile/Makefile       2009-10-22 01:00:14.000000000 -0600
 
8
@@ -26,13 +26,16 @@
 
9
 SRC_ARCH = x86.c x86_64.c ia64.c ppc64.c
 
10
 OBJ_ARCH = x86.o x86_64.o ia64.o ppc64.o
 
11
 
 
12
-all: makedumpfile
 
13
+all: makedumpfile makedumpfile-static
 
14
 
 
15
 $(OBJ_ARCH): $(SRC_ARCH)
 
16
        $(CC) $(CFLAGS_ARCH) -c -o ./$@ ./$(@:.o=.c) 
 
17
 
 
18
-makedumpfile: $(SRC) $(OBJ_ARCH)
 
19
+makedumpfile-static: $(SRC) $(OBJ_ARCH)
 
20
        $(CC) $(CFLAGS) $(OBJ_ARCH) -o $@ $< -static -ldw -lelf -lz
 
21
+
 
22
+makedumpfile: $(SRC) $(OBJ_ARCH)
 
23
+       $(CC) $(CFLAGS) $(OBJ_ARCH) -o $@ $< -ldw -lelf -lz
 
24
        echo .TH MAKEDUMPFILE 8 \"$(DATE)\" \"makedumpfile v$(VERSION)\" \"Linux System Administrator\'s Manual\" > temp.8
 
25
        grep -v "^.TH MAKEDUMPFILE 8" makedumpfile.8 >> temp.8
 
26
        mv temp.8 makedumpfile.8
 
27
@@ -40,9 +43,11 @@
 
28
 
 
29
 clean:
 
30
        rm -f $(OBJ) $(OBJ_ARCH) makedumpfile makedumpfile.8.gz
 
31
+       rm -f makedumpfile-static
 
32
 
 
33
 install:
 
34
        install -D -m755 ./makedumpfile ${DESTDIR}/usr/bin/makedumpfile
 
35
+       install -D -m755 ./makedumpfile-static ${DESTDIR}/bin/makedumpfile-static
 
36
        install -D -m755 ./makedumpfile-R.pl ${DESTDIR}/usr/bin/makedumpfile-R.pl
 
37
        install -D -m755 ./makedumpfile.8 ${DESTDIR}/usr/share/man/man8/makedumpfile.8
 
38