~ubuntu-branches/ubuntu/precise/makedumpfile/precise

« back to all changes in this revision

Viewing changes to debian/patches/use-install-in-makefile.patch

  • Committer: Bazaar Package Importer
  • Author(s): John Wright
  • Date: 2010-03-03 17:17:35 UTC
  • mfrom: (1.1.3 upstream) (7.1.2 sid)
  • Revision ID: james.westby@ubuntu.com-20100303171735-vxw4zqii21mcj0a0
Tags: 1.3.5-1
* New upstream version
* Preserve upstream's original makedumpfile.8 in clean target
* kdump-config: Fix a typo
* Switch to the "3.0 (quilt)" source format
  - Remove unneeded Build-Depends on quilt
* Update kdump-tools.README.Debian to reflect that recent kernels
  don't need a crash kernel start address
* Apply patch from Petter Reinholdtsen to fix incorrect dependencies
  in kdump-tools.init (Closes: #569685)
* Indicate support for Linux 2.6.32
  - Although upstream hasn't updated its LATEST_VERSION macro, this
    version works without modification on Linux 2.6.32.  Squelch a
    warning that a 2.6.32 kernel is not supported.
* Backport upstream commit 4a16bd39866093f4949f8e9dc183fa2321bda22d
  - Fix buffer overflow when writing dh->signature

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Use install instead of cp in Makefile
 
2
 
 
3
This patch also changes the install target to copy the uncompressed man
 
4
page, so that dh_compress can compress it according to policy.
 
5
 
 
6
diff --git a/Makefile b/Makefile
 
7
index e6ad925..eae1deb 100644
 
8
--- a/Makefile
 
9
+++ b/Makefile
 
10
@@ -39,7 +39,7 @@ clean:
 
11
        rm -f $(OBJ) $(OBJ_ARCH) makedumpfile makedumpfile.8.gz
 
12
 
 
13
 install:
 
14
-       cp makedumpfile ${DESTDIR}/bin
 
15
-       cp makedumpfile-R.pl ${DESTDIR}/bin
 
16
-       cp makedumpfile.8.gz ${DESTDIR}/usr/share/man/man8
 
17
+       install -D -m755 ./makedumpfile ${DESTDIR}/usr/bin/makedumpfile
 
18
+       install -D -m755 ./makedumpfile-R.pl ${DESTDIR}/usr/bin/makedumpfile-R.pl
 
19
+       install -D -m755 ./makedumpfile.8 ${DESTDIR}/usr/share/man/man8/makedumpfile.8
 
20