~ubuntu-branches/ubuntu/precise/mesa-lts-quantal/precise-updates

« back to all changes in this revision

Viewing changes to debian/patches/13-llvm-config-pick-a-version.diff

  • Committer: Package Import Robot
  • Author(s): Maarten Lankhorst
  • Date: 2012-11-30 20:58:34 UTC
  • Revision ID: package-import@ubuntu.com-20121130205834-0vmupgz9h8w2jioa
Tags: 9.0-0ubuntu1~precise1
Rename package for the LTS point update, and add
replaces/breaks/provides

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Several versions of llvm can coexist in the archive (at the time of this
 
2
writing, 2.9, 3.0 and 3.1), so pick a version. Let's assume the last version
 
3
receives bug fixes quickly, so pick 3.1 for now.
 
4
 
 
5
--- a/configure.ac
 
6
+++ b/configure.ac
 
7
@@ -1632,9 +1632,9 @@
 
8
 fi
 
9
 if test "x$enable_gallium_llvm" = xyes; then
 
10
     if test "x$llvm_prefix" != x; then
 
11
-        AC_PATH_PROG([LLVM_CONFIG], [llvm-config], [no], ["$llvm_prefix/bin"])
 
12
+        AC_PATH_PROG([LLVM_CONFIG], [llvm-config-3.1], [no], ["$llvm_prefix/bin"])
 
13
     else
 
14
-        AC_PATH_PROG([LLVM_CONFIG], [llvm-config], [no])
 
15
+        AC_PATH_PROG([LLVM_CONFIG], [llvm-config-3.1], [no])
 
16
     fi
 
17
 
 
18
     if test "x$LLVM_CONFIG" != xno; then