~ubuntu-branches/ubuntu/precise/net-snmp/precise-security

« back to all changes in this revision

Viewing changes to debian/patches/44_nlist_kvm.patch

  • Committer: Bazaar Package Importer
  • Author(s): Colin Watson
  • Date: 2011-05-10 06:14:05 UTC
  • mfrom: (1.1.15 sid)
  • Revision ID: james.westby@ubuntu.com-20110510061405-xd2cqlxvs59u3uja
Tags: 5.4.3~dfsg-2.2ubuntu1
* Resynchronise with Debian (LP: #780149).  Remaining changes:
  - net-snmp-config: Use bash.
  - Removed multiuser option when calling update-rc.d.
  - debian/snmpd.init: LSBify the init script.
  - debian/patches/52_fix_snmpcmd_1_typo.patch: Adjust a typo in
    snmpcmd.1.
  - debian/snmpd.postinst: Source debconf before doing work.
  - debian/snmp.preinst, debian/snmp.prerm: Kill any/all processes owned
    by snmp user before install/uninstall.
  - Add apport hook.
  - debian/patches/ubuntu-fix-lp-587828.patch: Fix row creation for 64bit
    arches.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- net-snmp-5.4.1~dfsg.orig/configure.in
2
 
+++ net-snmp-5.4.1~dfsg/configure.in
3
 
@@ -2854,6 +2854,9 @@
4
 
 AC_CHECK_FUNC(kvm_getswapinfo, AC_DEFINE(HAVE_KVM_GETSWAPINFO, 1, [Define to 1 if you have the `kvm_getswapinfo' function.]),
5
 
        AC_CHECK_LIB(kvm, kvm_getswapinfo, AC_DEFINE(HAVE_KVM_GETSWAPINFO, 1, [Define to 1 if you have the `kvm_getswapinfo' function.])
6
 
        _libkvm="-lkvm"))
7
 
+AC_CHECK_FUNC(nlist, AC_DEFINE(HAVE_NLIST, 1, [Define to 1 if you have the `nlist' function.]),
8
 
+        AC_CHECK_LIB(kvm, nlist, AC_DEFINE(HAVE_NLIST, 1, [Define to 1 if you have the `nlist' function.])
9
 
+        _libkvm="-lkvm"))
10
 
 if test "x${_libkvm}" != "x"; then
11
 
        AC_DEFINE(HAVE_LIBKVM, 1, [Define to 1 if you have the `kvm' library (-lkvm).])
12
 
        LAGENTLIBS="$LAGENTLIBS ${_libkvm}"
 
1
--- net-snmp-5.4.3~dfsg.orig/configure.in
 
2
+++ net-snmp-5.4.3~dfsg/configure.in
 
3
@@ -2890,6 +2890,9 @@
 
4
        AC_DEFINE(HAVE_LIBKVM, 1, [Define to 1 if you have the `kvm' library (-lkvm).])
 
5
        LAGENTLIBS="$LAGENTLIBS ${_libkvm}"
 
6
 fi
 
7
+AC_CHECK_FUNC(nlist, AC_DEFINE(HAVE_NLIST, 1, [Define to 1 if you have the `nlist' function.]),
 
8
+        AC_CHECK_LIB(bsd, nlist, AC_DEFINE(HAVE_NLIST, 1, [Define to 1 if you have the `nlist' function.])
 
9
+        LAGENTLIBS="$LAGENTLIBS bsd"))
 
10
 
 
11
 # DYNAMIC MODULE SUPPORT
 
12
 AC_CHECK_FUNC(dlopen, AC_DEFINE(HAVE_DLOPEN, 1, [Define to 1 if you have the `dlopen' function.]),