~ubuntu-branches/ubuntu/precise/open-vm-tools/precise

« back to all changes in this revision

Viewing changes to debian/patches/01-kvers.patch

  • Committer: Bazaar Package Importer
  • Author(s): Serge Hallyn
  • Date: 2011-03-31 14:20:05 UTC
  • mfrom: (1.4.3 upstream)
  • Revision ID: james.westby@ubuntu.com-20110331142005-3n9red91p7ogkweo
Tags: 2011.03.28-387002-0ubuntu1
* Merge latest upstream git tag.  This has the unlocked_ioctl change
  needed to fix dkms build failures (LP: #727342)
* Changes in debian/rules:
  - work around a bug in toolbox/Makefile, where install-exec-hook is
    not happening.  This needs to get fixed the right way.
  - don't install 'vmware-user' which seems to no longer exist
  - move /etc/xdg into open-vm-toolbox (which should be done using .install)
* debian/open-vm-tools.init: add 'modprobe [-r] vmblock'. (LP: #332323)
* debian/rules and debian/open-vm-toolbox.lintian-overrides:
  - Make vmware-user-suid-wrapper suid-root (LP: #332323)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
1
Author: Cyril Brulebois <cyril.brulebois@enst-bretagne.fr>
2
2
Description: Replacing uname call with KVERS, overwriting seemed not to work.
3
3
 
4
 
diff -Naurp open-vm-tools.orig/modules/linux/vmblock/Makefile open-vm-tools/modules/linux/vmblock/Makefile
5
 
--- open-vm-tools.orig/modules/linux/vmblock/Makefile   2010-06-18 01:02:36.000000000 +0200
6
 
+++ open-vm-tools/modules/linux/vmblock/Makefile        2010-07-03 20:59:43.128041723 +0200
7
 
@@ -43,7 +43,7 @@ INCLUDE      += -I$(SRCROOT)/shared
8
 
 endif
9
 
 
10
 
 
11
 
-VM_UNAME = $(shell uname -r)
12
 
+VM_UNAME = $(KVERS)
13
 
 
14
 
 # Header directory for the running kernel
15
 
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
16
 
diff -Naurp open-vm-tools.orig/modules/linux/vmci/Makefile open-vm-tools/modules/linux/vmci/Makefile
17
 
--- open-vm-tools.orig/modules/linux/vmci/Makefile      2010-06-18 01:02:36.000000000 +0200
18
 
+++ open-vm-tools/modules/linux/vmci/Makefile   2010-07-03 20:59:46.384042352 +0200
19
 
@@ -43,7 +43,7 @@ INCLUDE      += -I$(SRCROOT)/shared
20
 
 endif
21
 
 
22
 
 
23
 
-VM_UNAME = $(shell uname -r)
24
 
+VM_UNAME = $(KVERS)
25
 
 
26
 
 # Header directory for the running kernel
27
 
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
28
 
diff -Naurp open-vm-tools.orig/modules/linux/vmhgfs/Makefile open-vm-tools/modules/linux/vmhgfs/Makefile
29
 
--- open-vm-tools.orig/modules/linux/vmhgfs/Makefile    2010-06-18 01:02:36.000000000 +0200
30
 
+++ open-vm-tools/modules/linux/vmhgfs/Makefile 2010-07-03 20:59:49.264041335 +0200
31
 
@@ -43,7 +43,7 @@ INCLUDE      += -I$(SRCROOT)/shared
32
 
 endif
33
 
 
34
 
 
35
 
-VM_UNAME = $(shell uname -r)
36
 
+VM_UNAME = $(KVERS)
37
 
 
38
 
 # Header directory for the running kernel
39
 
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
40
 
diff -Naurp open-vm-tools.orig/modules/linux/vmsync/Makefile open-vm-tools/modules/linux/vmsync/Makefile
41
 
--- open-vm-tools.orig/modules/linux/vmsync/Makefile    2010-06-18 01:02:36.000000000 +0200
42
 
+++ open-vm-tools/modules/linux/vmsync/Makefile 2010-07-03 20:59:56.041024330 +0200
43
 
@@ -43,7 +43,7 @@ INCLUDE      += -I$(SRCROOT)/shared
44
 
 endif
45
 
 
46
 
 
47
 
-VM_UNAME = $(shell uname -r)
48
 
+VM_UNAME = $(KVERS)
49
 
 
50
 
 # Header directory for the running kernel
51
 
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
52
 
diff -Naurp open-vm-tools.orig/modules/linux/vmxnet/Makefile open-vm-tools/modules/linux/vmxnet/Makefile
53
 
--- open-vm-tools.orig/modules/linux/vmxnet/Makefile    2010-06-18 01:02:36.000000000 +0200
54
 
+++ open-vm-tools/modules/linux/vmxnet/Makefile 2010-07-03 21:00:00.172042218 +0200
55
 
@@ -43,7 +43,7 @@ INCLUDE      += -I$(SRCROOT)/shared
56
 
 endif
57
 
 
58
 
 
59
 
-VM_UNAME = $(shell uname -r)
60
 
+VM_UNAME = $(KVERS)
61
 
 
62
 
 # Header directory for the running kernel
63
 
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
64
 
diff -Naurp open-vm-tools.orig/modules/linux/vsock/Makefile open-vm-tools/modules/linux/vsock/Makefile
65
 
--- open-vm-tools.orig/modules/linux/vsock/Makefile     2010-06-18 01:02:36.000000000 +0200
66
 
+++ open-vm-tools/modules/linux/vsock/Makefile  2010-07-03 21:00:05.380042340 +0200
67
 
@@ -43,7 +43,7 @@ INCLUDE      += -I$(SRCROOT)/shared
68
 
 endif
69
 
 
70
 
 
71
 
-VM_UNAME = $(shell uname -r)
72
 
+VM_UNAME = $(KVERS)
73
 
 
74
 
 # Header directory for the running kernel
75
 
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
 
4
Index: open-vm-tools-2010.06.16-268169/modules/linux/vmblock/Makefile
 
5
===================================================================
 
6
--- open-vm-tools-2010.06.16-268169.orig/modules/linux/vmblock/Makefile 2011-03-08 17:11:48.701605582 -0600
 
7
+++ open-vm-tools-2010.06.16-268169/modules/linux/vmblock/Makefile      2011-03-08 17:11:50.821605582 -0600
 
8
@@ -43,7 +43,7 @@
 
9
 endif
 
10
 
 
11
 
 
12
-VM_UNAME = $(shell uname -r)
 
13
+VM_UNAME = $(KVERS)
 
14
 
 
15
 # Header directory for the running kernel
 
16
 ifdef LINUXINCLUDE
 
17
Index: open-vm-tools-2010.06.16-268169/modules/linux/vmci/Makefile
 
18
===================================================================
 
19
--- open-vm-tools-2010.06.16-268169.orig/modules/linux/vmci/Makefile    2011-03-08 17:11:48.721605582 -0600
 
20
+++ open-vm-tools-2010.06.16-268169/modules/linux/vmci/Makefile 2011-03-08 17:11:50.841605582 -0600
 
21
@@ -43,7 +43,7 @@
 
22
 endif
 
23
 
 
24
 
 
25
-VM_UNAME = $(shell uname -r)
 
26
+VM_UNAME = $(KVERS)
 
27
 
 
28
 # Header directory for the running kernel
 
29
 ifdef LINUXINCLUDE
 
30
Index: open-vm-tools-2010.06.16-268169/modules/linux/vmhgfs/Makefile
 
31
===================================================================
 
32
--- open-vm-tools-2010.06.16-268169.orig/modules/linux/vmhgfs/Makefile  2011-03-08 17:11:48.741605582 -0600
 
33
+++ open-vm-tools-2010.06.16-268169/modules/linux/vmhgfs/Makefile       2011-03-08 17:11:50.861605582 -0600
 
34
@@ -43,7 +43,7 @@
 
35
 endif
 
36
 
 
37
 
 
38
-VM_UNAME = $(shell uname -r)
 
39
+VM_UNAME = $(KVERS)
 
40
 
 
41
 # Header directory for the running kernel
 
42
 ifdef LINUXINCLUDE
 
43
Index: open-vm-tools-2010.06.16-268169/modules/linux/vmsync/Makefile
 
44
===================================================================
 
45
--- open-vm-tools-2010.06.16-268169.orig/modules/linux/vmsync/Makefile  2011-03-08 17:11:48.761605582 -0600
 
46
+++ open-vm-tools-2010.06.16-268169/modules/linux/vmsync/Makefile       2011-03-08 17:11:50.891605582 -0600
 
47
@@ -43,7 +43,7 @@
 
48
 endif
 
49
 
 
50
 
 
51
-VM_UNAME = $(shell uname -r)
 
52
+VM_UNAME = $(KVERS)
 
53
 
 
54
 # Header directory for the running kernel
 
55
 ifdef LINUXINCLUDE
 
56
Index: open-vm-tools-2010.06.16-268169/modules/linux/vmxnet/Makefile
 
57
===================================================================
 
58
--- open-vm-tools-2010.06.16-268169.orig/modules/linux/vmxnet/Makefile  2011-03-08 17:11:48.781605582 -0600
 
59
+++ open-vm-tools-2010.06.16-268169/modules/linux/vmxnet/Makefile       2011-03-08 17:11:50.931605582 -0600
 
60
@@ -43,7 +43,7 @@
 
61
 endif
 
62
 
 
63
 
 
64
-VM_UNAME = $(shell uname -r)
 
65
+VM_UNAME = $(KVERS)
 
66
 
 
67
 # Header directory for the running kernel
 
68
 ifdef LINUXINCLUDE
 
69
Index: open-vm-tools-2010.06.16-268169/modules/linux/vsock/Makefile
 
70
===================================================================
 
71
--- open-vm-tools-2010.06.16-268169.orig/modules/linux/vsock/Makefile   2011-03-08 17:11:48.811605582 -0600
 
72
+++ open-vm-tools-2010.06.16-268169/modules/linux/vsock/Makefile        2011-03-08 17:11:50.961605582 -0600
 
73
@@ -43,7 +43,7 @@
 
74
 endif
 
75
 
 
76
 
 
77
-VM_UNAME = $(shell uname -r)
 
78
+VM_UNAME = $(KVERS)
 
79
 
 
80
 # Header directory for the running kernel
 
81
 ifdef LINUXINCLUDE