~ubuntu-branches/ubuntu/precise/pd-zexy/precise

« back to all changes in this revision

Viewing changes to debian/patches/bashisms.patch

  • Committer: Bazaar Package Importer
  • Author(s): Luca Falavigna
  • Date: 2008-01-06 14:46:19 UTC
  • Revision ID: james.westby@ubuntu.com-20080106144619-40y77941r0akloqn
Tags: 2.1-1ubuntu1
* debian/patches/bashisms.patch: fix bashisms in makesource.sh
* debian/control: update Maintainer field as per spec

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -Nur pd-zexy-2.1/build-tree/zexy-2.1/src/makesource.sh pd-zexy-2.1.new/build-tree/zexy-2.1/src/makesource.sh
 
2
--- zexy-2.1/src/makesource.sh  2005-06-16 15:26:22.000000000 +0200
 
3
+++ zexy-2.1/src/makesource.sh  2008-01-06 14:45:48.000000000 +0100
 
4
@@ -12,7 +12,7 @@
 
5
 #################################
 
6
 ## functions
 
7
 
 
8
-function head_h() {
 
9
+head_h() {
 
10
  echo "/* zexy-setup autogenerated header-file"
 
11
  echo " * generated by \"$0\""
 
12
  echo " * !! DO NOT MANUALLY EDIT  !!"
 
13
@@ -22,12 +22,12 @@
 
14
  echo "#define Z_ZEXY_H__"
 
15
 }
 
16
 
 
17
-function foot_h() {
 
18
+foot_h() {
 
19
  echo "#endif /* Z_ZEXY_H__ */"
 
20
  echo ""
 
21
 }
 
22
 
 
23
-function head_c() {
 
24
+head_c() {
 
25
  echo "/* zexy-setup autogenerated setup-file"
 
26
  echo " * generated by \"$0\""
 
27
  echo " * !! DO NOT MANUALLY EDIT  !!"
 
28
@@ -39,16 +39,16 @@
 
29
  echo "{"
 
30
 }
 
31
 
 
32
-function foot_c() {
 
33
+foot_c() {
 
34
  echo "}"
 
35
  echo
 
36
 }
 
37
 
 
38
-function head_s() {
 
39
+head_s() {
 
40
   echo "SOURCES = \\"
 
41
 }
 
42
 
 
43
-function foot_s() {
 
44
+foot_s() {
 
45
   echo "       zexy.c"
 
46
   echo
 
47
 }