~ubuntu-branches/ubuntu/precise/puredata/precise

« back to all changes in this revision

Viewing changes to debian/patches/clean_helpbrowser.patch

  • Committer: Bazaar Package Importer
  • Author(s): Paul Brossier, IOhannes m zmölnig, Paul Brossier
  • Date: 2011-05-11 01:03:01 UTC
  • Revision ID: james.westby@ubuntu.com-20110511010301-fem05b1q975xx0gz
Tags: 0.43.0-3
[ IOhannes m zmölnig ]
* debian/patches/kfreebsd_fixes.patch: kFreeBSD build fixes
* debian/rules: simplified arch-dependent build-depends
* debian/rules: use dh_auto_configure, distinguish between linux/non-linux
* debian/patches/audio_oss_cleanup.patch: cleanup ifdef logic in
  s_audio_oss.c
* debian/patches/hurd_fixes.patch: fix hurd compilation
* debian/patches/series: updated
* debian/rules: link with --as-needed
* debian/patches/clean_helpbrowser.patch: cleanup helpbrowser to show files
  after directories
* forwarded patches to upstream
* debian/changelog: shortened changelog-lines to keep lintian happy
* debian/control: Conflict with older versions of puredata (Closes: #625663)

[ Paul Brossier ]
* debian/changelog: write changelog, build and upload package.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: IOhannes m zmölnig
 
2
Description: in the helpbrowser, sort directories before files to ease
 
3
navigation
 
4
Forward: https://sourceforge.net/tracker/?func=detail&atid=478072&aid=3296739&group_id=55736
 
5
--- puredata.orig/tcl/helpbrowser.tcl
 
6
+++ puredata/tcl/helpbrowser.tcl
 
7
@@ -50,9 +50,15 @@
 
8
                              -height 20 -width 23 -exportselection 0 -bd 0]
 
9
        pack $current_listbox [scrollbar "$b-scroll" -command [list $current_listbox yview]] \
 
10
         -side left -fill both -expand 1
 
11
-    foreach item [concat [lsort [concat $libdirlist $helplist]]] {
 
12
-               $current_listbox insert end $item
 
13
-       }
 
14
+    # first show the directories (for easier navigation)
 
15
+    foreach item [lsort  $libdirlist] {
 
16
+        $current_listbox insert end $item
 
17
+    }
 
18
+    # then show the (potentially) long list of patches
 
19
+    foreach item [lsort $helplist] {
 
20
+        $current_listbox insert end $item
 
21
+    }
 
22
 
23
        bind $current_listbox <Button-1> \
 
24
         [list ::helpbrowser::root_navigate %W %x %y]
 
25
     bind $current_listbox <Key-Return> \