~ubuntu-branches/ubuntu/precise/ruby1.9.1/precise-proposed

« back to all changes in this revision

Viewing changes to debian/patches/090729_fix_Makefile_deps.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Lucas Nussbaum
  • Date: 2009-07-30 19:06:31 UTC
  • Revision ID: james.westby@ubuntu.com-20090730190631-3x30w2mtev71ah62
Tags: 1.9.1.243-0ubuntu1
* Upload snapshot from Debian's pkg-ruby SVN repository to karmic.
  SVN revision: 235.
  Likely to be similar to the final package uploaded to Debian.
  Known issues:
  + lintian warnings/errors (nothing important)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 090729_fix_Makefile_deps.dpatch by Lucas Nussbaum <lucas@lucas-nussbaum.net>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: In some cases, during 'make install', ruby1.9 will be removed
 
6
## DP: because make will detect that one of the INSNS targets need to
 
7
## DP: be regenerated.
 
8
## DP: We add a dependency between do-install-nodoc and $(PROGRAM) to
 
9
## DP: rebuild ruby1.9 if it was removed.
 
10
 
 
11
@DPATCH@
 
12
diff -urNad ruby1.9-1.9.1.243~/common.mk ruby1.9-1.9.1.243/common.mk
 
13
--- ruby1.9-1.9.1.243~/common.mk        2009-05-04 14:31:23.000000000 +0200
 
14
+++ ruby1.9-1.9.1.243/common.mk 2009-07-29 16:01:30.000000000 +0200
 
15
@@ -168,7 +168,7 @@
 
16
 
 
17
 install-nodoc: pre-install-nodoc do-install-nodoc post-install-nodoc
 
18
 pre-install-nodoc:: pre-install-local pre-install-ext
 
19
-do-install-nodoc: $(PREP)
 
20
+do-install-nodoc: $(PREP) $(PROGRAM)
 
21
        $(INSTRUBY) --make="$(MAKE)" $(INSTRUBY_ARGS) --mantype="$(MANTYPE)"
 
22
 post-install-nodoc:: post-install-local post-install-ext
 
23