~ubuntu-branches/ubuntu/precise/s3d/precise

« back to all changes in this revision

Viewing changes to debian/patches/100-installable-examples.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sven Eckelmann
  • Date: 2009-07-11 17:00:52 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20090711170052-2lltwp4rr01e6oly
* New upstream release
* debian/control:
  - Reduce debhelper dependency to 5
  - Only depend on xmlto and docbook-xml in Build-Depends-Indep for
    arch all package s3d-doc
* debian/patches:
  - Add 100-installable-examples.patch, make example usable without
    extra headers
  - Remove upstream merged patches 100-hyphen-used-as-minus-sign.patch,
    101-fix-sigbus-on-mips.patch, 102-send-correct-load-over-net.patch,
    103-endian-safe-float.patch, 104-reduce-depends.patch,
    105-s3dfm-pathnames.patch, 106-g3dorientation.patch,
    107-fix-cmake-ftbfs.patch, 108-fix-gpsd-ftbfs.patch,
    109-strip-libs3d-parameters.patch, 110-s3dosm-api06.patch,
    111-xmlto-documentation.patch
* Install examples with libs3d-dev and libs3dw-dev
* Convert debian/copyright to new dep5 version
* Upgraded to policy 3.8.2, no changes required
* Install upstream changelogs

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From e74af0b5d1a1746f2238607c130bba0755dabb0e Mon Sep 17 00:00:00 2001
 
2
From: Sven Eckelmann <sven.eckelmann@gmx.de>
 
3
Date: Sat, 16 May 2009 21:56:54 +0200
 
4
Subject: [PATCH] Make examples compilable without extra example.h
 
5
 
 
6
Signed-off-by: Sven Eckelmann <sven.eckelmann@gmx.de>
 
7
---
 
8
 example/filebrowser.c |    2 +-
 
9
 example/linetest.c    |    2 +-
 
10
 example/modelloader.c |    2 +-
 
11
 example/ptrtest.c     |    2 +-
 
12
 example/s3dclock.c    |    2 +-
 
13
 example/strtest.c     |    2 +-
 
14
 example/widgets.c     |    2 +-
 
15
 example/wiresphere.c  |    2 +-
 
16
 8 files changed, 8 insertions(+), 8 deletions(-)
 
17
 
 
18
diff --git a/example/filebrowser.c b/example/filebrowser.c
 
19
index 04ed506..a63d1cb 100644
 
20
--- a/example/filebrowser.c
 
21
+++ b/example/filebrowser.c
 
22
@@ -33,7 +33,7 @@
 
23
 #include <math.h>  /*  sin(),cos() */
 
24
 #include <time.h> /* nanosleep() */
 
25
 #include <sys/stat.h>
 
26
-#include "example.h" /* S3DUNUSED */
 
27
+#define S3DUNUSED(x) x
 
28
 static struct timespec t = {
 
29
        0, 100*1000*1000
 
30
 }; /* 100 mili seconds */
 
31
diff --git a/example/linetest.c b/example/linetest.c
 
32
index 824c5fc..48a63a9 100644
 
33
--- a/example/linetest.c
 
34
+++ b/example/linetest.c
 
35
@@ -26,7 +26,7 @@
 
36
 #include <s3d.h>
 
37
 #include <stdio.h>  /*  NULL*/
 
38
 #include <unistd.h> /* sleep() */
 
39
-#include "example.h" /* S3DUNUSED */
 
40
+#define S3DUNUSED(x) x
 
41
 static int i;
 
42
 static int o;
 
43
 static void stop(struct s3d_evt *S3DUNUSED(evt))
 
44
diff --git a/example/modelloader.c b/example/modelloader.c
 
45
index 05ffdc1..4f315bb 100644
 
46
--- a/example/modelloader.c
 
47
+++ b/example/modelloader.c
 
48
@@ -27,7 +27,7 @@
 
49
 #include <s3d.h>
 
50
 #include <stdio.h>  /* NULL */
 
51
 #include <time.h> /* nanosleep() */
 
52
-#include "example.h" /* S3DUNUSED */
 
53
+#define S3DUNUSED(x) x
 
54
 static struct timespec t = {
 
55
        0, 100*1000*1000
 
56
 }; /* 100 mili seconds */
 
57
diff --git a/example/ptrtest.c b/example/ptrtest.c
 
58
index 1cae63e..c8eea0f 100644
 
59
--- a/example/ptrtest.c
 
60
+++ b/example/ptrtest.c
 
61
@@ -26,7 +26,7 @@
 
62
 #include <stdio.h>  /*  NULL*/
 
63
 #include <time.h> /* nanosleep() */
 
64
 #include <math.h> /* sin(), cos() */
 
65
-#include "example.h" /* S3DUNUSED */
 
66
+#define S3DUNUSED(x) x
 
67
 static int o;
 
68
 static float asp = 1.0;
 
69
 static float len = 1.0;
 
70
diff --git a/example/s3dclock.c b/example/s3dclock.c
 
71
index e01fce8..0eeae04 100644
 
72
--- a/example/s3dclock.c
 
73
+++ b/example/s3dclock.c
 
74
@@ -26,7 +26,7 @@
 
75
 #include <stdio.h>  /*  NULL, sprintf() */
 
76
 #include <time.h>  /*  nanosleep(), struct tm, time_t...  */
 
77
 #include <string.h>  /*  strlen() */
 
78
-#include "example.h" /* S3DUNUSED */
 
79
+#define S3DUNUSED(x) x
 
80
 static struct timespec t = {
 
81
        0, 100*1000*1000
 
82
 }; /* 100 mili seconds */
 
83
diff --git a/example/strtest.c b/example/strtest.c
 
84
index d5f2f62..8d23f92 100644
 
85
--- a/example/strtest.c
 
86
+++ b/example/strtest.c
 
87
@@ -26,7 +26,7 @@
 
88
 #include <s3d.h>
 
89
 #include <stdio.h>  /*  NULL*/
 
90
 #include <unistd.h> /* sleep() */
 
91
-#include "example.h" /* S3DUNUSED */
 
92
+#define S3DUNUSED(x) x
 
93
 static int o;
 
94
 static void stop(struct s3d_evt *S3DUNUSED(evt))
 
95
 {
 
96
diff --git a/example/widgets.c b/example/widgets.c
 
97
index dda89a3..67ed807 100644
 
98
--- a/example/widgets.c
 
99
+++ b/example/widgets.c
 
100
@@ -30,7 +30,7 @@
 
101
 #include <time.h> /* nanosleep() */
 
102
 #include <stdlib.h> /* free() */
 
103
 #include <string.h> /* strlen() */
 
104
-#include "example.h"
 
105
+#define S3DUNUSED(x) x
 
106
 
 
107
 static s3dw_surface *surface;
 
108
 static s3dw_input *input;
 
109
diff --git a/example/wiresphere.c b/example/wiresphere.c
 
110
index bba80ed..589158a 100644
 
111
--- a/example/wiresphere.c
 
112
+++ b/example/wiresphere.c
 
113
@@ -27,7 +27,7 @@
 
114
 #include <time.h> /* nanosleep()  */
 
115
 #include <math.h> /* M_PI, cos(), sin() */
 
116
 #include <stdlib.h> /* malloc(), free() */
 
117
-#include "example.h" /* S3DUNUSED */
 
118
+#define S3DUNUSED(x) x
 
119
 static struct timespec t = {
 
120
        0, 100*1000*1000
 
121
 }; /* 100 mili seconds */
 
122
-- 
 
123
1.6.3.3
 
124