~ubuntu-branches/ubuntu/precise/spatialite/precise

« back to all changes in this revision

Viewing changes to debian/patches/00-systemlibs.patch

  • Committer: Package Import Robot
  • Author(s): David Paleino, Francesco Paolo Lovergine, David Paleino
  • Date: 2011-11-21 12:10:43 UTC
  • mfrom: (4.1.3 sid)
  • Revision ID: package-import@ubuntu.com-20111121121043-0g14o2uf0r343a82
Tags: 3.0.0~beta20110817-3
[ Francesco Paolo Lovergine ]
* Fixed linking order for sqlite3 in debian patch 00-systemlibs.patch.
  (closes: #638929)

[ David Paleino ]
* Conditionally disable full EPSG initialization (for srs_init.c)
  on powerpc, and document what projections are available on that
  architecture (Closes: #649302)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
From: Francesco Paolo Lovergine <frankie@debian.org>
 
2
Subject: use system-wide libraries
 
3
Origin: vendor
 
4
Forwarded: no
 
5
 
 
6
---
 
7
 libspatialite/Makefile.am             |   14 ++++++--------
 
8
 libspatialite/headers/Makefile.am     |    2 --
 
9
 spatialite-tools/Makefile.am          |   14 +++++---------
 
10
 spatialite-tools/exif_loader.c        |    2 +-
 
11
 spatialite-tools/shapefiles.c         |    2 +-
 
12
 spatialite-tools/shell.c              |    2 +-
 
13
 spatialite-tools/shp_doctor.c         |    2 +-
 
14
 spatialite-tools/spatialite_network.c |    2 +-
 
15
 spatialite-tools/spatialite_osm.c     |    2 +-
 
16
 spatialite-tools/spatialite_tool.c    |    2 +-
 
17
 10 files changed, 18 insertions(+), 26 deletions(-)
 
18
 
 
19
--- spatialite.orig/libspatialite/headers/Makefile.am
 
20
+++ spatialite/libspatialite/headers/Makefile.am
 
21
@@ -4,6 +4,4 @@ nobase_include_HEADERS = \
 
22
        spatialite/gaiaexif.h \
 
23
        spatialite/gaiaaux.h \
 
24
        spatialite/gaiageo.h \
 
25
-       spatialite/sqlite3.h \
 
26
-       spatialite/sqlite3ext.h \
 
27
        spatialite/spatialite.h
 
28
--- spatialite.orig/libspatialite/Makefile.am
 
29
+++ spatialite/libspatialite/Makefile.am
 
30
@@ -7,8 +7,7 @@ INCLUDES += @PROJ_INCLUDE@ @GEOS_INCLUDE
 
31
 
 
32
 lib_LTLIBRARIES = libspatialite.la
 
33
 
 
34
-libspatialite_la_SOURCES = spatialite.c \
 
35
-       sqlite3.c
 
36
+libspatialite_la_SOURCES = spatialite.c
 
37
 
 
38
 if MINGW
 
39
 libspatialite_la_LDFLAGS = -version-info 2:4:0 -no-undefined
 
40
@@ -26,16 +25,15 @@ libspatialite_la_LIBADD = \
 
41
        @PROJ_LIB_LA@ \
 
42
        -liconv -lm -lstdc++ -lpthread -ldl
 
43
 else
 
44
-libspatialite_la_LDFLAGS = -version-info 2:4:0
 
45
-libspatialite_la_LIBADD = \
 
46
-       @GEOS_LIB_CLA@ \
 
47
-       @GEOS_LIB_LA@ \
 
48
-       @PROJ_LIB_LA@ \
 
49
+# Fixed SONAME to avoid not proper bumping.
 
50
+libspatialite_la_LDFLAGS = -lsqlite3 -version-info 3:0:1
 
51
+libspatialite_la_LIBADD = -lsqlite3 \
 
52
+       -lgeos_c -lgeos -lproj \
 
53
        -lm -lstdc++ -lpthread -ldl
 
54
 endif
 
55
 endif
 
56
 
 
57
-AUTOMAKE_OPTIONS = dist-zip
 
58
+AUTOMAKE_OPTIONS = dist-zip foreign
 
59
 
 
60
 EXTRA_DIST = makefile.vc nmake.opt libspatialite.def
 
61
 
 
62
--- spatialite.orig/spatialite-tools/exif_loader.c
 
63
+++ spatialite/spatialite-tools/exif_loader.c
 
64
@@ -40,7 +40,7 @@
 
65
 #include <dirent.h>
 
66
 #endif
 
67
 
 
68
-#include <spatialite/sqlite3.h>
 
69
+#include <sqlite3.h>
 
70
 #include <spatialite/gaiaexif.h>
 
71
 #include <spatialite/gaiageo.h>
 
72
 #include <spatialite.h>
 
73
--- spatialite.orig/spatialite-tools/Makefile.am
 
74
+++ spatialite/spatialite-tools/Makefile.am
 
75
@@ -45,21 +45,17 @@ LDADD = @SPATIALITE_LIB@ \
 
76
        @PROJ_LIB@ \
 
77
        -lm -liconv -lstdc++ -lpthread -ldl
 
78
 else
 
79
-spatialite_LDADD = @SPATIALITE_LIB@ \
 
80
-       @GEOS_LIB_C@ \
 
81
-       @GEOS_LIB@ \
 
82
-       @PROJ_LIB@ \
 
83
+spatialite_LDADD = @SPATIALITE_LIB@ -lsqlite3 \
 
84
+       -lgeos_c -lgeos -lproj \
 
85
        -lm -lstdc++ -lpthread -ldl \
 
86
        @READLINE_LIBS@
 
87
-LDADD = @SPATIALITE_LIB@ \
 
88
-       @GEOS_LIB_C@ \
 
89
-       @GEOS_LIB@ \
 
90
-       @PROJ_LIB@ \
 
91
+LDADD = @SPATIALITE_LIB@ -lsqlite3 \
 
92
+       -lgeos_c -lgeos -lproj \
 
93
        -lm -lstdc++ -lpthread -ldl
 
94
 endif
 
95
 endif
 
96
 
 
97
 EXTRA_DIST = makefile.vc nmake.opt
 
98
 
 
99
-AUTOMAKE_OPTIONS = dist-zip
 
100
+AUTOMAKE_OPTIONS = dist-zip foreign
 
101
 
 
102
--- spatialite.orig/spatialite-tools/shapefiles.c
 
103
+++ spatialite/spatialite-tools/shapefiles.c
 
104
@@ -47,7 +47,7 @@ the terms of any one of the MPL, the GPL
 
105
 #include <stdio.h>
 
106
 #include <string.h>
 
107
 
 
108
-#include <spatialite/sqlite3.h>
 
109
+#include <sqlite3.h>
 
110
 #include <spatialite/gaiaaux.h>
 
111
 #include <spatialite/gaiageo.h>
 
112
 #include <spatialite.h>
 
113
--- spatialite.orig/spatialite-tools/shell.c
 
114
+++ spatialite/spatialite-tools/shell.c
 
115
@@ -38,7 +38,7 @@
 
116
 /* Sandro Furieri 30 May 2008
 
117
 / #include "sqlite3.h"
 
118
 */
 
119
-#include <spatialite/sqlite3.h>
 
120
+#include <sqlite3.h>
 
121
 #include <spatialite.h>
 
122
 #ifdef __MINGW32__
 
123
 #define LIBICONV_STATIC
 
124
--- spatialite.orig/spatialite-tools/shp_doctor.c
 
125
+++ spatialite/spatialite-tools/shp_doctor.c
 
126
@@ -30,7 +30,7 @@
 
127
 #include <float.h>
 
128
 #include <errno.h>
 
129
 
 
130
-#include <spatialite/sqlite3.h>
 
131
+#include <sqlite3.h>
 
132
 #include <spatialite/gaiageo.h>
 
133
 
 
134
 #define ARG_NONE               0
 
135
--- spatialite.orig/spatialite-tools/spatialite_network.c
 
136
+++ spatialite/spatialite-tools/spatialite_network.c
 
137
@@ -29,7 +29,7 @@
 
138
 #include <string.h>
 
139
 #include <float.h>
 
140
 
 
141
-#include <spatialite/sqlite3.h>
 
142
+#include <sqlite3.h>
 
143
 #include <spatialite/gaiageo.h>
 
144
 #include <spatialite.h>
 
145
 
 
146
--- spatialite.orig/spatialite-tools/spatialite_osm.c
 
147
+++ spatialite/spatialite-tools/spatialite_osm.c
 
148
@@ -28,7 +28,7 @@
 
149
 #include <stdio.h>
 
150
 #include <string.h>
 
151
 
 
152
-#include <spatialite/sqlite3.h>
 
153
+#include <sqlite3.h>
 
154
 #include <spatialite/gaiageo.h>
 
155
 #include <spatialite.h>
 
156
 
 
157
--- spatialite.orig/spatialite-tools/spatialite_tool.c
 
158
+++ spatialite/spatialite-tools/spatialite_tool.c
 
159
@@ -29,7 +29,7 @@
 
160
 #include <string.h>
 
161
 #include <errno.h>
 
162
 
 
163
-#include <spatialite/sqlite3.h>
 
164
+#include <sqlite3.h>
 
165
 #include <spatialite/gaiaaux.h>
 
166
 #include <spatialite/gaiageo.h>
 
167
 #include <spatialite.h>