~ubuntu-branches/ubuntu/precise/sup/precise

« back to all changes in this revision

Viewing changes to debian/patches/03_shadow.patch

  • Committer: Bazaar Package Importer
  • Author(s): Jochen Friedrich
  • Date: 2009-10-20 17:18:49 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20091020171849-76d7gzmhnvns6jof
Tags: 20091019-1
* Update to new upstream snapshot.
* Convert to debhelper 7 and quilt.
* Fix compile on GNU/kFreeBSD. (Closes: #403816)
* Add patch to fix man pages.
* Bumped standards version to 3.8.3.
* Update Makefile patch to not strip any binaries. (Closes: #438074)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- sup-20060803.orig/Makefile  2006-08-04 13:12:59.000000000 +0200
2
 
+++ sup-20060803/Makefile       2006-08-04 13:14:36.000000000 +0200
3
 
@@ -95,7 +95,7 @@
 
1
Index: sup-20091019/Makefile
 
2
===================================================================
 
3
--- sup-20091019.orig/Makefile  2009-10-20 17:24:06.000000000 +0200
 
4
+++ sup-20091019/Makefile       2009-10-20 17:25:53.000000000 +0200
 
5
@@ -105,7 +105,7 @@
4
6
 OSF_LIBS               = -lbsd
5
7
 EXTRALIBS              = libextra.a
6
8
 sup_OFILES             = ${SUPCL} ${SUPS}
9
11
 supfilesrv_LIBS                = libextra.a 
10
12
 supscan_OFILES         = supscan.o stree.o scan.o
11
13
 SOLARIS_LIBS           = -lsocket -lnsl
12
 
--- sup-20060803.orig/wrap_pwd.h
13
 
+++ sup-20060803/wrap_pwd.h
 
14
Index: sup-20091019/wrap_pwd.h
 
15
===================================================================
 
16
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
17
+++ sup-20091019/wrap_pwd.h     2009-10-20 17:25:53.000000000 +0200
14
18
@@ -0,0 +1,16 @@
15
19
+/* wrap_pwd.h: Copyright (C) TOYODA Eizi, 1997
16
20
+ * In the public domain.
28
32
+# endif /* _WRAP_PWD_NO_MACROS */
29
33
+
30
34
+#endif /* _WRAP_PWD_H */
31
 
--- sup-20060803.orig/wrap_pwd.c
32
 
+++ sup-20060803/wrap_pwd.c
 
35
Index: sup-20091019/wrap_pwd.c
 
36
===================================================================
 
37
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
 
38
+++ sup-20091019/wrap_pwd.c     2009-10-20 17:25:53.000000000 +0200
33
39
@@ -0,0 +1,36 @@
34
40
+/* wrap_pwd.c: Copyright (C) TOYODA Eizi, 1997 */
35
41
+/* In the public domain. */
67
73
+      }
68
74
+      return &pw;
69
75
+}
70
 
--- sup-20060803.orig/supfilesrv.c      2006-08-03 18:09:33.000000000 +0200
71
 
+++ sup-20060803/supfilesrv.c   2006-08-04 13:17:42.000000000 +0200
72
 
@@ -219,6 +219,7 @@
 
76
Index: sup-20091019/supfilesrv.c
 
77
===================================================================
 
78
--- sup-20091019.orig/supfilesrv.c      2009-10-20 17:24:24.000000000 +0200
 
79
+++ sup-20091019/supfilesrv.c   2009-10-20 17:25:53.000000000 +0200
 
80
@@ -217,6 +217,7 @@
73
81
 #include <errno.h>
74
82
 #include <setjmp.h>
75
83
 #include <pwd.h>