~ubuntu-branches/ubuntu/precise/thunderbird/precise-updates

« back to all changes in this revision

Viewing changes to debian/patches/revert-bmo621446-investigation.patch

  • Committer: Package Import Robot
  • Author(s): Chris Coulson, Chris Coulson, David Planella, Ben Collins
  • Date: 2012-07-13 22:59:01 UTC
  • mfrom: (1.7.13)
  • Revision ID: package-import@ubuntu.com-20120713225901-9txaa5c2kw0ovbjg
Tags: 14.0+build1-0ubuntu0.12.04.1
* New upstream stable release (THUNDERBIRD_14_0_BUILD1)
  - see LP: #1024564 for USN information

[ Chris Coulson <chris.coulson@canonical.com> ]
* Update globalmenu-extension to 3.2.5
  - Fix a crash in uGlobalMenu::RecycleList::~RecycleList()
  - Fix LP: #1010580 - update the window event timestamp when handling
    menu events
* Drop patches fixed upstream
  - remove debian/patches/revert-bmo621446-investigation.patch
  - update debian/patches/series
* Update desktop file translations
  - update debian/thunderbird.desktop.in
* Ensure that additional actions in the desktop file match the fd.o spec
  in precise
  - update debian/thunderbird.desktop.in
  - update debian/rules
* Add application/x-xpinstall to the MimeType field of the desktop file
  - update debian/thunderbird.desktop.in
* Drop almost all mimetypes from the desktop file. Thunderbird won't display
  any of them if you invoke it with files of these types. It will just 
  open a Compose window and add the file as an attachment
  - update debian/thunderbird.desktop.in
* Drop the ability to select between tree/system libraries using a single
  option in debian/rules. It adds additional complexity and was never used
  - update debian/config/mozconfig.in
  - update debian/control.in
  - update debian/thunderbird-dev.links.in
  - update debian/rules
* Shuffle the order of google-breakpad/src/common/dwarf/Makefile.in to fix a
  variable substitution issue, which was causing some objects to be built with
  the wrong compiler flags, resulting in dump_syms crashing (LP: #1002590)
  - add debian/patches/fix-makefile-substitution-bug.patch
* Don't set LD_LIBRARY_PATH in our shell wrapper, and install
  dependentlibs.list instead now
  - update debian/thunderbird.sh.in
  - update debian/thunderbird.install.in
* Drop StartupWMClass from the desktop file now that WM_CLASS is the same
  as the binary name (also fixes LP: #1012158)
  - update debian/thunderbird.desktop.in
  - update debian/rules
* Apport hook improvements:
  - Sort preferences alphabetically in the apport data
  - Treat preferences set in default addons as default prefs so that
    they don't show up in apport data, unless the preference files have
    been modified
  - Support random pref files dropped in to the Thunderbird install folder,
    and preferences from application bundles
  - Fix ordering issues when loading preferences
* Update the Apport blacklist file after dropping thunderbird-bin
  - update debian/apport/blacklist.in

[ David Planella <david.planella@ubuntu.com > ]
* Add Catalan keywords
  - update debian/thunderbird.desktop.in

[ Ben Collins <ben.collins@ubuntu.com> ]
* Cherry pick patch from aurora to use YARR interpreter on ppc
  - update debian/patches/fix-build-failure-without-yarr-jit.patch
  - update debian/patches/series
* Fix ppc build due to new dtoa library
  - add debian/patches/fix-dtoa-build-on-ppc.patch
  - update debian/patches/series

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
# HG changeset patch
2
 
# Parent 28613a5ff81bf1e4fd203655a9db50eea22dd912
3
 
# User Chris Coulson <chris.coulson@canonical.com>
4
 
 
5
 
Index: mozilla/mozilla/netwerk/protocol/http/HttpChannelParent.cpp
6
 
===================================================================
7
 
--- mozilla.orig/mozilla/netwerk/protocol/http/HttpChannelParent.cpp    2012-01-23 02:08:29.000000000 +0000
8
 
+++ mozilla/mozilla/netwerk/protocol/http/HttpChannelParent.cpp 2012-01-23 14:23:35.799182395 +0000
9
 
@@ -57,7 +57,6 @@
10
 
 #include "nsIApplicationCacheService.h"
11
 
 #include "nsIOfflineCacheUpdate.h"
12
 
 #include "nsIRedirectChannelRegistrar.h"
13
 
-#include "prinit.h"
14
 
 
15
 
 namespace mozilla {
16
 
 namespace net {
17
 
@@ -67,9 +66,6 @@
18
 
   , mStoredStatus(0)
19
 
   , mStoredProgress(0)
20
 
   , mStoredProgressMax(0)
21
 
-  , mSentRedirect1Begin(false)
22
 
-  , mSentRedirect1BeginFailed(false)
23
 
-  , mReceivedRedirect2Verify(false)
24
 
 {
25
 
   // Ensure gHttpHandler is initialized: we need the atom table up and running.
26
 
   nsIHttpProtocolHandler* handler;
27
 
@@ -331,11 +327,6 @@
28
 
   return true;
29
 
 }
30
 
 
31
 
-// Bug 621446 investigation, we don't want conditional PR_Aborts bellow to be
32
 
-// merged to a single address.
33
 
-#pragma warning(disable : 4068)
34
 
-#pragma GCC optimize ("O0")
35
 
-
36
 
 bool
37
 
 HttpChannelParent::RecvRedirect2Verify(const nsresult& result, 
38
 
                                        const RequestHeaderTuples& changedHeaders)
39
 
@@ -353,30 +344,11 @@
40
 
     }
41
 
   }
42
 
 
43
 
-  if (!mRedirectCallback) {
44
 
-    // Bug 621446 investigation (optimization turned off above)
45
 
-    if (mReceivedRedirect2Verify)
46
 
-      NS_RUNTIMEABORT("Duplicate fire");
47
 
-    if (mSentRedirect1BeginFailed)
48
 
-      NS_RUNTIMEABORT("Send to child failed");
49
 
-    if (mSentRedirect1Begin && NS_FAILED(result))
50
 
-      NS_RUNTIMEABORT("Redirect failed");
51
 
-    if (mSentRedirect1Begin && NS_SUCCEEDED(result))
52
 
-      NS_RUNTIMEABORT("Redirect succeeded");
53
 
-    if (!mRedirectChannel)
54
 
-      NS_RUNTIMEABORT("Missing redirect channel");
55
 
-  }
56
 
-
57
 
-  mReceivedRedirect2Verify = true;
58
 
-
59
 
   mRedirectCallback->OnRedirectVerifyCallback(result);
60
 
   mRedirectCallback = nsnull;
61
 
   return true;
62
 
 }
63
 
 
64
 
-// Bug 621446 investigation
65
 
-#pragma GCC reset_options
66
 
-
67
 
 bool
68
 
 HttpChannelParent::RecvDocumentChannelCleanup()
69
 
 {
70
 
@@ -588,14 +560,8 @@
71
 
                                    redirectFlags,
72
 
                                    responseHead ? *responseHead
73
 
                                                 : nsHttpResponseHead());
74
 
-  if (!result) {
75
 
-    // Bug 621446 investigation
76
 
-    mSentRedirect1BeginFailed = true;
77
 
+  if (!result)
78
 
     return NS_BINDING_ABORTED;
79
 
-  }
80
 
-
81
 
-  // Bug 621446 investigation
82
 
-  mSentRedirect1Begin = true;
83
 
 
84
 
   // Result is handled in RecvRedirect2Verify above
85
 
 
86
 
Index: mozilla/mozilla/netwerk/protocol/http/HttpChannelParent.h
87
 
===================================================================
88
 
--- mozilla.orig/mozilla/netwerk/protocol/http/HttpChannelParent.h      2012-01-23 02:08:29.000000000 +0000
89
 
+++ mozilla/mozilla/netwerk/protocol/http/HttpChannelParent.h   2012-01-23 14:24:01.663183457 +0000
90
 
@@ -133,10 +133,6 @@
91
 
   nsresult mStoredStatus;
92
 
   PRUint64 mStoredProgress;
93
 
   PRUint64 mStoredProgressMax;
94
 
-
95
 
-  bool mSentRedirect1Begin : 1;
96
 
-  bool mSentRedirect1BeginFailed : 1;
97
 
-  bool mReceivedRedirect2Verify : 1;
98
 
 };
99
 
 
100
 
 } // namespace net